aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
new file mode 100644
index 00000000..f7d0b61b
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
@@ -0,0 +1,26 @@
+require cryptodev-qoriq_${PV}.inc
+
+SUMMARY = "A test suite for /dev/crypto device driver"
+
+DEPENDS = "openssl"
+
+PROVIDES = "cryptodev-tests"
+
+EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" DESTDIR="${D}"'
+
+SRC_URI_append = " \
+file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
+"
+
+do_compile() {
+ oe_runmake testprogs
+}
+
+do_install() {
+ oe_runmake install_tests
+}
+
+FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
+FILES_${PN} = "${bindir}/tests_cryptodev/*"
+
+COMPATIBLE_MACHINE = "(qoriq)"