aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 00000000..ec11097c
--- /dev/null
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1,22 @@
+PACKAGECONFIG_remove_mx5 = "egl gles"
+PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl"
+
+PACKAGECONFIG_remove_mx6 = "egl gles"
+
+# i.MX6SL uses mesa software rendering
+
+PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/egl"
+PROVIDES_remove_mx6q = "virtual/libgl"
+PROVIDES_remove_mx6dl = "virtual/libgl"
+PROVIDES_remove_mx6sx = "virtual/libgl"
+
+USE_VIV_LIBGL = "yes"
+USE_VIV_LIBGL_mx6sl = "no"
+
+# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
+do_install_append_mx6 () {
+ if [ "${USE_VIV_LIBGL}" = "yes" ]; then
+ rm -f ${D}${libdir}/libGL.*
+ fi
+}
+EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}"