aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa')
-rw-r--r--recipes-dpaa/fmc/fmc_git.bb52
-rw-r--r--recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch80
-rw-r--r--recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch49
-rw-r--r--recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb68
4 files changed, 0 insertions, 249 deletions
diff --git a/recipes-dpaa/fmc/fmc_git.bb b/recipes-dpaa/fmc/fmc_git.bb
deleted file mode 100644
index d54b8454..00000000
--- a/recipes-dpaa/fmc/fmc_git.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-DESCRIPTION = "Frame Manager Configuration tool"
-SECTION = "fmc"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=a504ab5a8ff235e67c7301214749346c"
-
-PR = "r2"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git;branch=sdk-v1.9.x"
-SRCREV = "a079d2c844edd85dff85a317a63198e7988bcd09"
-
-DEPENDS = "libxml2 fmlib tclap"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_HOST_qoriq-ppc = ".*"
-COMPATIBLE_HOST ?= "(none)"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = 'FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
- FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
- TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
-EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
- FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
- TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
-
-PARALLEL_MAKE = ""
-
-EXTRA_OEMAKE_PLATFORM ?= ""
-EXTRA_OEMAKE_PLATFORM_b4 = "b4860qds"
-EXTRA_OEMAKE_PLATFORM_t2 = "b4860qds"
-EXTRA_OEMAKE_PLATFORM_t4 = "b4860qds"
-EXTRA_OEMAKE_PLATFORM_t1 = "t1040qds"
-
-do_compile () {
- oe_runmake MACHINE=${EXTRA_OEMAKE_PLATFORM} -C source
-}
-
-do_install () {
- install -d ${D}/${bindir}
- install -m 755 ${S}/source/fmc ${D}/${bindir}/fmc
-
- install -d ${D}/etc/fmc/config
- install -m 644 ${S}/etc/fmc/config/hxs_pdl_v3.xml ${D}/etc/fmc/config
-
- install -d ${D}/${includedir}/fmc
- install ${S}/source/fmc.h ${D}/${includedir}/fmc
-
- install -d ${D}/${libdir}
- install ${S}/source/libfmc.a ${D}/${libdir}
-}
-
-BBCLASSEXTEND = "native"
diff --git a/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch b/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch
deleted file mode 100644
index 9f3d22cc..00000000
--- a/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 2b308217d2811e5d1420d7ce6e18f77a992f52e9 Mon Sep 17 00:00:00 2001
-From: Ting Liu <ting.liu@freescale.com>
-Date: Tue, 22 Dec 2015 13:16:33 +0800
-Subject: [PATCH] fix the inline function definition with gcc 5.x
-
-There are different semantics for inline functions for gcc-5.x compared to
-previous gcc. Fix the following build error:
-| dpa_classif_demo.c:(.text+0xeae): undefined reference to `crc64_hash_function'
-| simple_crypto.c:(.text+0x5b8e): undefined reference to `get_num_of_buffers'
-| simple_crypto.c:(.text+0x5b9a): undefined reference to `get_test_mode'
-| simple_crypto.c:(.text+0x5baa): undefined reference to `get_num_of_cpus'
-| simple_crypto.c:(.text+0x5bb2): undefined reference to `requires_authentication'
-| simple_crypto.c:(.text+0x5bbe): undefined reference to `get_thread_barrier'
-
-Upstream-Status: Pending
-
-Signed-off-by: Ting Liu <ting.liu@freescale.com>
----
- lib/hash_table/fman_crc64_hash_func.h | 2 +-
- src/simple_crypto/include/simple_crypto.h | 10 +++++-----
- src/simple_proto/include/simple_proto.h | 10 +++++-----
- 3 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/lib/hash_table/fman_crc64_hash_func.h b/lib/hash_table/fman_crc64_hash_func.h
-index 5095203..bdcf12b 100644
---- a/lib/hash_table/fman_crc64_hash_func.h
-+++ b/lib/hash_table/fman_crc64_hash_func.h
-@@ -36,7 +36,7 @@
- #include <fsl_fman.h>
-
- /* Hash function used by the hash table based on FMan CRC64 */
--inline uint32_t crc64_hash_function(uint8_t *key, uint32_t size)
-+static inline uint32_t crc64_hash_function(uint8_t *key, uint32_t size)
- {
- uint64_t hashval = 0;
- hashval = fman_crc64_init();
-diff --git a/src/simple_crypto/include/simple_crypto.h b/src/simple_crypto/include/simple_crypto.h
-index bae3460..46ea176 100644
---- a/src/simple_crypto/include/simple_crypto.h
-+++ b/src/simple_crypto/include/simple_crypto.h
-@@ -123,10 +123,10 @@ static int validate_test_set(struct test_param crypto_info);
- void set_crypto_cbs(struct test_cb *crypto_cb, struct test_param crypto_info);
- inline int get_num_of_iterations(void *stuff);
- void set_num_of_iterations(void *stuff, unsigned int itr_num);
--inline int get_num_of_buffers(void *stuff);
--inline enum test_mode get_test_mode(void *stuff);
--inline uint8_t requires_authentication(void *);
--inline long get_num_of_cpus(void);
--inline pthread_barrier_t *get_thread_barrier(void);
-+static inline int get_num_of_buffers(void *stuff);
-+static inline enum test_mode get_test_mode(void *stuff);
-+static inline uint8_t requires_authentication(void *);
-+static inline long get_num_of_cpus(void);
-+static inline pthread_barrier_t *get_thread_barrier(void);
-
- #endif /* __SIMPLE_CRYPTO_H */
-diff --git a/src/simple_proto/include/simple_proto.h b/src/simple_proto/include/simple_proto.h
-index d413e70..ce0e842 100644
---- a/src/simple_proto/include/simple_proto.h
-+++ b/src/simple_proto/include/simple_proto.h
-@@ -83,11 +83,11 @@ struct protocol_info *(*register_protocol[])(void) = {
- static void set_crypto_cbs(struct test_cb *crypto_cb);
- int get_num_of_iterations(void *params);
- void set_num_of_iterations(void *params, unsigned int itr_num);
--inline int get_num_of_buffers(void *params);
--inline enum test_mode get_test_mode(void *params);
--inline uint8_t requires_authentication(void *);
--inline long get_num_of_cpus(void);
--inline pthread_barrier_t *get_thread_barrier(void);
-+static inline int get_num_of_buffers(void *params);
-+static inline enum test_mode get_test_mode(void *params);
-+static inline uint8_t requires_authentication(void *);
-+static inline long get_num_of_cpus(void);
-+static inline pthread_barrier_t *get_thread_barrier(void);
- int register_modules(void);
- void unregister_modules(void);
-
---
-1.9.2
-
diff --git a/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch b/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch
deleted file mode 100644
index c6d35f00..00000000
--- a/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 1e1e8d74db98faed57a5a62788e1226801661e0e Mon Sep 17 00:00:00 2001
-From: Ting Liu <ting.liu@freescale.com>
-Date: Tue, 22 Dec 2015 23:37:49 +0800
-Subject: [PATCH] xfrm_km.c: use in6_* macros from glibc instead of kernel
-
-Both glibc and the kernel have in6_* macros definition. Use the one from glibc.
-Kernel headers will check for previous libc definitions by including
-include/linux/libc-compat.h.
-
-Fix the below build error:
-| [CC] xfrm_km.c (bin:srio_ipsec_offload)
-| In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0,
-| from src/srio_ipsec_offload/xfrm_km.c:46:
-| .../usr/include/netinet/in.h:99:5: error: expected identifier before numeric constant
-| IPPROTO_HOPOPTS = 0, /* IPv6 Hop-by-Hop options. */
-| ^
-| In file included from .../tmp/sysroots/b4860qds-64b/usr/include/netinet/ip.h:24:0,
-| from src/srio_ipsec_offload/xfrm_km.c:52:
-| .../tmp/sysroots/b4860qds-64b/usr/include/netinet/in.h:209:8: error: redefinition of 'struct in6_addr'
-| struct in6_addr
-| ^
-| In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0,
-| from src/srio_ipsec_offload/xfrm_km.c:46:
-| .../tmp/sysroots/b4860qds-64b/usr/include/linux/in6.h:32:8: note: originally defined here
-| struct in6_addr {
-| ^
-
-Upstream-Status: Pending
-
-Signed-off-by: Ting Liu <ting.liu@freescale.com>
----
- src/srio_ipsec_offload/xfrm_km.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/srio_ipsec_offload/xfrm_km.c b/src/srio_ipsec_offload/xfrm_km.c
-index df23fd1..d69aafa 100644
---- a/src/srio_ipsec_offload/xfrm_km.c
-+++ b/src/srio_ipsec_offload/xfrm_km.c
-@@ -42,6 +42,7 @@
- #include <linux/types.h>
- #include <sys/socket.h>
- #include <sys/ioctl.h>
-+#include <netinet/in.h>
- #include <linux/netlink.h>
- #include <linux/xfrm.h>
- #include <sched.h>
---
-1.9.2
-
diff --git a/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb b/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb
deleted file mode 100644
index 1a19d1e8..00000000
--- a/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb
+++ /dev/null
@@ -1,68 +0,0 @@
-DESCRIPTION = "User-Space Data-Path Acceleration Architecture Demo Applications"
-LICENSE = "BSD & GPLv2"
-LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=d2a5d894118910d49993347f3f6e0f1e"
-
-inherit pkgconfig
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS = "libxml2 libedit ncurses readline fmc usdpaa dpa-offload libnl"
-DEPENDS_append_b4860qds = " ipc-ust"
-DEPENDS_append_b4420qds = " ipc-ust"
-
-RDEPENDS_${PN} = "libgcc bash"
-RDEPENDS_${PN}_append_b4860qds = " ipc-ust"
-RDEPENDS_${PN}_append_b4420qds = " ipc-ust"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v1.9.x \
- file://fix-the-inline-function-definition-with-gcc-5.x.patch \
- file://xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch \
-"
-SRCREV = "1d9418af04990289bec72cd43a9385690523fcdb"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"'
-export ARCH="${TARGET_ARCH}"
-
-SOC ?= "P4080"
-SOC_b4 = "B4860"
-SOC_t1 = "T1040"
-SOC_t2 = "T2080"
-SOC_t4 = "T4240"
-SOC_p1023rdb = "P1023"
-
-FMAN_VARIANT ?= "P4080"
-FMAN_VARIANT_b4 = "FMAN_V3H"
-FMAN_VARIANT_t1 = "FMAN_V3L"
-FMAN_VARIANT_t2 = "FMAN_V3H"
-FMAN_VARIANT_t4 = "FMAN_V3H"
-FMAN_VARIANT_p1023rdb = "P1023"
-
-do_compile_prepend () {
- export SOC=${SOC}
- export FMC_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmc"
- export FMLIB_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmd \
- -I ${STAGING_INCDIR}/fmd/Peripherals \
- -I ${STAGING_INCDIR}/fmd/integrations \
- -D${FMAN_VARIANT}"
- export USDPAA_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/usdpaa"
- export DPAOFFLOAD_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/dpa-offload"
- export LIBNL_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/libnl3"
- export LIBNL_EXTRA_LDFLAGS="-lnl-3 -lnl-route-3"
- export LIBXML2_CFLAGS="`pkg-config --cflags libxml-2.0`"
- export LIBXML2_LDFLAGS="`pkg-config --libs --static libxml-2.0`"
- export LIBEDIT_CFLAGS="`pkg-config --cflags libedit`"
- export LIBEDIT_LDFLAGS="`pkg-config --libs --static libedit`"
-}
-
-do_install () {
- export SOC=${SOC}
- oe_runmake install DESTDIR=${D}
-}
-
-PARALLEL_MAKE_pn-${PN} = ""
-FILES_${PN} += "/root/SOURCE_THIS /usr/etc/"
-
-COMPATIBLE_HOST_qoriq-ppc = ".*"
-COMPATIBLE_HOST ?= "(none)"