aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch')
-rw-r--r--recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
new file mode 100644
index 00000000..7497e91d
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
@@ -0,0 +1,30 @@
+From fd826140db0f2a867ef588cccf2e5322cc77126a Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Mon, 19 Jan 2015 16:56:29 -0200
+Subject: [PATCH] Fix build in OpenEmbedded-Core environment
+Organization: O.S. Systems Software LTDA.
+
+Some of the unit-tests were not being built due to differences on how
+the build system behaves when running inside of the OE-Core. This
+fixes those minor issues and increases the number of tests available.
+
+Upstream-Status: Pending
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+
+diff --git a/test/ar3k_bt/Makefile b/test/ar3k_bt/Makefile
+index 92e2901..75d3e78 100755
+--- a/test/ar3k_bt/Makefile
++++ b/test/ar3k_bt/Makefile
+@@ -21,7 +21,7 @@ all: $(OBJS)
+ CFLAGS += -lbluetooth
+
+ $(OBJDIR)/hciattach-ar3k.bin :
+- $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o hciattach-ar3k.bin
++ $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o $(OBJDIR)/hciattach-ar3k.bin
+
+ clean:
+ rm -f *.o hciattach-ar3k.bin
+--
+2.1.4
+