aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.sh2
-rw-r--r--recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb13
2 files changed, 12 insertions, 3 deletions
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.sh b/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.sh
new file mode 100644
index 00000000..8854a877
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.sh
@@ -0,0 +1,2 @@
+export MESA_GL_VERSION_OVERRIDE=2.1
+export ETNA_MESA_DEBUG=nir
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
index 13cdf02d..2a32c448 100644
--- a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
+++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
@@ -4,12 +4,15 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
PACKAGE_ARCH = "${MACHINE_ARCH}"
-SRC_URI = "file://mesa-etnaviv.conf"
+SRC_URI = "\
+ file://mesa-etnaviv.conf \
+ file://mesa-etnaviv.sh \
+"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-do_install() {
+do_install_use-mainline-bsp() {
# MESA global envirronment variables
# systemd
@@ -18,7 +21,11 @@ do_install() {
${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf
fi
- # sysvinit - TODO
+ # sysvinit
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
+ install -D -m 644 ${WORKDIR}/mesa-etnaviv.sh \
+ ${D}${sysconfdir}/profile.d/mesa-etnaviv.sh
+ fi
}
ALLOW_EMPTY_${PN} = "1"