aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/imx-base.inc6
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend3
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf31
3 files changed, 15 insertions, 25 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 16d48da9..a1ab6cc3 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -101,7 +101,11 @@ XSERVER_DRIVER = "xf86-video-fbdev"
XSERVER_DRIVER_imxgpu2d = "xf86-video-imx-vivante"
XSERVER_DRIVER_vf = "xf86-video-modesetting"
XSERVER_DRIVER_append_mx8 = " xf86-video-modesetting"
-XSERVER_DRIVER_use-mainline-bsp = "xf86-video-armada"
+XSERVER_DRIVER_use-mainline-bsp = " \
+ xf86-video-fbdev \
+ xf86-video-modesetting \
+ xserver-xorg-extension-glx \
+"
XSERVER = "xserver-xorg \
xf86-input-evdev \
${XSERVER_DRIVER}"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 76f1bc28..738f02c8 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -20,6 +20,9 @@ PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
# For NXP BSP, GPU drivers don't support dri
PACKAGECONFIG_remove_imxgpu_use-nxp-bsp = "dri"
+# mainline/etnaviv:
+RRECOMMENDS_${PN}-megadriver_append_use-mainline-bsp = " libdrm-etnaviv mesa-etnaviv-env"
+
BACKEND = \
"${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf
index b6f83469..c58ae207 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf
@@ -1,28 +1,11 @@
Section "Device"
- Identifier "Driver0"
- Screen 0
- Driver "armada"
-
-# Support hotplugging displays?
- Option "Hotplug" "TRUE"
-
-# Support hardware cursor if available?
- Option "HWCursor" "TRUE"
-
-# Use GPU acceleration?
- Option "UseGPU" "TRUE"
-
-# Provide Xv interfaces?
- Option "XvAccel" "TRUE"
-
-# Prefer overlay for Xv (TRUE for armada-drm, FALSE for imx-drm)
- Option "XvPreferOverlay" "TRUE"
-
-# Which accelerator module to load (automatically found if commented out)
- Option "AccelModule" "etnadrm_gpu"
- Option "AccelModule" "etnaviv_gpu"
+ Identifier "etnaviv"
+ Driver "modesetting"
+ Option "kmsdev" "/dev/dri/card0"
+ Option "AccelMethod" "glamor"
+EndSection
-# Support DRI2 interfaces?
- Option "DRI" "TRUE"
+Section "ServerFlags"
+ Option "AutoAddGPU" "false"
EndSection