aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
new file mode 100644
index 00000000..557c0493
--- /dev/null
+++ b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
@@ -0,0 +1,23 @@
+FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:"
+
+# Pin systemd revision down for systemd-boot recipe.
+# Patches could not be applied cleanly when systemd in OE is updated,
+# though we don't expect a lot of changes could happen in bootloader.
+# RMC is designed to support a large number of types of boards, so we
+# should do explicit update with validation to prevent regression even
+# resolving conflicts for a new tip could be done in a short time.
+
+# Revision: systemd v232 in OE
+SRCREV_intel-x86-common = "a1e2ef7ec912902d8142e7cb5830cbfb47dba86c"
+
+include systemd-boot/${EFI_PROVIDER}.inc
+
+PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
+
+do_compile_append_intel-x86-common() {
+ oe_runmake linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
+}
+
+do_deploy_append_intel-x86-common() {
+ install ${B}/linux*.efi.stub ${DEPLOYDIR}
+}