aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch14
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch28
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch14
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch16
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch12
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch16
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch8
7 files changed, 47 insertions, 61 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch b/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch
index cc8041e7..2facd39d 100644
--- a/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch
+++ b/recipes-extended/dpdk/dpdk/0001-examples-Fix-maybe-uninitialized-warning.patch
@@ -1,4 +1,4 @@
-From 3924f5df5aca5ba23abbe9a84173280ede8be2dd Mon Sep 17 00:00:00 2001
+From 41ac64efa5050430b73e0f8813dffc7327083273 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 1 Aug 2017 20:18:46 -0700
Subject: [PATCH] examples: Fix maybe-uninitialized warning
@@ -8,16 +8,17 @@ Initialize arrays to 0, makes compiler happy about
error: 'vals[0]' may be used uninitialized in this function [-Werror=maybe-uninitialized]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
examples/qos_sched/args.c | 2 +-
examples/vhost/virtio_net.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/examples/qos_sched/args.c b/examples/qos_sched/args.c
-index 476a0ee..fd601c3 100644
+index 83eee95cc28e..3d2c0fbd6d0a 100644
--- a/examples/qos_sched/args.c
+++ b/examples/qos_sched/args.c
-@@ -241,7 +241,7 @@ static int
+@@ -212,7 +212,7 @@ static int
app_parse_flow_conf(const char *conf_str)
{
int ret;
@@ -27,10 +28,10 @@ index 476a0ee..fd601c3 100644
uint64_t mask;
diff --git a/examples/vhost/virtio_net.c b/examples/vhost/virtio_net.c
-index cc2c3d8..16b5392 100644
+index f6e00674d9af..a4a90704d7b4 100644
--- a/examples/vhost/virtio_net.c
+++ b/examples/vhost/virtio_net.c
-@@ -327,7 +327,7 @@ vs_dequeue_pkts(struct vhost_dev *dev, uint16_t queue_id,
+@@ -293,7 +293,7 @@ vs_dequeue_pkts(struct vhost_dev *dev, uint16_t queue_id,
{
struct vhost_queue *queue;
struct rte_vhost_vring *vr;
@@ -39,6 +40,3 @@ index cc2c3d8..16b5392 100644
uint32_t used_idx;
uint32_t i = 0;
uint16_t free_entries;
---
-2.13.3
-
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch b/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch
index 8786af7c..78283336 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.04-Fix-for-misleading-indentation-error.patch
@@ -1,4 +1,4 @@
-From 8cd0a16af531cca0af6b4f9b729c252b8bdbf8e2 Mon Sep 17 00:00:00 2001
+From e7df50cd214e30741a4594c1fb969baa7574c303 Mon Sep 17 00:00:00 2001
From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
Date: Tue, 5 Jul 2016 00:05:25 +0800
Subject: [PATCH] Fix for misleading indentation error
@@ -7,18 +7,19 @@ fix the indentation of the code to match the block structure. This may cause
build errors if you have -Wall -Werror in your project.
Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
---
lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c | 8 ++++----
lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c b/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c
-index df22470..ba28eba 100644
+index 1934a309cda4..58ed65f062ae 100644
--- a/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c
+++ b/lib/librte_eal/linuxapp/kni/ethtool/igb/e1000_phy.c
-@@ -3302,8 +3302,8 @@ s32 e1000_read_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 *data)
+@@ -3287,8 +3287,8 @@ s32 e1000_read_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 *data)
/* Disable access to mPHY if it was originally disabled */
- if (locked)
+ if (locked) {
ready = e1000_is_mphy_ready(hw);
- if (!ready)
- return -E1000_ERR_PHY;
@@ -26,10 +27,10 @@ index df22470..ba28eba 100644
+ return -E1000_ERR_PHY;
E1000_WRITE_REG(hw, E1000_MPHY_ADDR_CTRL,
E1000_MPHY_DIS_ACCESS);
-
-@@ -3367,8 +3367,8 @@ s32 e1000_write_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 data,
+ }
+@@ -3353,8 +3353,8 @@ s32 e1000_write_phy_reg_mphy(struct e1000_hw *hw, u32 address, u32 data,
/* Disable access to mPHY if it was originally disabled */
- if (locked)
+ if (locked) {
ready = e1000_is_mphy_ready(hw);
- if (!ready)
- return -E1000_ERR_PHY;
@@ -37,20 +38,17 @@ index df22470..ba28eba 100644
+ return -E1000_ERR_PHY;
E1000_WRITE_REG(hw, E1000_MPHY_ADDR_CTRL,
E1000_MPHY_DIS_ACCESS);
-
+ }
diff --git a/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c b/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c
-index 017dfe1..7248a7e 100644
+index 3f15912307ce..90635fc60520 100644
--- a/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c
+++ b/lib/librte_eal/linuxapp/kni/ethtool/ixgbe/ixgbe_82599.c
-@@ -870,7 +870,7 @@ s32 ixgbe_setup_mac_link_82599(struct ixgbe_hw *hw,
- if (speed & IXGBE_LINK_SPEED_10GB_FULL)
+@@ -855,7 +855,7 @@ s32 ixgbe_setup_mac_link_82599(struct ixgbe_hw *hw,
+ if (speed & IXGBE_LINK_SPEED_10GB_FULL) {
if (orig_autoc & IXGBE_AUTOC_KX4_SUPP)
autoc |= IXGBE_AUTOC_KX4_SUPP;
- if ((orig_autoc & IXGBE_AUTOC_KR_SUPP) &&
+ if ((orig_autoc & IXGBE_AUTOC_KR_SUPP) &&
(hw->phy.smart_speed_active == false))
autoc |= IXGBE_AUTOC_KR_SUPP;
- if (speed & IXGBE_LINK_SPEED_1GB_FULL)
---
-1.9.1
-
+ }
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch b/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch
index e446ce44..603bd32c 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.04-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch
@@ -1,4 +1,4 @@
-From 6c8d348190a8cf6c35111913cbf117ca98137e84 Mon Sep 17 00:00:00 2001
+From 0808b30cd00f307f182007d21a8be3a0866ccf83 Mon Sep 17 00:00:00 2001
From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
Date: Fri, 18 Dec 2015 18:30:47 +0800
Subject: [PATCH] dpdk v2.2.0: add RTE_KERNELDIR_OUT to split kernel build
@@ -12,15 +12,16 @@ separate directories for kernel source and kernel artifacts.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
---
mk/rte.module.mk | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/mk/rte.module.mk b/mk/rte.module.mk
-index 53ed4fe..b7a014b 100644
+index 1ada528a00b1..da0538cd5321 100644
--- a/mk/rte.module.mk
+++ b/mk/rte.module.mk
-@@ -77,7 +77,7 @@ build: _postbuild
+@@ -48,7 +48,7 @@ build: _postbuild
# build module
$(MODULE).ko: $(SRCS_LINKS)
@if [ ! -f $(notdir Makefile) ]; then ln -nfs $(SRCDIR)/Makefile . ; fi
@@ -29,7 +30,7 @@ index 53ed4fe..b7a014b 100644
CC="$(KERNELCC)" CROSS_COMPILE=$(CROSS) V=$(if $V,1,0)
# install module in $(RTE_OUTPUT)/kmod
-@@ -88,7 +88,7 @@ $(RTE_OUTPUT)/kmod/$(MODULE).ko: $(MODULE).ko
+@@ -59,7 +59,7 @@ $(RTE_OUTPUT)/kmod/$(MODULE).ko: $(MODULE).ko
# install module
modules_install:
@@ -38,7 +39,7 @@ index 53ed4fe..b7a014b 100644
modules_install
.PHONY: clean
-@@ -98,7 +98,7 @@ clean: _postclean
+@@ -69,7 +69,7 @@ clean: _postclean
.PHONY: doclean
doclean:
@if [ ! -f $(notdir Makefile) ]; then ln -nfs $(SRCDIR)/Makefile . ; fi
@@ -47,6 +48,3 @@ index 53ed4fe..b7a014b 100644
@$(foreach FILE,$(SRCS-y) $(SRCS-n) $(SRCS-),\
if [ -h $(notdir $(FILE)) ]; then rm -f $(notdir $(FILE)) ; fi ;)
@if [ -h $(notdir Makefile) ]; then rm -f $(notdir Makefile) ; fi
---
-1.9.1
-
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch b/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch
index 3719aa78..7a8b035a 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch
@@ -1,4 +1,4 @@
-From f7be643cc62860a986c9e0aec990c90bfc58a941 Mon Sep 17 00:00:00 2001
+From 916378ef5ae45e63d12cc5235b2b59f90514ba25 Mon Sep 17 00:00:00 2001
From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
Date: Fri, 1 Apr 2016 17:31:55 +0800
Subject: [PATCH] dpdk: enable ip_fragmentation in common_base config
@@ -8,26 +8,24 @@ Upstream-Status: Inappropriate [Configuration]
This configuration need to set for ip_fragmentation application.
Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
---
config/common_base | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/config/common_base b/config/common_base
-index abd6a64..90259f0 100644
+index ad03cf43392f..ba5794d6c402 100644
--- a/config/common_base
+++ b/config/common_base
-@@ -442,6 +442,11 @@ CONFIG_RTE_LIBRTE_POWER_DEBUG=n
+@@ -691,6 +691,11 @@ CONFIG_RTE_LIBRTE_POWER=n
+ CONFIG_RTE_LIBRTE_POWER_DEBUG=n
CONFIG_RTE_MAX_LCORE_FREQS=64
- #
++#
+# Compile ip_fragmentation
+#
+CONFIG_RTE_IP_FRAG=y
+
-+#
+ #
# Compile librte_net
#
- CONFIG_RTE_LIBRTE_NET=y
---
-1.9.1
-
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
index a4c47112..18b761c7 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
@@ -1,4 +1,4 @@
-From a33a9e7559b59bc5fb0988af85062436ec4389a4 Mon Sep 17 00:00:00 2001
+From d08d11c8b6fdfe73884d67a94d907000afd136ed Mon Sep 17 00:00:00 2001
From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
Date: Fri, 19 Aug 2016 11:57:49 +0800
Subject: [PATCH] dpdk: add --sysroot option within app makefile
@@ -10,23 +10,21 @@ under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
correctly when we depends on gcc to setup for GNU ld.
Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
---
mk/rte.app.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mk/rte.app.mk b/mk/rte.app.mk
-index eb28e11..296c8c7 100644
+index 3eb41d176d21..9ab6688718db 100644
--- a/mk/rte.app.mk
+++ b/mk/rte.app.mk
-@@ -195,7 +195,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
+@@ -300,7 +300,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
ifeq ($(LINK_USING_CC),1)
- O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(OBJS-y) $(call linkerprefix, \
+ O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(EXTRA_CFLAGS) $(OBJS-y) $(call linkerprefix, \
$(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
- $(MAPFLAGS))
+ $(MAPFLAGS)) $(SYSROOTPATH)
else
O_TO_EXE = $(LD) -o $@ $(OBJS-y) \
$(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
---
-1.9.1
-
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
index fc965fa4..55f0c15f 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
@@ -1,4 +1,4 @@
-From 4cdcb5ea4af9677677a007c4f9b286948123be87 Mon Sep 17 00:00:00 2001
+From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001
From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
Date: Fri, 2 Sep 2016 15:48:52 +0800
Subject: [PATCH] dpdk: fix for parellel make issue
@@ -8,28 +8,29 @@ libraries will be build before, And available at the time of
linking example apps.
Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
---
examples/Makefile | 1 +
examples/ethtool/ethtool-app/Makefile | 1 +
2 files changed, 2 insertions(+)
diff --git a/examples/Makefile b/examples/Makefile
-index 18b41b9..c7c2beb 100644
+index 17ecf7f64cda..2a8e805b85a7 100644
--- a/examples/Makefile
+++ b/examples/Makefile
-@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
+@@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app
DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
DIRS-y += cmdline
DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
+DEPDIRS-y += examples/ethtool/lib
DIRS-y += ethtool
DIRS-y += exception_path
- DIRS-y += helloworld
+ DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd
diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
-index 09c66ad..ec068e6 100644
+index 4cd9efdd574b..d3c709ab2fef 100644
--- a/examples/ethtool/ethtool-app/Makefile
+++ b/examples/ethtool/ethtool-app/Makefile
-@@ -47,6 +47,7 @@ SRCS-y := main.c ethapp.c
+@@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c
CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
CFLAGS += $(WERROR_FLAGS)
@@ -37,6 +38,3 @@ index 09c66ad..ec068e6 100644
LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
LDLIBS += -lrte_ethtool
---
-1.9.1
-
diff --git a/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
index f5171674..05058883 100644
--- a/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
+++ b/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
@@ -1,4 +1,4 @@
-From 363817bf84286fc167e0c3c255a7fd522bf87d8c Mon Sep 17 00:00:00 2001
+From 0be350c3b04d83ea9182f45936ef3219aed5c0c1 Mon Sep 17 00:00:00 2001
From: Shashwat Pandey <shashwatx.p@intel.com>
Date: Mon, 20 Feb 2017 15:46:22 +0800
Subject: [PATCH] dpdk: fix installation warning and issue
@@ -12,12 +12,13 @@ Added excluded files from bin and removing mk and app/dpdk-pmdinfogen files
installation since it is not needed as a part of image.
Signed-off-by: Shashwat Pandey <shashwatx.p@intel.com>
+
---
mk/rte.sdkinstall.mk | 29 ++++++++++++++---------------
1 file changed, 14 insertions(+), 15 deletions(-)
diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk
-index dbac2a2..563954e 100644
+index 4e97feff9fde..42625333a4e2 100644
--- a/mk/rte.sdkinstall.mk
+++ b/mk/rte.sdkinstall.mk
@@ -115,16 +115,17 @@ endif
@@ -76,6 +77,3 @@ index dbac2a2..563954e 100644
$(Q)$(call rte_mkdir, $(DESTDIR)$(datadir))
- $(Q)cp -a $(RTE_SDK)/examples $(DESTDIR)$(datadir)
+ $(Q)cp -r $(RTE_SDK)/examples $(DESTDIR)$(datadir)
---
-1.9.1
-