aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/consul/consul_git.bb5
-rw-r--r--recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch31
2 files changed, 3 insertions, 33 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index b0afa03c..f9fb2367 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -4,14 +4,15 @@ LICENSE = "MPL-2.0 & BSD & Apache-2.0 & BSD-2-Clause & MIT"
LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2c1509760384428817710378"
GO_IMPORT = "github.com/hashicorp/consul"
-SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab"
+SRCREV = "567e41ff6b096a478333c804d5c18264050bc3f8"
SRC_URI = "git://${GO_IMPORT}.git \
file://consul.service \
- file://0001-prepared_query-make-compatible-with-go1.5.patch \
"
S = "${WORKDIR}/git"
+RDEPENDS_${PN}-dev_append = " bash"
+
inherit systemd go
# Besides the hosts specified in goarch, we do not build for mips.
diff --git a/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch b/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
deleted file mode 100644
index 324530b6..00000000
--- a/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From fb11d9e31788c912f94faf8b188278d54dc9a8f1 Mon Sep 17 00:00:00 2001
-From: Bruce Ashfield <bruce.ashfield@windriver.com>
-Date: Wed, 20 Apr 2016 16:34:50 -0400
-Subject: [PATCH] prepared_query: make compatible with go1.5
-
-The copying of a regex is only in go 1.6. We can take the chance of
-lock contention, so we drop the copy and use the regex directly.
-
-Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
----
- src/github.com/hashicorp/consul/consul/prepared_query/template.go | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/github.com/hashicorp/consul/consul/prepared_query/template.go b/src/github.com/hashicorp/consul/consul/prepared_query/template.go
-index 984f0bcf9cc6..1c61910c1526 100644
---- a/src/github.com/hashicorp/consul/consul/prepared_query/template.go
-+++ b/src/github.com/hashicorp/consul/consul/prepared_query/template.go
-@@ -116,8 +116,8 @@ func (ct *CompiledTemplate) Render(name string) (*structs.PreparedQuery, error)
- // from multiple goroutines.
- var matches []string
- if ct.re != nil {
-- re := ct.re.Copy()
-- matches = re.FindStringSubmatch(name)
-+ // re := ct.re.Copy()
-+ matches = ct.re.FindStringSubmatch(name)
- }
-
- // Create a safe match function that can't fail at run time. It will
---
-2.4.0.53.g8440f74
-