aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul/consul_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul/consul_git.bb')
-rw-r--r--recipes-connectivity/consul/consul_git.bb22
1 files changed, 7 insertions, 15 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index 5f865975..a44e0b22 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -1,30 +1,22 @@
DESCRIPTION = "A tool for discovering and configuring services in your infrastructure"
HOMEPAGE = "https://www.consul.io/"
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378"
+LICENSE = "MPL-2.0 & BSD & Apache-2.0 & BSD-2-Clause & MIT"
+LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2c1509760384428817710378"
-PKG_NAME = "github.com/hashicorp/consul"
-SRC_URI = "git://${PKG_NAME}.git \
+GO_IMPORT = "github.com/hashicorp/consul"
+SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab"
+SRC_URI = "git://${GO_IMPORT}.git \
file://consul.service \
file://0001-prepared_query-make-compatible-with-go1.5.patch \
"
-SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab"
-
-CCACHE = ""
-inherit systemd golang
+S = "${WORKDIR}/git"
-INSANE_SKIP_${PN} += "ldflags"
+inherit systemd go
SYSTEMD_SERVICE_${PN} = "consul.service"
SYSTEMD_AUTO_ENABLE_${PN} = "enable"
-export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
-
-#Stops go from installing and testing the package
-do_configure(){
-}
-
do_install_append() {
install -d ${D}/${systemd_unitdir}/system
cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system