aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb b/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
new file mode 100644
index 00000000..e2cf1cd7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "This pytest plugin will allow the Salt Daemons to be used in tests."
+HOMEPAGE = "https://github.com/saltstack/pytest-salt"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+SRCNAME = "pytest-salt"
+SRC_URI = "git://github.com/saltstack/${SRCNAME}.git;branch=master"
+
+SRC_URI[md5sum] = "c598d7db87ea52cdeb067d7596b3b0b1"
+SRC_URI[sha256sum] = "7052459cda9fbdbbfff9a25b24243b0b96cf56835a2c41135d754cc5b65e2494"
+
+SRCREV = "feb5031f80cf84b113ebe69543cdd44b6a373d21"
+S = "${WORKDIR}/git"
+
+inherit setuptools
+
+RDEPENDS_${PN} = " \
+ python-pytest \
+ python-pytest-tempdir \
+ python-pytest-helpers-namespace \
+ python-psutil \
+ "