aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb b/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb
new file mode 100644
index 00000000..336de30e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+HOMEPAGE = "https://github.com/idan/oauthlib"
+SECTION = "devel/python"
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5ba9ce41463615e082609806255bce1b"
+
+PR = "r1"
+
+SRCNAME = "oauthlib"
+SRC_URI = "http://pypi.python.org/packages/source/o/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "3ecba28f991ee58db2aeda8b4e2b56b1"
+SRC_URI[sha256sum] = "0a11ab2311f7a29d0079fe529bde9503fec9a2bdd52db834cf8a284a8c1c52f9"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ python-pip \
+ "
+
+# RDEPENDS_default:
+RDEPENDS_${PN} += " \
+ "
+
+do_install_append() {
+ perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`
+ for f in $perm_files; do
+ chmod 644 "${f}"
+ done
+}
+