aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-connectivity/openssh/openssh_6.7p1.bbappend (renamed from meta-openstack/recipes-connectivity/openssh/openssh_6.6p1.bbappend)0
-rw-r--r--meta-openstack/recipes-containers/lxc/lxc_1.0.7.bbappend (renamed from meta-openstack/recipes-containers/lxc/lxc_1.0.6.bbappend)0
-rw-r--r--meta-openstack/recipes-core/busybox/busybox_1.23.1.bbappend (renamed from meta-openstack/recipes-core/busybox/busybox_1.22.1.bbappend)0
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch105
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch32
-rw-r--r--meta-openstack/recipes-devtools/qemu/qemu_2.2.0.bbappend (renamed from meta-openstack/recipes-devtools/qemu/qemu_2.1.0.bbappend)0
-rw-r--r--meta-openstack/recipes-extended/libvirt/libvirt_1.2.12.bbappend (renamed from meta-openstack/recipes-extended/libvirt/libvirt_1.2.8.bbappend)0
-rw-r--r--meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.1.bbappend (renamed from meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.bbappend)0
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend5
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend9
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_3.17.0.bbappend (renamed from meta-openstack/recipes-support/iproute2/iproute2_3.16.0.bbappend)0
-rw-r--r--meta-openstack/recipes-support/xmlto/xmlto_0.0.26.bbappend (renamed from meta-openstack/recipes-support/xmlto/xmlto_0.0.25.bbappend)0
12 files changed, 9 insertions, 142 deletions
diff --git a/meta-openstack/recipes-connectivity/openssh/openssh_6.6p1.bbappend b/meta-openstack/recipes-connectivity/openssh/openssh_6.7p1.bbappend
index bfc543aa..bfc543aa 100644
--- a/meta-openstack/recipes-connectivity/openssh/openssh_6.6p1.bbappend
+++ b/meta-openstack/recipes-connectivity/openssh/openssh_6.7p1.bbappend
diff --git a/meta-openstack/recipes-containers/lxc/lxc_1.0.6.bbappend b/meta-openstack/recipes-containers/lxc/lxc_1.0.7.bbappend
index 7447c56e..7447c56e 100644
--- a/meta-openstack/recipes-containers/lxc/lxc_1.0.6.bbappend
+++ b/meta-openstack/recipes-containers/lxc/lxc_1.0.7.bbappend
diff --git a/meta-openstack/recipes-core/busybox/busybox_1.22.1.bbappend b/meta-openstack/recipes-core/busybox/busybox_1.23.1.bbappend
index 569bd300..569bd300 100644
--- a/meta-openstack/recipes-core/busybox/busybox_1.22.1.bbappend
+++ b/meta-openstack/recipes-core/busybox/busybox_1.23.1.bbappend
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch
deleted file mode 100644
index 37688d62..00000000
--- a/meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch
+++ /dev/null
@@ -1,105 +0,0 @@
----
- novaclient/client.py | 10 ++++++++++
- novaclient/openstack/common/apiclient/client.py | 10 ++++++++++
- novaclient/v1_1/client.py | 6 ++++++
- novaclient/v3/client.py | 6 ++++++
- 4 files changed, 32 insertions(+)
-
-Index: git/novaclient/client.py
-===================================================================
---- git.orig/novaclient/client.py
-+++ git/novaclient/client.py
-@@ -266,6 +266,7 @@
- self.timeout = None
-
- self.times = [] # [("item", starttime, endtime), ...]
-+ self.times_max_len = 200
-
- self.management_url = self.bypass_url or None
- self.auth_token = auth_token
-@@ -328,6 +329,12 @@
- else:
- return name, value
-
-+ def get_timings_max_len(self):
-+ return self.times_max_len
-+
-+ def set_timings_max_len(self, new_len):
-+ self.times_max_len = new_len
-+
- def http_log_req(self, method, url, kwargs):
- if not self.http_log_debug:
- return
-@@ -441,6 +448,9 @@
- resp, body = self.request(url, method, **kwargs)
- self.times.append(("%s %s" % (method, url),
- start_time, time.time()))
-+ # remove oldest items until we maintain max length
-+ while len(self.times) > self.times_max_len:
-+ del self.times[0]
- return resp, body
-
- def _cs_request(self, url, method, **kwargs):
-Index: git/novaclient/openstack/common/apiclient/client.py
-===================================================================
---- git.orig/novaclient/openstack/common/apiclient/client.py
-+++ git/novaclient/openstack/common/apiclient/client.py
-@@ -92,6 +92,7 @@
- self.user_agent = user_agent or self.user_agent
-
- self.times = [] # [("item", starttime, endtime), ...]
-+ self.times_max_len = 200
- self.timings = timings
-
- # requests within the same session can reuse TCP connections from pool
-@@ -144,6 +145,12 @@
- def reset_timings(self):
- self.times = []
-
-+ def get_timings_max_len(self):
-+ return self.times_max_len
-+
-+ def set_timings_max_len(self, new_len):
-+ self.times_max_len = new_len
-+
- def request(self, method, url, **kwargs):
- """Send an http request with the specified characteristics.
-
-@@ -175,6 +182,9 @@
- if self.timings:
- self.times.append(("%s %s" % (method, url),
- start_time, time.time()))
-+ # remove oldest items until we maintain max length
-+ while len(self.times) > self.times_max_len:
-+ del self.times[0]
- self._http_log_resp(resp)
-
- if resp.status_code >= 400:
-Index: git/novaclient/v1_1/client.py
-===================================================================
---- git.orig/novaclient/v1_1/client.py
-+++ git/novaclient/v1_1/client.py
-@@ -232,3 +232,9 @@
- credentials are wrong.
- """
- self.client.authenticate()
-+
-+ def get_timings_max_len(self):
-+ return self.client.get_timings_max_len()
-+
-+ def set_timings_max_len(self, new_len):
-+ self.client.set_timings_max_len(new_len)
-Index: git/novaclient/v3/client.py
-===================================================================
---- git.orig/novaclient/v3/client.py
-+++ git/novaclient/v3/client.py
-@@ -194,3 +194,9 @@
- credentials are wrong.
- """
- self.client.authenticate()
-+
-+ def get_timings_max_len(self):
-+ return self.client.get_timings_max_len()
-+
-+ def set_timings_max_len(self, new_len):
-+ self.client.set_timings_max_len(new_len)
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch b/meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch
deleted file mode 100644
index 1cee4d0f..00000000
--- a/meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From bdd853d38c7b14088d3e6368e298201c249ab004 Mon Sep 17 00:00:00 2001
-From: Keith Holman <Keith.Holman@windriver.com>
-Date: Fri, 13 Jun 2014 09:54:41 -0400
-Subject: [PATCH] novaclient: specify full path to test certificate
-
-The tests shipped with novaclient assume that the files
-exist at the same location as are appear within the
-source tree. The tests also assume that the test is ran
-from the root of the tree. This causes a test to fail as
-it can't find a test certificate used in one of the
-tests. This patch fixes the affected test by putting in
-an identifier that is replaced with the full path to the
-certificate file.
-
-Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
----
- novaclient/tests/v1_1/test_servers.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: git/novaclient/tests/v1_1/test_servers.py
-===================================================================
---- git.orig/novaclient/tests/v1_1/test_servers.py
-+++ git/novaclient/tests/v1_1/test_servers.py
-@@ -501,7 +501,7 @@
- def test_get_password(self):
- s = self.cs.servers.get(1234)
- self.assertEqual(b'FooBar123',
-- s.get_password('novaclient/tests/idfake.pem'))
-+ s.get_password('%PYTHON_SITEPACKAGES_DIR%/novaclient/tests/idfake.pem'))
- self.assert_called('GET', '/servers/1234/os-server-password')
-
- def test_get_password_without_key(self):
diff --git a/meta-openstack/recipes-devtools/qemu/qemu_2.1.0.bbappend b/meta-openstack/recipes-devtools/qemu/qemu_2.2.0.bbappend
index 1c8c682f..1c8c682f 100644
--- a/meta-openstack/recipes-devtools/qemu/qemu_2.1.0.bbappend
+++ b/meta-openstack/recipes-devtools/qemu/qemu_2.2.0.bbappend
diff --git a/meta-openstack/recipes-extended/libvirt/libvirt_1.2.8.bbappend b/meta-openstack/recipes-extended/libvirt/libvirt_1.2.12.bbappend
index 195633b1..195633b1 100644
--- a/meta-openstack/recipes-extended/libvirt/libvirt_1.2.8.bbappend
+++ b/meta-openstack/recipes-extended/libvirt/libvirt_1.2.12.bbappend
diff --git a/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.bbappend b/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.1.bbappend
index 8da640f5..8da640f5 100644
--- a/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.bbappend
+++ b/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.1.bbappend
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 955716b4..00000000
--- a/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://iscsi-tcp.scc \
- file://enable-iscsi-tcp.cfg \
- "
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend
new file mode 100644
index 00000000..843546c8
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://enable-veth.cfg \
+ file://enable-iscsi-tcp.cfg \
+ file://enable-nbd.cfg \
+ file://enable-rtlink.cfg \
+ file://nf.scc \
+ file://nfs.scc \
+ "
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_3.16.0.bbappend b/meta-openstack/recipes-support/iproute2/iproute2_3.17.0.bbappend
index 89496461..89496461 100644
--- a/meta-openstack/recipes-support/iproute2/iproute2_3.16.0.bbappend
+++ b/meta-openstack/recipes-support/iproute2/iproute2_3.17.0.bbappend
diff --git a/meta-openstack/recipes-support/xmlto/xmlto_0.0.25.bbappend b/meta-openstack/recipes-support/xmlto/xmlto_0.0.26.bbappend
index 7447c56e..7447c56e 100644
--- a/meta-openstack/recipes-support/xmlto/xmlto_0.0.25.bbappend
+++ b/meta-openstack/recipes-support/xmlto/xmlto_0.0.26.bbappend