aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-logutils.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python-logutils_0.3.5.bb18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-logutils.inc b/meta-openstack/recipes-devtools/python/python-logutils.inc
new file mode 100644
index 00000000..87ab631b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-logutils.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Set of handlers for the Python standard library's logging package"
+HOMEPAGE = "https://pypi.python.org/pypi/logutils"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44c35f0b8e2a27a2f33a4e4a5c65d014"
+
+SRC_URI[md5sum] = "fcd2f8e9217bfa0b580f253b35a9d954"
+SRC_URI[sha256sum] = "bc058a25d5c209461f134e1f03cab637d66a7a5ccc12e593db56fbb279899a82"
+
+inherit pypi
+
+# avoid "error: option --single-version-externally-managed not recognized"
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --prefix=${prefix} \
+ --install-lib=${PYTHON_SITEPACKAGES_DIR} \
+ --install-data=${datadir}"
diff --git a/meta-openstack/recipes-devtools/python/python-logutils_0.3.5.bb b/meta-openstack/recipes-devtools/python/python-logutils_0.3.5.bb
index 51177b3c..9331a16d 100644
--- a/meta-openstack/recipes-devtools/python/python-logutils_0.3.5.bb
+++ b/meta-openstack/recipes-devtools/python/python-logutils_0.3.5.bb
@@ -1,16 +1,2 @@
-DESCRIPTION = "Set of handlers for the Python standard library's logging package"
-HOMEPAGE = "https://pypi.python.org/pypi/logutils"
-SECTION = "devel/python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44c35f0b8e2a27a2f33a4e4a5c65d014"
-
-SRC_URI[md5sum] = "fcd2f8e9217bfa0b580f253b35a9d954"
-SRC_URI[sha256sum] = "bc058a25d5c209461f134e1f03cab637d66a7a5ccc12e593db56fbb279899a82"
-
-inherit setuptools pypi
-
-# avoid "error: option --single-version-externally-managed not recognized"
-DISTUTILS_INSTALL_ARGS = "--root=${D} \
- --prefix=${prefix} \
- --install-lib=${PYTHON_SITEPACKAGES_DIR} \
- --install-data=${datadir}"
+inherit setuptools
+require python-logutils.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb b/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb
new file mode 100644
index 00000000..4d760e09
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-logutils.inc