aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-statsd.inc13
-rw-r--r--meta-openstack/recipes-devtools/python/python-statsd_3.3.0.bb15
-rw-r--r--meta-openstack/recipes-devtools/python/python3-statsd_3.3.0.bb2
3 files changed, 16 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-statsd.inc b/meta-openstack/recipes-devtools/python/python-statsd.inc
new file mode 100644
index 00000000..33257b90
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-statsd.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "A simple statsd client."
+HOMEPAGE = "https://github.com/jsocol/pystatsd"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4d8aa8ac1dc54b8aee4054bd5e5c61bd"
+
+inherit pypi
+
+SRC_URI[md5sum] = "b397ccf880f37cf099e775907ebf7a46"
+SRC_URI[sha256sum] = "e3e6db4c246f7c59003e51c9720a51a7f39a396541cb9b147ff4b14d15b5dd1f"
+
+RDEPENDS_${PN} += " \
+ "
diff --git a/meta-openstack/recipes-devtools/python/python-statsd_3.3.0.bb b/meta-openstack/recipes-devtools/python/python-statsd_3.3.0.bb
index 7400129e..51b179b4 100644
--- a/meta-openstack/recipes-devtools/python/python-statsd_3.3.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-statsd_3.3.0.bb
@@ -1,15 +1,2 @@
-DESCRIPTION = "A simple statsd client."
-HOMEPAGE = "https://github.com/jsocol/pystatsd"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4d8aa8ac1dc54b8aee4054bd5e5c61bd"
-
-inherit pypi
-
-SRC_URI[md5sum] = "b397ccf880f37cf099e775907ebf7a46"
-SRC_URI[sha256sum] = "e3e6db4c246f7c59003e51c9720a51a7f39a396541cb9b147ff4b14d15b5dd1f"
-
inherit setuptools
-
-RDEPENDS_${PN} += " \
- "
+require python-statsd.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-statsd_3.3.0.bb b/meta-openstack/recipes-devtools/python/python3-statsd_3.3.0.bb
new file mode 100644
index 00000000..3e430a12
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-statsd_3.3.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-statsd.inc