aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb25
-rw-r--r--meta-openstack/recipes-devtools/python/python3-testtools_2.3.0.bb2
3 files changed, 27 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testtools.inc b/meta-openstack/recipes-devtools/python/python-testtools.inc
new file mode 100644
index 00000000..7cc63f42
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-testtools.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Extensions to the Python standard library unit testing framework"
+HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
+
+SRC_URI[md5sum] = "0f0feb915497816cb99e39437494217e"
+SRC_URI[sha256sum] = "5827ec6cf8233e0f29f51025addd713ca010061204fdea77484a2934690a0559"
+
+inherit pypi
+DEPENDS += " \
+ ${PYTHON_PN}-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-extras \
+ ${PYTHON_PN}-pbr \
+ "
diff --git a/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb b/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
index bbf1d01a..56ff9de0 100644
--- a/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
@@ -1,23 +1,2 @@
-DESCRIPTION = "Extensions to the Python standard library unit testing framework"
-HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
-
-SRC_URI[md5sum] = "0f0feb915497816cb99e39437494217e"
-SRC_URI[sha256sum] = "5827ec6cf8233e0f29f51025addd713ca010061204fdea77484a2934690a0559"
-
-inherit setuptools pypi
-DEPENDS += " \
- python-pbr \
- "
-
-# Satisfy setup.py 'setup_requires'
-DEPENDS += " \
- python-pbr-native \
- "
-
-RDEPENDS_${PN} += "\
- python-extras \
- python-pbr \
- "
+inherit setuptools
+require python-testtools.inc
diff --git a/meta-openstack/recipes-devtools/python/python3-testtools_2.3.0.bb b/meta-openstack/recipes-devtools/python/python3-testtools_2.3.0.bb
new file mode 100644
index 00000000..896ecee6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-testtools_2.3.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-testtools.inc