aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-rally/sqlalchemy-db-missing-name-for-ENUM.patch25
-rw-r--r--meta-openstack/recipes-devtools/python/python-rally_git.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-rally/sqlalchemy-db-missing-name-for-ENUM.patch b/meta-openstack/recipes-devtools/python/python-rally/sqlalchemy-db-missing-name-for-ENUM.patch
new file mode 100644
index 00000000..afb425ce
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-rally/sqlalchemy-db-missing-name-for-ENUM.patch
@@ -0,0 +1,25 @@
+sqlalchemy-db: missing name for ENUM
+
+Command "rally-manage db recreate" gives the following error:
+
+TRACE rally File "/usr/lib64/python2.7/site-packages/sqlalchemy/dialects/postgresql/base.py", line 898, in format_type
+TRACE rally raise exc.CompileError("Postgresql ENUM type requires a name.")
+TRACE rally CompileError: Postgresql ENUM type requires a name.
+
+Signed-off-by: Vu Tran <vu.tran@windriver.com>
+
+diff --git a/rally/db/sqlalchemy/models.py b/rally/db/sqlalchemy/models.py
+index c68e345..5b2dbc0 100644
+--- a/rally/db/sqlalchemy/models.py
++++ b/rally/db/sqlalchemy/models.py
+@@ -85,8 +85,8 @@ class Deployment(BASE, RallyBase):
+ )
+
+ status = sa.Column(
+- sa.Enum(*consts.DeployStatus),
+- name='enum_deployments_status',
++ sa.Enum(*consts.DeployStatus,
++ name='enum_deployments_status'),
+ default=consts.DeployStatus.DEPLOY_INIT,
+ nullable=False,
+ )
diff --git a/meta-openstack/recipes-devtools/python/python-rally_git.bb b/meta-openstack/recipes-devtools/python/python-rally_git.bb
index 2a834577..360e89fc 100644
--- a/meta-openstack/recipes-devtools/python/python-rally_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-rally_git.bb
@@ -16,6 +16,7 @@ SRC_URI = "git://github.com/stackforge/${SRCNAME}.git;branch=master \
file://deployment-existing.json \
file://remove-ironic-support.patch \
file://verification-to-use-existing-tempest.patch \
+ file://sqlalchemy-db-missing-name-for-ENUM.patch \
"
SRCREV="b297cf00750f263b8b5bdeb71f6952f672e87f5a"