aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--meta-openstack/conf/layer.conf2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb2
-rw-r--r--meta-openstack/recipes-extended/novnc/novnc_git.bb51
4 files changed, 20 insertions, 37 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index a159d994..25e18f2b 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -7,5 +7,5 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "cloud-services-layer"
BBFILE_PATTERN_cloud-services-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_cloud-services-layer = "5"
-LAYERSERIES_COMPAT_cloud-services-layer = "gatesgarth hardknott honister"
+LAYERSERIES_COMPAT_cloud-services-layer = "gatesgarth hardknott"
LAYERDEPENDS_cloud-services-layer = "core filesystems-layer networking-layer"
diff --git a/meta-openstack/conf/layer.conf b/meta-openstack/conf/layer.conf
index 3c39d5ef..f9ffa900 100644
--- a/meta-openstack/conf/layer.conf
+++ b/meta-openstack/conf/layer.conf
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "openstack-layer"
BBFILE_PATTERN_openstack-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_openstack-layer = "5"
-LAYERSERIES_COMPAT_openstack-layer = "gatesgarth hardknott honister"
+LAYERSERIES_COMPAT_openstack-layer = "gatesgarth hardknott"
BB_DANGLINGAPPENDS_WARNONLY ?= "true"
LAYERDEPENDS_openstack-layer = " \
diff --git a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
index 2e8dca06..cded499d 100644
--- a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
+++ b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
@@ -20,6 +20,8 @@ DEPENDS += " \
${PYTHON_PN}-pip \
"
+LDSHARED="${CCLD} -shared -lrt"
+
# RDEPENDS_default:
RDEPENDS_${PN} += " \
"
diff --git a/meta-openstack/recipes-extended/novnc/novnc_git.bb b/meta-openstack/recipes-extended/novnc/novnc_git.bb
index 7099d856..53a70560 100644
--- a/meta-openstack/recipes-extended/novnc/novnc_git.bb
+++ b/meta-openstack/recipes-extended/novnc/novnc_git.bb
@@ -1,52 +1,33 @@
DESCRIPTION = "HTML5 VNC client"
HOMEPAGE = "https://github.com/kanaka/noVNC"
SECTION = "web"
-
-PR = "r0"
-
LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ac06308a999996ffc2d24d81b3a39f1b"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b428e7772bf00c07fb7b863b80358adf"
-SRCREV = "8f12ca7a5a64144fe548cada332d5d19ef26a1fe"
-PV = "0.4+git${SRCPV}"
+SRCREV = "9142f8f0f7b4a53447f5cfec3a797cbf0d6204a9"
+PV = "1.2.0+git${SRCPV}"
SRC_URI = "git://github.com/kanaka/noVNC.git"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} += "python-numpy"
-RDEPENDS_${PN} += "python-novnc"
-RDEPENDS_${PN} += "python-websockify"
-
do_compile() {
:
}
+RDEPENDS_${PN} += " \
+ bash \
+"
+
do_install() {
- install -m 755 -d ${D}${bindir}/novnc
- install -m 755 -d ${D}${datadir}/novnc/include
-
- install -m 644 ${S}/vnc.html ${D}${datadir}/novnc
- install -m 644 ${S}/vnc_auto.html ${D}${datadir}/novnc
- install -m 644 ${S}/images/favicon.ico ${D}${datadir}/novnc
- install -m 644 ${S}/include/base64.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/des.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/display.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/input.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/logo.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/base.css ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/blue.css ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/black.css ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/playback.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/rfb.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/ui.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/util.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/websock.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/webutil.js ${D}${datadir}/novnc/include
- install -m 644 ${S}/include/jsunzip.js ${D}${datadir}/novnc/include
-
- sed -i -e 's:#!/usr/bin/env bash:#!/bin/sh:' ${S}/utils/launch.sh
-
- install -m 755 ${S}/utils/launch.sh ${D}${bindir}/novnc-launch.sh
+ install -m 755 -d ${D}${datadir}/novnc
+
+ cp -R --no-dereference --preserve=mode,links ${S}/* ${D}${datadir}/novnc
+
+ install -m 444 ${S}/vnc.html ${D}${datadir}/novnc/index.html
+ install -m 444 ${S}/vnc_lite.html ${D}${datadir}/novnc/vnc_auto.html
+
+ install -m 755 -d ${D}${bindir}
+ install -m 644 ${S}/utils/launch.sh ${D}${bindir}/novnc_server
}