aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/0001-mounted.ocfs2-use-sys-sysmacros.h-include-for-makede.patch47
-rw-r--r--meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/ocfs2-fix-compile-error-when-glibc-upgrade.patch88
-rw-r--r--meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools_1.8.6.bb (renamed from meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools_1.8.5.bb)8
3 files changed, 3 insertions, 140 deletions
diff --git a/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/0001-mounted.ocfs2-use-sys-sysmacros.h-include-for-makede.patch b/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/0001-mounted.ocfs2-use-sys-sysmacros.h-include-for-makede.patch
deleted file mode 100644
index ddc43aa..0000000
--- a/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/0001-mounted.ocfs2-use-sys-sysmacros.h-include-for-makede.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 03be837c7d0b9be393ffb555879c49e6212fbd0f Mon Sep 17 00:00:00 2001
-From: Valentin Vidic <Valentin.Vidic@CARNet.hr>
-Date: Thu, 25 Jan 2018 13:05:27 +0100
-Subject: [PATCH] mounted.ocfs2: use <sys/sysmacros.h> include for makedev
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
- mounted.c: In function "build_partition_list":
- mounted.c:354:13: warning: In the GNU C Library, "makedev" is defined
- by <sys/sysmacros.h>. For historical compatibility, it is
- currently defined by <sys/types.h> as well, but we plan to
- remove this soon. To use "makedev", include <sys/sysmacros.h>
- directly. If you did not intend to use a system-defined macro
- "makedev", you should undefine it after including <sys/types.h>.
- makedev(major, minor), &devname);
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-Fix the below error:
-/usr/src/debug/ocfs2-tools/1.8.5-r0/git/mounted.ocfs2/mounted.c:354: undefined reference to `makedev'
-collect2: error: ld returned 1 exit status
-Makefile:36: recipe for target 'mounted.ocfs2' failed
-make[1]: *** [mounted.ocfs2] Error 1
-
-Upstream-Status: Backport[https://github.com/markfasheh/ocfs2-tools/commit/03be837c7d0b9be393ffb555879c49e6212fbd0f]
-
-Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
----
- mounted.ocfs2/mounted.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mounted.ocfs2/mounted.c b/mounted.ocfs2/mounted.c
-index 1576f902..090ab4ed 100644
---- a/mounted.ocfs2/mounted.c
-+++ b/mounted.ocfs2/mounted.c
-@@ -25,7 +25,7 @@
- #define _LARGEFILE64_SOURCE
- #define _GNU_SOURCE /* Because libc really doesn't want us using O_DIRECT? */
-
--#include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <stdio.h>
- #include <unistd.h>
- #include <errno.h>
---
-2.17.1
-
diff --git a/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/ocfs2-fix-compile-error-when-glibc-upgrade.patch b/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/ocfs2-fix-compile-error-when-glibc-upgrade.patch
deleted file mode 100644
index 5eb2a61..0000000
--- a/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools/ocfs2-fix-compile-error-when-glibc-upgrade.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 0ffd58b223e24779420130522ea8ee359505f493 Mon Sep 17 00:00:00 2001
-From: Gang He <ghe@suse.com>
-Date: Mon, 4 Sep 2017 14:08:59 +0800
-Subject: [PATCH] fsck.ocfs2: fix compile error when glibc upgrade
-
-When glibc upgrade to glibc-2.26.90-14, there was a compile error in fsck.ocfs2,
-the compile error messages like,
-
-In file included from /usr/include/string.h:431:0,
- from ../include/ocfs2/ocfs2.h:41,
- from pass4.c:32:
-include/strings.h:37:1: error: unknown type name 'errcode_t'; did you mean 'mode_t'?
- errcode_t o2fsck_strings_insert(o2fsck_strings *strings, char *string,
- ^~~~~~~~~
- mode_t
-
-
-Upstream-Status: Backport [https://github.com/markfasheh/ocfs2-tools/commit/0ffd58b223e24779420130522ea8ee359505f493]
-
-Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
----
- fsck.ocfs2/Makefile | 2 +-
- fsck.ocfs2/include/{strings.h => o2fsck_strings.h} | 0
- fsck.ocfs2/pass2.c | 2 +-
- fsck.ocfs2/pass5.c | 2 +-
- fsck.ocfs2/strings.c | 2 +-
- 5 files changed, 4 insertions(+), 4 deletions(-)
- rename fsck.ocfs2/include/{strings.h => o2fsck_strings.h} (100%)
-
-diff --git a/fsck.ocfs2/Makefile b/fsck.ocfs2/Makefile
-index 051ed74..baf1994 100644
---- a/fsck.ocfs2/Makefile
-+++ b/fsck.ocfs2/Makefile
-@@ -64,7 +64,7 @@ HFILES = include/fsck.h \
- include/problem.h \
- include/refcount.h \
- include/slot_recovery.h \
-- include/strings.h \
-+ include/o2fsck_strings.h \
- include/util.h
-
-
-diff --git a/fsck.ocfs2/include/strings.h b/fsck.ocfs2/include/o2fsck_strings.h
-similarity index 100%
-rename from fsck.ocfs2/include/strings.h
-rename to fsck.ocfs2/include/o2fsck_strings.h
-diff --git a/fsck.ocfs2/pass2.c b/fsck.ocfs2/pass2.c
-index 181febb..a48a50b 100644
---- a/fsck.ocfs2/pass2.c
-+++ b/fsck.ocfs2/pass2.c
-@@ -43,7 +43,7 @@
- #include "fsck.h"
- #include "pass2.h"
- #include "problem.h"
--#include "strings.h"
-+#include "o2fsck_strings.h"
- #include "util.h"
-
- static const char *whoami = "pass2";
-diff --git a/fsck.ocfs2/pass5.c b/fsck.ocfs2/pass5.c
-index 5c2d899..bfad1b7 100644
---- a/fsck.ocfs2/pass5.c
-+++ b/fsck.ocfs2/pass5.c
-@@ -40,7 +40,7 @@
- #include "fsck.h"
- #include "pass5.h"
- #include "problem.h"
--#include "strings.h"
-+#include "o2fsck_strings.h"
- #include "util.h"
-
- static const char *whoami = "pass5";
-diff --git a/fsck.ocfs2/strings.c b/fsck.ocfs2/strings.c
-index 4ad3782..8a7a8d9 100644
---- a/fsck.ocfs2/strings.c
-+++ b/fsck.ocfs2/strings.c
-@@ -31,7 +31,7 @@
- #include "ocfs2/ocfs2.h"
-
- #include "fsck.h"
--#include "strings.h"
-+#include "o2fsck_strings.h"
- #include "util.h"
-
- struct string_entry {
---
-2.7.4
-
diff --git a/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools_1.8.5.bb b/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools_1.8.6.bb
index a0376ec..bc0551b 100644
--- a/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools_1.8.5.bb
+++ b/meta-cgl-common/recipes-cgl/ocfs2-tools/ocfs2-tools_1.8.6.bb
@@ -10,19 +10,17 @@ ext3."
HOMEPAGE = "http://oss.oracle.com/projects/ocfs2-tools/"
SECTION = "System Environment/Base"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ef380476f642c20ebf40fecb0add2ec"
SRC_URI = "git://github.com/markfasheh/ocfs2-tools \
file://0003-vendor-common-o2cb.ocf-add-new-conf-file.patch \
- file://ocfs2-fix-compile-error-when-glibc-upgrade.patch \
file://ocfs2-tools-1.8.5-format-fortify.patch \
file://no-redhat.patch \
file://o2cb.service \
file://ocfs2.service \
file://0001-Fix-build-with-glibc-2.28.patch \
- file://0001-mounted.ocfs2-use-sys-sysmacros.h-include-for-makede.patch \
"
-SRCREV = "f1b4d073f08679f97b64b3eb88e586032f92a701"
+SRCREV = "4d76ceb4aa7aaa1fd595368089e99575d708f719"
S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig systemd
@@ -35,7 +33,7 @@ DEPENDS = "corosync pacemaker \
# lsbinitscripts are needed to replace /etc/init.d/functions supplied by initscripts (systemv)
# They are not the same code!
#
-RDEPENDS_${PN} = "bash coreutils net-tools module-init-tools e2fsprogs chkconfig glib-2.0 \
+RDEPENDS_${PN} = "bash coreutils net-tools module-init-tools e2fsprogs glib-2.0 \
${@bb.utils.contains('DISTRO_FEATURES','systemd','lsbinitscripts','',d)}"
ASNEEDED_pn-${PN} = ""