summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-arm-autonomy/documentation/arm-autonomy-quickstart.md4
-rw-r--r--meta-arm-autonomy/recipes-bsp/u-boot/u-boot-2020.01/fvp-base/xen_u-boot_kernel_addr.patch16
-rw-r--r--meta-arm-autonomy/recipes-bsp/u-boot/u-boot_2020.01.bbappend9
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-arm-autonomy/documentation/arm-autonomy-quickstart.md b/meta-arm-autonomy/documentation/arm-autonomy-quickstart.md
index 2a457c16..22b270ad 100644
--- a/meta-arm-autonomy/documentation/arm-autonomy-quickstart.md
+++ b/meta-arm-autonomy/documentation/arm-autonomy-quickstart.md
@@ -115,6 +115,10 @@ To boot the system using an u-boot base board you will need to:
In this example the addresses might need to be adapted depending on your board.
+For arm-autonomy host on FVP-Base u-boot has been modified such that
+`booti 0x84000000 - 0x83000000` is the default boot command. If FVP-Base is your
+MACHINE target there should be no need to interfere with u-boot.
+
Guest project
-------------
The guest projects are not target specific and will use a Yocto MACHINE defined
diff --git a/meta-arm-autonomy/recipes-bsp/u-boot/u-boot-2020.01/fvp-base/xen_u-boot_kernel_addr.patch b/meta-arm-autonomy/recipes-bsp/u-boot/u-boot-2020.01/fvp-base/xen_u-boot_kernel_addr.patch
new file mode 100644
index 00000000..ac27ddea
--- /dev/null
+++ b/meta-arm-autonomy/recipes-bsp/u-boot/u-boot-2020.01/fvp-base/xen_u-boot_kernel_addr.patch
@@ -0,0 +1,16 @@
+Upstream Status: Inappropriate [meta-arm-autonomy specifc u-boot config]
+Signed-off-by: Nathan Dunne <nathan.dunne@arm.com>
+
+diff --git a/include/configs/vexpress_aemv8a.h b/include/configs/vexpress_aemv8a.h
+index e63c335f85..9ee050a4a6 100644
+--- a/include/configs/vexpress_aemv8a.h
++++ b/include/configs/vexpress_aemv8a.h
+@@ -162,7 +162,7 @@
+ #elif CONFIG_TARGET_VEXPRESS64_BASE_FVP
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "kernel_name=Image\0" \
+- "kernel_addr=0x80080000\0" \
++ "kernel_addr=0x84000000\0" \
+ "initrd_name=ramdisk.img\0" \
+ "initrd_addr=0x88000000\0" \
+ "fdtfile=devtree.dtb\0" \
diff --git a/meta-arm-autonomy/recipes-bsp/u-boot/u-boot_2020.01.bbappend b/meta-arm-autonomy/recipes-bsp/u-boot/u-boot_2020.01.bbappend
new file mode 100644
index 00000000..daabc5f1
--- /dev/null
+++ b/meta-arm-autonomy/recipes-bsp/u-boot/u-boot_2020.01.bbappend
@@ -0,0 +1,9 @@
+# Machine specific u-boot
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BP}:"
+
+#
+# FVP BASE
+#
+
+SRC_URI_append_fvp-base = "${@bb.utils.contains('DISTRO_FEATURES', 'arm-autonomy-host', ' file://xen_u-boot_kernel_addr.patch', '', d)}"