aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch')
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch
new file mode 100644
index 00000000..c18441f5
--- /dev/null
+++ b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-loader-layers/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch
@@ -0,0 +1,71 @@
+From af1706e021e900f2cfb15e7bc0f9f68cdd1bd04c Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 4 Sep 2018 14:58:18 +0500
+Subject: [PATCH 3/5] CMakeLists.txt: use a fixed header for spirv_commit
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ CMakeLists.txt | 3 ---
+ spirv_tools_commit_id.h | 29 +++++++++++++++++++++++++++++
+ 2 files changed, 29 insertions(+), 3 deletions(-)
+ create mode 100644 spirv_tools_commit_id.h
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5cf85d487..b0ec3cbaf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -343,7 +343,6 @@ add_custom_target(generate_helper_files DEPENDS
+ vk_dispatch_table_helper.h
+ vk_extension_helper.h
+ vk_typemap_helper.h
+- spirv_tools_commit_id.h
+ )
+ set_target_properties(generate_helper_files PROPERTIES FOLDER ${LVL_TARGET_FOLDER})
+
+@@ -358,8 +357,6 @@ run_vk_xml_generate(helper_file_generator.py vk_enum_string_helper.h)
+ run_vk_xml_generate(helper_file_generator.py vk_object_types.h)
+ run_vk_xml_generate(helper_file_generator.py vk_extension_helper.h)
+ run_vk_xml_generate(helper_file_generator.py vk_typemap_helper.h)
+-run_external_revision_generate(${EXTERNAL_SOURCE_ROOT}/glslang/External/spirv-tools SPIRV_TOOLS_COMMIT_ID spirv_tools_commit_id.h)
+-
+
+
+ if(NOT WIN32)
+diff --git a/include/vulkan/spirv_tools_commit_id.h b/include/vulkan/spirv_tools_commit_id.h
+new file mode 100644
+index 000000000..ae588b33f
+--- /dev/null
++++ b/include/vulkan/spirv_tools_commit_id.h
+@@ -0,0 +1,29 @@
++// *** THIS FILE IS GENERATED - DO NOT EDIT ***
++// See external_revision_generator.py for modifications
++
++/***************************************************************************
++ *
++ * Copyright (c) 2015-2017 The Khronos Group Inc.
++ * Copyright (c) 2015-2017 Valve Corporation
++ * Copyright (c) 2015-2017 LunarG, Inc.
++ * Copyright (c) 2015-2017 Google Inc.
++ *
++ * Licensed under the Apache License, Version 2.0 (the "License");
++ * you may not use this file except in compliance with the License.
++ * You may obtain a copy of the License at
++ *
++ * http://www.apache.org/licenses/LICENSE-2.0
++ *
++ * Unless required by applicable law or agreed to in writing, software
++ * distributed under the License is distributed on an "AS IS" BASIS,
++ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++ * See the License for the specific language governing permissions and
++ * limitations under the License.
++ *
++ * Author: Chris Forbes <chrisforbes@google.com>
++ * Author: Cort Stratton <cort@google.com>
++ *
++ ****************************************************************************/
++#pragma once
++
++#define SPIRV_TOOLS_COMMIT_ID "2651ccaec8170b3257642b3c438f50dc4f181fdd"
+--
+2.11.1
+