aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86/conf/local.conf.append.amdfalconx86')
-rw-r--r--meta-amdfalconx86/conf/local.conf.append.amdfalconx8633
1 files changed, 18 insertions, 15 deletions
diff --git a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86 b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
index 56552668..742f5e5e 100644
--- a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
+++ b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
@@ -28,8 +28,8 @@ RT_KERNEL_AMD = "no"
INCLUDE_MPV ??= "no"
COMMERCIAL_LIC_FLAGS_MPV = "commercial_ffmpeg commercial_x264"
-LICENSE_FLAGS_WHITELIST .= "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
-CORE_IMAGE_EXTRA_INSTALL .= "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
+LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
+CORE_IMAGE_EXTRA_INSTALL_append = "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
# Certain multimedia formats also require license restricted codecs and
# software components which are not included in MEL build by default.
@@ -40,17 +40,20 @@ COMMERCIAL_LIC_FLAGS_MULTIMEDIA = "commercial_gstreamer1.0-plugins-ugly \
commercial_mpeg2dec \
commercial_gstreamer1.0-libav \
commercial_mpg123"
-LICENSE_FLAGS_WHITELIST .= "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
-CORE_IMAGE_EXTRA_INSTALL .= "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
-
-# MEL has support for gaming components including LunarG SDK,
-# CodeXL etc. In order to include these components in your final
-# image or generating an ADE which can be used to develop for/against
-# these please change the below define to "yes" before building the
+LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+CORE_IMAGE_EXTRA_INSTALL_append = "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+
+# MEL has support for Vulkan/LunarG SDK components.
+# These components are required to run the Vulkan based applications.
+# In order to include these components in your final
+# image or generating an ADE that can be used to develop for/against these
+# please change the below define to "yes" before building the
# image or generating ADE.
-# The list of components this package provides can be seen in the
-# RDEPENDS list of:
-# meta-amd/common/recipes-core/packagegroups/packagegroup-gaming.bb
-INCLUDE_GAMING_COMPONENTS ??= "no"
-
-CORE_IMAGE_EXTRA_INSTALL .= "${@' packagegroup-gaming' if bb.utils.to_boolean('${INCLUDE_GAMING_COMPONENTS}') else ''}"
+INCLUDE_VULKAN ??= "no"
+
+# MEL has support for CodeXL.
+# This include CodeXL remote agent and some sample applications to
+# verify the GPU debugging and profiling functionality.
+# In order to include these components in your final
+# image please change the below define to "yes" before building the image.
+INCLUDE_CODEXL ??= "no"