aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/dpdk/recipes-extended/dpdk/files/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/dpdk/recipes-extended/dpdk/files/dpdk-16.07-add-sysroot-option-within-app-makefile.patch')
-rw-r--r--meta-amd-bsp/dpdk/recipes-extended/dpdk/files/dpdk-16.07-add-sysroot-option-within-app-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-amd-bsp/dpdk/recipes-extended/dpdk/files/dpdk-16.07-add-sysroot-option-within-app-makefile.patch b/meta-amd-bsp/dpdk/recipes-extended/dpdk/files/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
new file mode 100644
index 00000000..18b761c7
--- /dev/null
+++ b/meta-amd-bsp/dpdk/recipes-extended/dpdk/files/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
@@ -0,0 +1,30 @@
+From d08d11c8b6fdfe73884d67a94d907000afd136ed Mon Sep 17 00:00:00 2001
+From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+Date: Fri, 19 Aug 2016 11:57:49 +0800
+Subject: [PATCH] dpdk: add --sysroot option within app makefile
+
+Upstream-Status: Inappropriate [configuration]
+
+rte.app.mk has been changed to add -Wl, to all items listed
+under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
+correctly when we depends on gcc to setup for GNU ld.
+
+Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
+
+---
+ mk/rte.app.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mk/rte.app.mk b/mk/rte.app.mk
+index 3eb41d176d21..9ab6688718db 100644
+--- a/mk/rte.app.mk
++++ b/mk/rte.app.mk
+@@ -300,7 +300,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
+ ifeq ($(LINK_USING_CC),1)
+ O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(EXTRA_CFLAGS) $(OBJS-y) $(call linkerprefix, \
+ $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
+- $(MAPFLAGS))
++ $(MAPFLAGS)) $(SYSROOTPATH)
+ else
+ O_TO_EXE = $(LD) -o $@ $(OBJS-y) \
+ $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \