aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto-4.14.71/4795-drm-amd-display-remove-soc_bounding_box.c.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto-4.14.71/4795-drm-amd-display-remove-soc_bounding_box.c.patch')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/4795-drm-amd-display-remove-soc_bounding_box.c.patch193
1 files changed, 193 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-4.14.71/4795-drm-amd-display-remove-soc_bounding_box.c.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/4795-drm-amd-display-remove-soc_bounding_box.c.patch
new file mode 100644
index 00000000..affc7634
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/4795-drm-amd-display-remove-soc_bounding_box.c.patch
@@ -0,0 +1,193 @@
+From 90850500a1c1154a957a242443a74f3797ef0f07 Mon Sep 17 00:00:00 2001
+From: Dmytro Laktyushkin <Dmytro.Laktyushkin@amd.com>
+Date: Tue, 5 Jun 2018 07:33:10 -0400
+Subject: [PATCH 4795/5725] drm/amd/display: remove soc_bounding_box.c
+
+Signed-off-by: Dmytro Laktyushkin <Dmytro.Laktyushkin@amd.com>
+Reviewed-by: Tony Cheng <Tony.Cheng@amd.com>
+Acked-by: Harry Wentland <harry.wentland@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/dml/Makefile | 3 +-
+ .../gpu/drm/amd/display/dc/dml/display_mode_lib.h | 1 -
+ .../drm/amd/display/dc/dml/display_mode_structs.h | 3 +-
+ .../gpu/drm/amd/display/dc/dml/soc_bounding_box.c | 79 ----------------------
+ .../gpu/drm/amd/display/dc/dml/soc_bounding_box.h | 35 ----------
+ 5 files changed, 2 insertions(+), 119 deletions(-)
+ delete mode 100644 drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.c
+ delete mode 100644 drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.h
+
+diff --git a/drivers/gpu/drm/amd/display/dc/dml/Makefile b/drivers/gpu/drm/amd/display/dc/dml/Makefile
+index a29fa6d..ec2475d 100644
+--- a/drivers/gpu/drm/amd/display/dc/dml/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/dml/Makefile
+@@ -15,11 +15,10 @@ CFLAGS_display_mode_lib.o := $(dml_ccflags)
+ CFLAGS_display_pipe_clocks.o := $(dml_ccflags)
+ CFLAGS_dml1_display_rq_dlg_calc.o := $(dml_ccflags)
+ CFLAGS_display_rq_dlg_helpers.o := $(dml_ccflags)
+-CFLAGS_soc_bounding_box.o := $(dml_ccflags)
+ CFLAGS_dml_common_defs.o := $(dml_ccflags)
+
+ DML = display_mode_lib.o display_rq_dlg_helpers.o dml1_display_rq_dlg_calc.o \
+- soc_bounding_box.o dml_common_defs.o
++ dml_common_defs.o
+
+ AMD_DAL_DML = $(addprefix $(AMDDALPATH)/dc/dml/,$(DML))
+
+diff --git a/drivers/gpu/drm/amd/display/dc/dml/display_mode_lib.h b/drivers/gpu/drm/amd/display/dc/dml/display_mode_lib.h
+index 3c2abcb..6352062 100644
+--- a/drivers/gpu/drm/amd/display/dc/dml/display_mode_lib.h
++++ b/drivers/gpu/drm/amd/display/dc/dml/display_mode_lib.h
+@@ -27,7 +27,6 @@
+
+
+ #include "dml_common_defs.h"
+-#include "soc_bounding_box.h"
+ #include "dml1_display_rq_dlg_calc.h"
+
+ enum dml_project {
+diff --git a/drivers/gpu/drm/amd/display/dc/dml/display_mode_structs.h b/drivers/gpu/drm/amd/display/dc/dml/display_mode_structs.h
+index 7fa0375..6943801 100644
+--- a/drivers/gpu/drm/amd/display/dc/dml/display_mode_structs.h
++++ b/drivers/gpu/drm/amd/display/dc/dml/display_mode_structs.h
+@@ -64,10 +64,9 @@ struct _vcs_dpi_voltage_scaling_st {
+ double dscclk_mhz;
+ double dcfclk_mhz;
+ double socclk_mhz;
+- double dram_speed_mhz;
++ double dram_speed_mts;
+ double fabricclk_mhz;
+ double dispclk_mhz;
+- double dram_bw_per_chan_gbps;
+ double phyclk_mhz;
+ double dppclk_mhz;
+ };
+diff --git a/drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.c b/drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.c
+deleted file mode 100644
+index 324239c..0000000
+--- a/drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.c
++++ /dev/null
+@@ -1,79 +0,0 @@
+-/*
+- * Copyright 2017 Advanced Micro Devices, Inc.
+- *
+- * Permission is hereby granted, free of charge, to any person obtaining a
+- * copy of this software and associated documentation files (the "Software"),
+- * to deal in the Software without restriction, including without limitation
+- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
+- * and/or sell copies of the Software, and to permit persons to whom the
+- * Software is furnished to do so, subject to the following conditions:
+- *
+- * The above copyright notice and this permission notice shall be included in
+- * all copies or substantial portions of the Software.
+- *
+- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+- * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
+- * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+- * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+- * OTHER DEALINGS IN THE SOFTWARE.
+- *
+- * Authors: AMD
+- *
+- */
+-#include "soc_bounding_box.h"
+-#include "display_mode_lib.h"
+-#include "dc_features.h"
+-
+-#include "dml_inline_defs.h"
+-
+-/*
+- * NOTE:
+- * This file is gcc-parseable HW gospel, coming straight from HW engineers.
+- *
+- * It doesn't adhere to Linux kernel style and sometimes will do things in odd
+- * ways. Unless there is something clearly wrong with it the code should
+- * remain as-is as it provides us with a guarantee from HW that it is correct.
+- */
+-
+-void dml_socbb_set_latencies(soc_bounding_box_st *to_box, soc_bounding_box_st *from_box)
+-{
+- to_box->dram_clock_change_latency_us = from_box->dram_clock_change_latency_us;
+- to_box->sr_exit_time_us = from_box->sr_exit_time_us;
+- to_box->sr_enter_plus_exit_time_us = from_box->sr_enter_plus_exit_time_us;
+- to_box->urgent_latency_us = from_box->urgent_latency_us;
+- to_box->writeback_latency_us = from_box->writeback_latency_us;
+-}
+-
+-voltage_scaling_st dml_socbb_voltage_scaling(
+- const soc_bounding_box_st *soc,
+- enum voltage_state voltage)
+-{
+- const voltage_scaling_st *voltage_state;
+- const voltage_scaling_st * const voltage_end = soc->clock_limits + DC__VOLTAGE_STATES;
+-
+- for (voltage_state = soc->clock_limits;
+- voltage_state < voltage_end && voltage_state->state != voltage;
+- voltage_state++) {
+- }
+-
+- if (voltage_state < voltage_end)
+- return *voltage_state;
+- return soc->clock_limits[DC__VOLTAGE_STATES - 1];
+-}
+-
+-double dml_socbb_return_bw_mhz(soc_bounding_box_st *box, enum voltage_state voltage)
+-{
+- double return_bw;
+-
+- voltage_scaling_st state = dml_socbb_voltage_scaling(box, voltage);
+-
+- return_bw = dml_min((double) box->return_bus_width_bytes * state.dcfclk_mhz,
+- state.dram_bw_per_chan_gbps * 1000.0 * (double) box->num_chans
+- * box->ideal_dram_bw_after_urgent_percent / 100.0);
+-
+- return_bw = dml_min((double) box->return_bus_width_bytes * state.fabricclk_mhz, return_bw);
+-
+- return return_bw;
+-}
+diff --git a/drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.h b/drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.h
+deleted file mode 100644
+index 7a65206..0000000
+--- a/drivers/gpu/drm/amd/display/dc/dml/soc_bounding_box.h
++++ /dev/null
+@@ -1,35 +0,0 @@
+-/*
+- * Copyright 2017 Advanced Micro Devices, Inc.
+- *
+- * Permission is hereby granted, free of charge, to any person obtaining a
+- * copy of this software and associated documentation files (the "Software"),
+- * to deal in the Software without restriction, including without limitation
+- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
+- * and/or sell copies of the Software, and to permit persons to whom the
+- * Software is furnished to do so, subject to the following conditions:
+- *
+- * The above copyright notice and this permission notice shall be included in
+- * all copies or substantial portions of the Software.
+- *
+- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+- * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
+- * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+- * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+- * OTHER DEALINGS IN THE SOFTWARE.
+- *
+- * Authors: AMD
+- *
+- */
+-
+-#ifndef __SOC_BOUNDING_BOX_H__
+-#define __SOC_BOUNDING_BOX_H__
+-
+-#include "dml_common_defs.h"
+-
+-void dml_socbb_set_latencies(soc_bounding_box_st *to_box, soc_bounding_box_st *from_box);
+-voltage_scaling_st dml_socbb_voltage_scaling(const soc_bounding_box_st *box, enum voltage_state voltage);
+-double dml_socbb_return_bw_mhz(soc_bounding_box_st *box, enum voltage_state voltage);
+-
+-#endif
+--
+2.7.4
+