aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-core/packagegroups/packagegroup-gaming.bb15
-rw-r--r--common/recipes-sato/images/core-image-sato.bbappend7
-rw-r--r--meta-amdfalconx86/conf/local.conf.append.amdfalconx8633
-rw-r--r--meta-amdfalconx86/conf/machine/amdfalconx86.conf2
4 files changed, 26 insertions, 31 deletions
diff --git a/common/recipes-core/packagegroups/packagegroup-gaming.bb b/common/recipes-core/packagegroups/packagegroup-gaming.bb
deleted file mode 100644
index 7524f44c..00000000
--- a/common/recipes-core/packagegroups/packagegroup-gaming.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Package group targeting gaming components for AMD platforms"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r0"
-
-inherit packagegroup
-
-LUNARG_SDK_COMPONENTS = "glslang spirv-tools vulkan-loader-layers vulkan-tools vulkan-samples"
-CODEXL_COMPONENTS = "codexl codexl-examples"
-
-RDEPENDS_${PN} += "\
- ${LUNARG_SDK_COMPONENTS} \
- ${CODEXL_COMPONENTS} \
-"
diff --git a/common/recipes-sato/images/core-image-sato.bbappend b/common/recipes-sato/images/core-image-sato.bbappend
index 31818edc..0f626879 100644
--- a/common/recipes-sato/images/core-image-sato.bbappend
+++ b/common/recipes-sato/images/core-image-sato.bbappend
@@ -2,3 +2,10 @@ require conf/machine/include/amd-common.inc
IMAGE_INSTALL_append_amdgpu = " mesa-demos"
IMAGE_INSTALL_append_radeon = " mesa-demos"
+
+VULKAN_COMPONENTS_amdfalconx86 = "glslang spirv-tools vulkan-loader-layers vulkan-tools vulkan-samples"
+CODEXL_COMPONENTS = "codexl codexl-examples"
+
+IMAGE_INSTALL_append = "${@' ${VULKAN_COMPONENTS}' if bb.utils.to_boolean('${INCLUDE_VULKAN}') else ''} \
+ ${@' ${CODEXL_COMPONENTS}' if bb.utils.to_boolean('${INCLUDE_CODEXL}') else ''} \
+ "
diff --git a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86 b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
index 56552668..742f5e5e 100644
--- a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
+++ b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
@@ -28,8 +28,8 @@ RT_KERNEL_AMD = "no"
INCLUDE_MPV ??= "no"
COMMERCIAL_LIC_FLAGS_MPV = "commercial_ffmpeg commercial_x264"
-LICENSE_FLAGS_WHITELIST .= "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
-CORE_IMAGE_EXTRA_INSTALL .= "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
+LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
+CORE_IMAGE_EXTRA_INSTALL_append = "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
# Certain multimedia formats also require license restricted codecs and
# software components which are not included in MEL build by default.
@@ -40,17 +40,20 @@ COMMERCIAL_LIC_FLAGS_MULTIMEDIA = "commercial_gstreamer1.0-plugins-ugly \
commercial_mpeg2dec \
commercial_gstreamer1.0-libav \
commercial_mpg123"
-LICENSE_FLAGS_WHITELIST .= "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
-CORE_IMAGE_EXTRA_INSTALL .= "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
-
-# MEL has support for gaming components including LunarG SDK,
-# CodeXL etc. In order to include these components in your final
-# image or generating an ADE which can be used to develop for/against
-# these please change the below define to "yes" before building the
+LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+CORE_IMAGE_EXTRA_INSTALL_append = "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+
+# MEL has support for Vulkan/LunarG SDK components.
+# These components are required to run the Vulkan based applications.
+# In order to include these components in your final
+# image or generating an ADE that can be used to develop for/against these
+# please change the below define to "yes" before building the
# image or generating ADE.
-# The list of components this package provides can be seen in the
-# RDEPENDS list of:
-# meta-amd/common/recipes-core/packagegroups/packagegroup-gaming.bb
-INCLUDE_GAMING_COMPONENTS ??= "no"
-
-CORE_IMAGE_EXTRA_INSTALL .= "${@' packagegroup-gaming' if bb.utils.to_boolean('${INCLUDE_GAMING_COMPONENTS}') else ''}"
+INCLUDE_VULKAN ??= "no"
+
+# MEL has support for CodeXL.
+# This include CodeXL remote agent and some sample applications to
+# verify the GPU debugging and profiling functionality.
+# In order to include these components in your final
+# image please change the below define to "yes" before building the image.
+INCLUDE_CODEXL ??= "no"
diff --git a/meta-amdfalconx86/conf/machine/amdfalconx86.conf b/meta-amdfalconx86/conf/machine/amdfalconx86.conf
index f6556ff2..9025ce31 100644
--- a/meta-amdfalconx86/conf/machine/amdfalconx86.conf
+++ b/meta-amdfalconx86/conf/machine/amdfalconx86.conf
@@ -41,6 +41,6 @@ KERNEL_SERIAL_CONSOLE ?= "console=ttyS0,115200n8"
# Enable powerplay
APPEND += "amdgpu.powerplay=1 amdgpu.pg_mask=0"
-TOOLCHAIN_HOST_TASK_append = " ${@bb.utils.contains('INCLUDE_GAMING_COMPONENTS', 'yes', "nativesdk-glslang", "", d)}"
+TOOLCHAIN_HOST_TASK_append = " ${@bb.utils.contains('INCLUDE_VULKAN', 'yes', "nativesdk-glslang", "", d)}"
MACHINEOVERRIDES =. "amd:amdx86:amdgpu:"