aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/mentor-swupdate/recipes-core/glib-networking/glib-networking_%.bbappend1
-rw-r--r--common/mentor-swupdate/recipes-gnome/gdk-pixbuf/gdk-pixbuf_%.bbappend5
-rw-r--r--common/mentor-swupdate/recipes-graphics/ttf-fonts/liberation-fonts_%.bbappend4
-rw-r--r--common/mentor-swupdate/recipes-multimedia/libomxil/libomxil_%.bbappend3
4 files changed, 13 insertions, 0 deletions
diff --git a/common/mentor-swupdate/recipes-core/glib-networking/glib-networking_%.bbappend b/common/mentor-swupdate/recipes-core/glib-networking/glib-networking_%.bbappend
new file mode 100644
index 00000000..c7a551c5
--- /dev/null
+++ b/common/mentor-swupdate/recipes-core/glib-networking/glib-networking_%.bbappend
@@ -0,0 +1 @@
+GIO_MODULE_PACKAGES=""
diff --git a/common/mentor-swupdate/recipes-gnome/gdk-pixbuf/gdk-pixbuf_%.bbappend b/common/mentor-swupdate/recipes-gnome/gdk-pixbuf/gdk-pixbuf_%.bbappend
new file mode 100644
index 00000000..42e2ec29
--- /dev/null
+++ b/common/mentor-swupdate/recipes-gnome/gdk-pixbuf/gdk-pixbuf_%.bbappend
@@ -0,0 +1,5 @@
+python populate_packages_append () {
+ pixbuf_pkgs = d.getVar('PIXBUF_PACKAGES').split()
+ for pkg in pixbuf_pkgs:
+ d.setVar('pkg_postinst_%s' % pkg, '')
+}
diff --git a/common/mentor-swupdate/recipes-graphics/ttf-fonts/liberation-fonts_%.bbappend b/common/mentor-swupdate/recipes-graphics/ttf-fonts/liberation-fonts_%.bbappend
new file mode 100644
index 00000000..2092c17a
--- /dev/null
+++ b/common/mentor-swupdate/recipes-graphics/ttf-fonts/liberation-fonts_%.bbappend
@@ -0,0 +1,4 @@
+python add_fontcache_postinsts_append () {
+ for pkg in d.getVar('FONT_PACKAGES').split():
+ d.setVar('pkg_postinst_%s' % pkg, '')
+}
diff --git a/common/mentor-swupdate/recipes-multimedia/libomxil/libomxil_%.bbappend b/common/mentor-swupdate/recipes-multimedia/libomxil/libomxil_%.bbappend
new file mode 100644
index 00000000..d71acdc4
--- /dev/null
+++ b/common/mentor-swupdate/recipes-multimedia/libomxil/libomxil_%.bbappend
@@ -0,0 +1,3 @@
+python () {
+ d.setVar('pkg_postinst_ontarget_libomxil', '')
+}