aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-sato/matchbox-sato_0.1.bb')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
new file mode 100644
index 0000000000..64091bcd7f
--- /dev/null
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Custom MB session files for poky"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-engine-sato"
+PR = "r1"
+
+SRC_URI = "file://etc"
+S = ${WORKDIR}
+
+do_install() {
+ cp -R ${S}/etc ${D}/etc
+ rm -fR ${D}/etc/.svn
+ rm -fR ${D}/etc/matchbox/.svn
+ chmod -R 755 ${D}/etc
+}
+
+pkg_postinst_matchbox-poky () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
+}