aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/cairo/cairo_1.3.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/cairo/cairo_1.3.10.bb')
-rw-r--r--meta/packages/cairo/cairo_1.3.10.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/packages/cairo/cairo_1.3.10.bb b/meta/packages/cairo/cairo_1.3.10.bb
new file mode 100644
index 0000000000..d9454fadcd
--- /dev/null
+++ b/meta/packages/cairo/cairo_1.3.10.bb
@@ -0,0 +1,20 @@
+#This is a development snapshot, so lets hint OE to use the releases
+DEFAULT_PREFERENCE = "-1"
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 libsm libpng fontconfig libxrender"
+DESCRIPTION = "Cairo graphics library"
+LICENSE = "MPL LGPL"
+
+SRC_URI = "http://cairographics.org/snapshots/cairo-${PV}.tar.gz"
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require cairo-fpu.inc
+EXTRA_OECONF += "${@get_cairo_fpu_setting(bb, d)}"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}