summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/libsecret/libsecret_0.20.0.bb')
-rw-r--r--meta/recipes-gnome/libsecret/libsecret_0.20.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb b/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
new file mode 100644
index 00000000000..aa3dfab581d
--- /dev/null
+++ b/meta/recipes-gnome/libsecret/libsecret_0.20.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets"
+DESCRIPTION = "A GObject-based library for accessing the Secret Service API of \
+the freedesktop.org project, a cross-desktop effort to access passwords, \
+tokens and other types of secrets. libsecret provides a convenient wrapper \
+for these methods so consumers do not have to call the low-level DBus methods."
+LICENSE = "LGPLv2.1"
+BUGTRACKER = "https://gitlab.gnome.org/GNOME/libsecret/issues"
+LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
+
+inherit gnomebase gtk-doc vala gobject-introspection manpages
+
+DEPENDS += "glib-2.0 libgcrypt gettext-native"
+
+PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
+
+SRC_URI += " file://0001-secret-file-collection-Rename-internal-functions-to-.patch"
+SRC_URI[archive.md5sum] = "335750caeed47f50496b3b0e6a1875ff"
+SRC_URI[archive.sha256sum] = "f1187370b453106af878e30c284a121ba0c513da8bb4170b329d66e250bdae43"
+
+# http://errors.yoctoproject.org/Errors/Details/20228/
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+ARM_INSTRUCTION_SET_armv6 = "arm"
+
+# vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes
+do_configure_prepend() {
+ rm -f ${S}/build/m4/vapigen.m4
+}