aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/openvas-libraries
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/openvas-libraries')
-rw-r--r--recipes-security/openvas-libraries/files/g_type_init.patch36
-rw-r--r--recipes-security/openvas-libraries/openvas-libraries_6.0.0.bb14
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-security/openvas-libraries/files/g_type_init.patch b/recipes-security/openvas-libraries/files/g_type_init.patch
new file mode 100644
index 0000000..db55057
--- /dev/null
+++ b/recipes-security/openvas-libraries/files/g_type_init.patch
@@ -0,0 +1,36 @@
+From f498503889b8178f165afa66dc33aa8ad8901371 Mon Sep 17 00:00:00 2001
+From: Andrei Dinu <andrei.adrianx.dinu@intel.com>
+Date: Fri, 28 Jun 2013 09:38:08 +0300
+Subject: [PATCH] removed the g_type_init()
+
+The function is depricated in glib >= 2.35.0 and is
+automatically called.
+
+Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
+---
+ base/openvas_file.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/base/openvas_file.c b/base/openvas_file.c
+index 8597198..d110c7f 100644
+--- a/base/openvas_file.c
++++ b/base/openvas_file.c
+@@ -164,7 +164,6 @@ openvas_file_copy (const gchar *source_file, const gchar *dest_file)
+ GFile *sfile, *dfile;
+ GError *error;
+
+- g_type_init ();
+ sfile = g_file_new_for_path (source_file);
+ dfile = g_file_new_for_path (dest_file);
+ error = NULL;
+@@ -200,7 +199,6 @@ openvas_file_move (const gchar *source_file, const gchar *dest_file)
+ GFile *sfile, *dfile;
+ GError *error;
+
+- g_type_init ();
+ sfile = g_file_new_for_path (source_file);
+ dfile = g_file_new_for_path (dest_file);
+ error = NULL;
+--
+1.7.9.5
+
diff --git a/recipes-security/openvas-libraries/openvas-libraries_6.0.0.bb b/recipes-security/openvas-libraries/openvas-libraries_6.0.0.bb
new file mode 100644
index 0000000..caf96f1
--- /dev/null
+++ b/recipes-security/openvas-libraries/openvas-libraries_6.0.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "This is the libraries module for the Open Vulnerability Assessment System (OpenVAS)."
+SECTION = "security"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+DEPENDS = "bison flex gpgme glib-2.0"
+
+SRC_URI = "http://wald.intevation.org/frs/download.php/1303/${PN}-${PV}.tar.gz \
+ file://g_type_init.patch"
+
+SRC_URI[md5sum] = "0e8b73ee4ad5b36984b5d7be5d6bdfc0"
+SRC_URI[sha256sum] = "50d23afd46f7b49c4cb82a6500b0fe1fb53378af5efce95fd275ea33c879e1dd"
+
+inherit cmake pkgconfig