aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/nmap
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/nmap')
-rw-r--r--recipes-security/nmap/files/lua.patch79
-rw-r--r--recipes-security/nmap/nmap_6.25.bb21
2 files changed, 100 insertions, 0 deletions
diff --git a/recipes-security/nmap/files/lua.patch b/recipes-security/nmap/files/lua.patch
new file mode 100644
index 0000000..7cb86ab
--- /dev/null
+++ b/recipes-security/nmap/files/lua.patch
@@ -0,0 +1,79 @@
+Added missing definitions which caused failuire at do_configure
+with --without-liblua option.
+
+Upstream Status : pending
+
+Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
+--- a/output.h
++++ b/output.h
+@@ -226,6 +226,10 @@
+ void printscriptresults(ScriptResults *scriptResults, stype scantype);
+
+ void printhostscriptresults(Target *currenths);
++
++/*This is a helper function to determine the ordering of the script results
++ based on their id */
++bool comparescriptids(ScriptResult first, ScriptResult second);
+ #endif
+
+ /* Print a table with traceroute hops. */
+@@ -253,8 +257,4 @@
+ were found. */
+ void printdatafilepaths();
+
+-/*This is a helper function to determine the ordering of the script results
+- based on their id */
+-bool comparescriptids(ScriptResult first, ScriptResult second);
+-
+ #endif /* OUTPUT_H */
+--- a/output.cc
++++ b/output.cc
+@@ -2613,6 +2613,7 @@
+ }
+ }
+
++#ifndef NOLUA
+ /*This is a helper function to determine the ordering of the script results
+ based on their id */
+ bool comparescriptids(ScriptResult first, ScriptResult second){
+@@ -2625,5 +2626,6 @@
+ else
+ return false;
+ }
++#endif
+
+
+--- a/portlist.cc
++++ b/portlist.cc
+@@ -144,6 +144,7 @@
+ }
+ }
+
++#ifndef NOLUA
+ void Port::freeScriptResults(void)
+ {
+ while (!scriptResults.empty()) {
+@@ -151,6 +152,7 @@
+ scriptResults.pop_front();
+ }
+ }
++#endif
+
+ /* Fills in namebuf (as long as there is space in buflen) with the
+ Name nmap normal output will use to describe the port. This takes
+--- a/Target.cc
++++ b/Target.cc
+@@ -162,10 +162,12 @@
+
+ Target::~Target() {
+ FreeInternal();
++#ifndef NOLUA
+ while (!scriptResults.empty()) {
+ scriptResults.front().clear();
+ scriptResults.pop_front();
+ }
++#endif
+ }
+
+ void Target::FreeInternal() {
+
diff --git a/recipes-security/nmap/nmap_6.25.bb b/recipes-security/nmap/nmap_6.25.bb
new file mode 100644
index 0000000..ff0caa7
--- /dev/null
+++ b/recipes-security/nmap/nmap_6.25.bb
@@ -0,0 +1,21 @@
+SUMMARY = "network auditing tool"
+DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing."
+SECTION = "security"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "http://nmap.org/dist/${PN}-${PV}.tar.bz2 \
+ file://lua.patch"
+
+SRC_URI[md5sum] = "fcc80f94ff3adcb11eedf91092ea6f5e"
+SRC_URI[sha256sum] = "3349cc6d36b86b95ca2b8075d16615a3a598cef494920d6652f9a8bf9f7660b5"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-liblua --without-zenmap"
+
+do_configure() {
+ autoconf
+ oe_runconf
+}
+