aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/rockchip-gpt-img.bbclass1
-rw-r--r--conf/machine/tinker-rk3288.conf10
-rw-r--r--recipes-kernel/linux/linux_4.12.bb2
3 files changed, 12 insertions, 1 deletions
diff --git a/classes/rockchip-gpt-img.bbclass b/classes/rockchip-gpt-img.bbclass
index cb09935..458c214 100644
--- a/classes/rockchip-gpt-img.bbclass
+++ b/classes/rockchip-gpt-img.bbclass
@@ -20,6 +20,7 @@ MINILOADER = "loader.bin"
UBOOT = "u-boot.out"
TRUST = "trust.out"
GPTIMG_APPEND ?= "console=tty1 console=ttyS2,115200n8 rw root=/dev/mmcblk2p7 rootfstype=ext4 init=/sbin/init"
+GPTIMG_APPEND_tinker-rk3288 = "console=tty1 console=ttyS2,115200n8 rw root=/dev/mmcblk0p7 rootfstype=ext4 init=/sbin/init"
# default partitions [in Sectors]
# More info at http://rockchip.wikidot.com/partitions
diff --git a/conf/machine/tinker-rk3288.conf b/conf/machine/tinker-rk3288.conf
new file mode 100644
index 0000000..e4dea88
--- /dev/null
+++ b/conf/machine/tinker-rk3288.conf
@@ -0,0 +1,10 @@
+# Copyright (C) 2018 Trevor Woerner
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+#@TYPE: Machine
+#@NAME: Tinker RK3288
+#@DESCRIPTION: ASUS Tinker Board is a Raspberry Pi 3 Alternative based on Rockchip RK3288 Processor.
+
+include conf/machine/include/rk3288.inc
+KERNEL_DEVICETREE = "rk3288-tinker.dtb"
+UBOOT_MACHINE = "tinker-rk3288_defconfig"
diff --git a/recipes-kernel/linux/linux_4.12.bb b/recipes-kernel/linux/linux_4.12.bb
index 0eff49b..db8aeae 100644
--- a/recipes-kernel/linux/linux_4.12.bb
+++ b/recipes-kernel/linux/linux_4.12.bb
@@ -15,6 +15,6 @@ PR = "r1"
PV = "${LINUX_VERSION}"
# Include only supported boards for now
-COMPATIBLE_MACHINE = "(radxarock|marsboard-rk3066|firefly-rk3288|rock2-square)"
+COMPATIBLE_MACHINE = "(radxarock|marsboard-rk3066|firefly-rk3288|rock2-square|tinker-rk3288)"
deltask kernel_configme