aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb')
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
new file mode 100644
index 0000000..b0475e6
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
@@ -0,0 +1,18 @@
+SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git;branch=main"
+SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-adafruit-blinka \
+ python3-core \
+"