aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb')
-rw-r--r--recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 3457300..0106ac3 100644
--- a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -5,6 +5,8 @@ COMPATIBLE_MACHINE = "^rpi$"
DEPENDS = "u-boot-mkimage-native"
+INHIBIT_DEFAULT_DEPS = "1"
+
SRC_URI = "file://boot.cmd.in"
do_compile() {
@@ -14,7 +16,7 @@ do_compile() {
mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
}
-inherit deploy
+inherit deploy nopackages
do_deploy() {
install -d ${DEPLOYDIR}