aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/gmp/gmp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/gmp/gmp')
-rw-r--r--recipes-support/gmp/gmp/amd64.patch18
-rw-r--r--recipes-support/gmp/gmp/use-includedir.patch15
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-support/gmp/gmp/amd64.patch b/recipes-support/gmp/gmp/amd64.patch
new file mode 100644
index 0000000..564d12d
--- /dev/null
+++ b/recipes-support/gmp/gmp/amd64.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Pending
+
+Index: gmp-5.0.3/longlong.h
+===================================================================
+--- gmp-5.0.3.orig/longlong.h
++++ gmp-5.0.3/longlong.h
+@@ -994,8 +994,10 @@ extern UWtype __MPN(udiv_qrnnd) _PROTO (
+ count is only an int. */
+ #define count_trailing_zeros(count, x) \
+ do { \
++ UDItype __cbtmp; \
+ ASSERT ((x) != 0); \
+- __asm__ ("bsfq %1,%q0" : "=r" (count) : "rm" ((UDItype)(x))); \
++ __asm__ ("bsfq %1,%0" : "=r" (__cbtmp) : "rm" ((UDItype)(x))); \
++ (count) = __cbtmp; \
+ } while (0)
+ #endif /* x86_64 */
+
diff --git a/recipes-support/gmp/gmp/use-includedir.patch b/recipes-support/gmp/gmp/use-includedir.patch
new file mode 100644
index 0000000..74904a2
--- /dev/null
+++ b/recipes-support/gmp/gmp/use-includedir.patch
@@ -0,0 +1,15 @@
+Upstream-Status: Pending
+
+Index: gmp-4.2.4/Makefile.am
+===================================================================
+--- gmp-4.2.4.orig/Makefile.am 2008-09-10 19:31:27.000000000 +0000
++++ gmp-4.2.4/Makefile.am 2009-07-06 20:19:19.000000000 +0000
+@@ -106,7 +106,7 @@
+ # but anyone knowledgable enough to be playing with exec_prefix will be able
+ # to address that.
+ #
+-includeexecdir = $(exec_prefix)/include
++includeexecdir = $(includedir)
+ include_HEADERS = $(GMPXX_HEADERS_OPTION)
+ nodist_includeexec_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
+ lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION) $(MPBSD_LTLIBRARIES_OPTION)