aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/rhino/rhino_1.7r4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/rhino/rhino_1.7r4.bb')
-rw-r--r--recipes-core/rhino/rhino_1.7r4.bb18
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes-core/rhino/rhino_1.7r4.bb b/recipes-core/rhino/rhino_1.7r4.bb
index 4242005..d645e8a 100644
--- a/recipes-core/rhino/rhino_1.7r4.bb
+++ b/recipes-core/rhino/rhino_1.7r4.bb
@@ -2,7 +2,7 @@ SUMMARY = "Lexical analyzer generator for Java"
LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e2372bdbf22c99279ae4599a13cc458"
-DEPENDS_class-native += "classpath-native"
+DEPENDS:class-native += "classpath-native"
BBCLASSEXTEND = "native"
@@ -10,19 +10,20 @@ PACKAGE_ARCH = "${TUNE_PKGARCH}"
inherit java-library
+SRCREV = "82ffb8f3e09e77e3b1f5782c35b621e7ca742b58"
SRC_URI = "\
- https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \
+ git://github.com/mozilla/rhino;protocol=https;branch=master \
file://rhino \
file://rhino-jsc \
"
-S = "${WORKDIR}/rhino1_7R4"
+S = "${WORKDIR}/git"
PACKAGES = "${JPN} rhino"
-FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
-RDEPENDS_${PN} = "java2-runtime ${JPN}"
-RDEPENDS_${PN}_class-native = ""
+FILES:${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
+RDEPENDS:${PN} = "java2-runtime ${JPN}"
+RDEPENDS:${PN}:class-native = ""
do_compile() {
mkdir -p build
@@ -39,12 +40,9 @@ do_compile() {
fastjar cfm ${JARFILENAME} ${S}/src/manifest -C build .
}
-do_install_append() {
+do_install:append() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
}
-
-SRC_URI[md5sum] = "ad67a3dff135e3a70f0c3528a2d6edf2"
-SRC_URI[sha256sum] = "9eb08f85bbe7c8e0b9eaffb1cf4984b31fb679f3c8a682acc3bb8ac20626c61e"