aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch')
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch b/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
index 8e70cab..711d17b 100644
--- a/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
+++ b/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
@@ -22,10 +22,10 @@ Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
14 files changed, 123 insertions(+), 12 deletions(-)
diff --git a/hotspot/make/Makefile b/hotspot/make/Makefile
-index ad195763b..53b5ea046 100644
+index de2607c71..3054c3fe8 100644
--- a/hotspot/make/Makefile
+++ b/hotspot/make/Makefile
-@@ -525,7 +525,7 @@ $(EXPORT_INCLUDE_DIR)/%: $(SHARK_BUILD_DIR)/../generated/jvmtifiles/%
+@@ -536,7 +536,7 @@ $(EXPORT_INCLUDE_DIR)/%: $(SHARK_BUILD_DIR)/../generated/jvmtifiles/%
# Unix
$(EXPORT_JRE_LIB_ARCH_DIR)/%.$(LIBRARY_SUFFIX): $(SHARK_BUILD_DIR)/%.$(LIBRARY_SUFFIX)
$(install-file)
@@ -79,10 +79,10 @@ index 4707cc96e..a2b297ca0 100644
flow_block(blk, temp_vector, temp_set);
if (failing()) return; // Watch for bailouts.
diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp
-index 98412e1e1..f62731c43 100644
+index df4d56f6f..b1dd335cb 100644
--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp
+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp
-@@ -2392,6 +2392,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
+@@ -2371,6 +2371,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
spe = NULL;
// Must create lots of stuff here, but outside of the SystemDictionary lock.
m = Method::make_method_handle_intrinsic(iid, signature, CHECK_(empty));
@@ -90,7 +90,7 @@ index 98412e1e1..f62731c43 100644
if (!Arguments::is_interpreter_only()) {
// Generate a compiled form of the MH intrinsic.
AdapterHandlerLibrary::create_native_wrapper(m);
-@@ -2401,6 +2402,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
+@@ -2380,6 +2381,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
"out of space in CodeCache for method handle intrinsic", empty);
}
}
@@ -98,7 +98,7 @@ index 98412e1e1..f62731c43 100644
// Now grab the lock. We might have to throw away the new method,
// if a racing thread has managed to install one at the same time.
{
-@@ -2414,9 +2416,11 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
+@@ -2393,9 +2395,11 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
}
assert(spe != NULL && spe->method() != NULL, "");