aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/javasqlite/javasqlite_20150419.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/javasqlite/javasqlite_20150419.bb')
-rw-r--r--recipes-core/javasqlite/javasqlite_20150419.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-core/javasqlite/javasqlite_20150419.bb b/recipes-core/javasqlite/javasqlite_20150419.bb
index 06fbac2..45262e2 100644
--- a/recipes-core/javasqlite/javasqlite_20150419.bb
+++ b/recipes-core/javasqlite/javasqlite_20150419.bb
@@ -5,7 +5,7 @@ This is a Java wrapper including a basic JDBC driver for the SQLite 2/3 \
database engine. It is designed using JNI to interface to the SQLite API. \
That API is wrapped by methods in the SQLite.Database class."
-LICENSE = "BSD"
+LICENSE = "MIT-Modern-Variant"
SECTION = "application"
PR = "r1"
SRC_URI = " \
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "file://license.terms;md5=3da0e50feac5f64f08184584a8cad58a"
inherit autotools-brokensep
DEPENDS += "sqlite3 sqlite3-native icedtea7-native"
-RDEPENDS_${PN} += "sqlite3"
-FILES_${PN} +="/usr/share"
+RDEPENDS:${PN} += "sqlite3"
+FILES:${PN} +="/usr/share"
PARALLEL_MAKE = "-j 1"
@@ -35,13 +35,9 @@ EXTRA_OECONF = " \
EXTRA_OEMAKE = "DESTDIR=${D}"
# This dev package contains an '.so' file used for JNI development
-INSANE_SKIP_${PN}-dev = "dev-elf"
+INSANE_SKIP:${PN}-dev = "dev-elf"
-do_configure_append (){
- cp ${S}/*-libtool ${S}/libtool
-}
-
-do_compile_prepend (){
+do_compile:prepend (){
echo '#!/bin/sh' > ${STAGING_BINDIR_NATIVE}/cc
echo '${BUILD_CC} $@' >> ${STAGING_BINDIR_NATIVE}/cc
chmod a+x ${STAGING_BINDIR_NATIVE}/cc