aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-yocto-ivi/tasks
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-yocto-ivi/tasks')
-rw-r--r--recipes-yocto-ivi/tasks/files/COPYING.MIT34
-rw-r--r--recipes-yocto-ivi/tasks/task-core-boot-genivi.bb45
-rw-r--r--recipes-yocto-ivi/tasks/task-core-p1.bb88
-rw-r--r--recipes-yocto-ivi/tasks/task-core-p2.bb38
-rw-r--r--recipes-yocto-ivi/tasks/task-discovery-core-p1.bb38
-rw-r--r--recipes-yocto-ivi/tasks/task-xserver-ivi.bb32
6 files changed, 160 insertions, 115 deletions
diff --git a/recipes-yocto-ivi/tasks/files/COPYING.MIT b/recipes-yocto-ivi/tasks/files/COPYING.MIT
index ee0ffb9..fb950dc 100644
--- a/recipes-yocto-ivi/tasks/files/COPYING.MIT
+++ b/recipes-yocto-ivi/tasks/files/COPYING.MIT
@@ -1,17 +1,17 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/recipes-yocto-ivi/tasks/task-core-boot-genivi.bb b/recipes-yocto-ivi/tasks/task-core-boot-genivi.bb
new file mode 100644
index 0000000..a7f5be7
--- /dev/null
+++ b/recipes-yocto-ivi/tasks/task-core-boot-genivi.bb
@@ -0,0 +1,45 @@
+# Copyright (C) 2007 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Task for OpenedHand Poky - minimal bootable image"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+DEPENDS = "virtual/kernel"
+ALLOW_EMPTY = "1"
+PR = "r9"
+
+#
+# Set by the machine configuration with packages essential for device bootup
+#
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+
+# Distro can override the following VIRTUAL-RUNTIME providers:
+VIRTUAL-RUNTIME_dev_manager ?= "udev"
+VIRTUAL-RUNTIME_login_manager ?= "tinylogin"
+VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
+VIRTUAL-RUNTIME_initscripts ?= "initscripts"
+VIRTUAL-RUNTIME_keymaps ?= "keymaps"
+
+PACKAGES = "\
+ task-core-boot-genivi \
+ task-core-boot-genivi-dbg \
+ task-core-boot-genivi-dev \
+"
+
+RDEPENDS_task-core-boot-genivi = "\
+ base-files \
+ base-passwd \
+ busybox \
+ ${VIRTUAL-RUNTIME_initscripts} \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
+ netbase \
+ ${VIRTUAL-RUNTIME_login_manager} \
+ ${VIRTUAL-RUNTIME_init_manager} \
+ ${VIRTUAL-RUNTIME_dev_manager} \
+ ${VIRTUAL-RUNTIME_update-alternatives} \
+ ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
+
+RRECOMMENDS_task-core-boot-genivi = "\
+ ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"
diff --git a/recipes-yocto-ivi/tasks/task-core-p1.bb b/recipes-yocto-ivi/tasks/task-core-p1.bb
index 3b4f774..67d9e7e 100644
--- a/recipes-yocto-ivi/tasks/task-core-p1.bb
+++ b/recipes-yocto-ivi/tasks/task-core-p1.bb
@@ -1,44 +1,44 @@
-DESCRIPTION = "P1 packages"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r0"
-
-PACKAGES = "\
- task-core-p1 \
- task-core-p1-dbg \
- task-core-p1-dev \
- "
-
-ALLOW_EMPTY = "1"
-
-RDEPENDS_task-core-p1 = "\
- DLT-daemon \
- alsa-lib \
- alsa-utils \
- bluez4 \
- connman \
- curl \
- dbus \
- dhcp-client \
- ecryptfs-utils \
- eglibc \
- fuse \
- gstreamer \
- gst-plugins-good \
- gst-plugins-base \
- layer-management \
- libusb1 \
- nfs-utils \
- ntp \
- openssl \
- qt4-embedded \
- quota \
- sqlite3 \
- udev \
- usbutils \
- wpa-supplicant \
- "
-
-RRECOMMENDS_${PN} = "\
- task-xserver-ivi \
- "
+DESCRIPTION = "P1 packages"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+PACKAGES = "\
+ task-core-p1 \
+ task-core-p1-dbg \
+ task-core-p1-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-core-p1 = "\
+ DLT-daemon \
+ alsa-lib \
+ alsa-utils \
+ bluez4 \
+ connman \
+ curl \
+ dbus \
+ dhcp-client \
+ ecryptfs-utils \
+ eglibc \
+ fuse \
+ gstreamer \
+ gst-plugins-good \
+ gst-plugins-base \
+ layer-management \
+ libusb1 \
+ nfs-utils \
+ ntp \
+ openssl \
+ qt4-embedded \
+ quota \
+ sqlite3 \
+ udev \
+ usbutils \
+ wpa-supplicant \
+ "
+
+RRECOMMENDS_${PN} = "\
+ task-xserver-ivi \
+ "
diff --git a/recipes-yocto-ivi/tasks/task-core-p2.bb b/recipes-yocto-ivi/tasks/task-core-p2.bb
index bb7e2fe..52057dd 100644
--- a/recipes-yocto-ivi/tasks/task-core-p2.bb
+++ b/recipes-yocto-ivi/tasks/task-core-p2.bb
@@ -1,19 +1,19 @@
-DESCRIPTION = "P2 packages"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r0"
-
-PACKAGES = "\
- task-core-p2 \
- task-core-p2-dbg \
- task-core-p2-dev \
- "
-
-ALLOW_EMPTY = "1"
-
-RDEPENDS_task-core-p2 = "\
- pulseaudio \
- "
-
-
-
+DESCRIPTION = "P2 packages"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+PACKAGES = "\
+ task-core-p2 \
+ task-core-p2-dbg \
+ task-core-p2-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-core-p2 = "\
+ pulseaudio \
+ "
+
+
+
diff --git a/recipes-yocto-ivi/tasks/task-discovery-core-p1.bb b/recipes-yocto-ivi/tasks/task-discovery-core-p1.bb
index 11c325d..41654cd 100644
--- a/recipes-yocto-ivi/tasks/task-discovery-core-p1.bb
+++ b/recipes-yocto-ivi/tasks/task-discovery-core-p1.bb
@@ -1,19 +1,19 @@
-DESCRIPTION = "Discovery P1 packages"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r0"
-
-PACKAGES = "\
- task-discovery-core-p1 \
- task-discovery-core-p1-dbg \
- task-discovery-core-p1-dev \
- "
-
-ALLOW_EMPTY = "1"
-
-RDEPENDS_task-discovery-core-p1 = "\
- AudioManager \
- "
-
-
-
+DESCRIPTION = "Discovery P1 packages"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+PACKAGES = "\
+ task-discovery-core-p1 \
+ task-discovery-core-p1-dbg \
+ task-discovery-core-p1-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-discovery-core-p1 = "\
+ AudioManager \
+ "
+
+
+
diff --git a/recipes-yocto-ivi/tasks/task-xserver-ivi.bb b/recipes-yocto-ivi/tasks/task-xserver-ivi.bb
index a1267c1..ecfddd6 100644
--- a/recipes-yocto-ivi/tasks/task-xserver-ivi.bb
+++ b/recipes-yocto-ivi/tasks/task-xserver-ivi.bb
@@ -1,17 +1,17 @@
-DESCRIPTION = "Task for xserver and GPU drivers"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-inherit task
-
-XSERVER ?= "xserver-xorg \
- xf86-input-evdev \
- xf86-input-mouse \
- xf86-video-fbdev \
- xf86-input-keyboard \
- "
-
-RDEPENDS_${PN} = " \
- ${XSERVER}"
-
+DESCRIPTION = "Task for xserver and GPU drivers"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit task
+
+XSERVER ?= "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard \
+ "
+
+RDEPENDS_${PN} = " \
+ ${XSERVER}"
+
PACKAGE_ARCH = "${MACHINE_ARCH}" \ No newline at end of file