aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-xserver')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf26
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb18
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/X.service11
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend26
4 files changed, 81 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf
new file mode 100644
index 0000000..12170d7
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf
@@ -0,0 +1,26 @@
+
+Section "Device"
+ Identifier "Intel Graphics Driver"
+ Driver "fbdev"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ Option "DPMS"
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Intel Graphics Driver"
+ Monitor "Generic Monitor"
+ DefaultDepth 16
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+EndSection
+
+Section "ServerFlags"
+ Option "DontZap" "0"
+EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
new file mode 100644
index 0000000..cc0b93a
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "X.Org X server configuration file"
+HOMEPAGE = "http://www.x.org"
+SECTION = "x11/base"
+LICENSE = "MIT-X"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r10"
+
+SRC_URI = "file://xorg.conf"
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install () {
+ install -d ${D}/${sysconfdir}/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+}
+
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/X.service b/recipes-graphics/xorg-xserver/xserver-xorg/X.service
new file mode 100644
index 0000000..ba25065
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/X.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Starts the X Server
+
+[Service]
+Type=simple
+KillMode=none
+ExecStartPre=-/bin/rm -rf /var/log/Xorg*
+ExecStart=/usr/bin/X
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..3e90610
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,26 @@
+LIB_DEPS := "${@oe_filter_out('mesa-dri', '${LIB_DEPS}', d)}"
+LIB_DEPS += "virtual/libgl"
+
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+SRC_URI_append = " file://X.service \
+ "
+
+# If we don't have mesa-dri as virtual/gl we deactivate this support in xserver and
+# remove remove xorg-extension-glx from RDEPENDS as we user OPENGLES and EGL
+python () {
+ if ((d.getVar("PREFERRED_PROVIDER_virtual/libgl", True) or "").find("mesa-dri") == -1):
+ extraoeconf = d.getVar("EXTRA_OECONF", True)
+ extraoeconf += " --disable-glx --disable-dri"
+ d.setVar('EXTRA_OECONF', extraoeconf)
+ else:
+ d.setVar('RDEPENDS_xserver-xorg', "xserver-xorg-extension-glx")
+}
+
+do_install_append() {
+ install -d ${D}/lib/systemd/system
+ install -m 0755 ${WORKDIR}/X.service ${D}/lib/systemd/system
+}
+
+FILES_${PN} += "/lib/systemd/system"
+
+WARN_QA = "ldflags useless-rpaths rpaths staticdev"