aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssh
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssh')
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch20
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/sshd10
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/sshd.service16
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys26
4 files changed, 72 insertions, 0 deletions
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch b/recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch
new file mode 100644
index 0000000..663df5c
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch
@@ -0,0 +1,20 @@
+Disable stripping binaries during make install.
+
+Upstream-Status: Inappropriate [configuration]
+
+Build system specific.
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+diff -ur openssh-5.6p1.orig/Makefile.in openssh-5.6p1/Makefile.in
+--- openssh-5.6p1.orig/Makefile.in 2010-05-11 23:51:39.000000000 -0700
++++ openssh-5.6p1/Makefile.in 2010-08-30 16:49:54.000000000 -0700
+@@ -29,7 +29,7 @@
+ RAND_HELPER=$(libexecdir)/ssh-rand-helper
+ PRIVSEP_PATH=@PRIVSEP_PATH@
+ SSH_PRIVSEP_USER=@SSH_PRIVSEP_USER@
+-STRIP_OPT=@STRIP_OPT@
++STRIP_OPT=
+
+ PATHS= -DSSHDIR=\"$(sysconfdir)\" \
+ -D_PATH_SSH_PROGRAM=\"$(SSH_PROGRAM)\" \
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/sshd b/recipes-connectivity/openssh/openssh-5.9p1/sshd
new file mode 100644
index 0000000..b843e37
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/sshd
@@ -0,0 +1,10 @@
+#%PAM-1.0
+
+auth include common-auth
+account required pam_nologin.so
+account include common-account
+password include common-password
+session optional pam_keyinit.so force revoke
+session include common-session
+session required pam_loginuid.so
+
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/sshd.service b/recipes-connectivity/openssh/openssh-5.9p1/sshd.service
new file mode 100644
index 0000000..1f1ca08
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/sshd.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=SSH Secure Shell Service
+After=connman.service
+Requires=connman.service
+
+[Service]
+ExecStartPre=/lib/systemd/scripts/sshdgenkeys
+ExecStart=/usr/sbin/sshd -D
+
+[Install]
+WantedBy=multi-user.target
+
+# Note that this is the service file for running a single SSH server for all
+# incoming connections, suitable only for systems with a large amount of SSH
+# traffic. In almost all other cases it is a better idea to use sshd.socket +
+# sshd@.service.
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys b/recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys
new file mode 100644
index 0000000..61709b1
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# This script
+# generates host keys
+# check /var/run/sshd nad creates it if not already created
+
+
+if ! [ -f /etc/ssh/ssh_host_ecdsa_key ]; then
+ /usr/bin/ssh-keygen -q -t ecdsa -N "" -f /etc/ssh/ssh_host_ecdsa_key || exit 1
+fi
+
+if ! [ -f /etc/ssh/ssh_host_rsa_key ]; then
+ /usr/bin/ssh-keygen -q -t rsa -N "" -f /etc/ssh/ssh_host_rsa_key || exit 1
+fi
+
+if ! [ -f /etc/ssh/ssh_host_dsa_key ]; then
+ /usr/bin/ssh-keygen -q -t dsa -N "" -f /etc/ssh/ssh_host_dsa_key || exit 1
+fi
+
+if [ ! -d /var/run/sshd ]; then
+ mkdir /var/run/sshd || exit 1
+ chmod 0755 /var/run/sshd || exit 1
+fi
+
+# `test' returns non-zero when it fails. Don't let this hold up ExecStart.
+exit 0 \ No newline at end of file