aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-graphics')
-rw-r--r--meta-ivi/recipes-graphics/mesa/mesa_10.%.bbappend2
-rw-r--r--meta-ivi/recipes-graphics/wayland/wayland-ivi-extension/use_sysroot_dir.patch10
-rw-r--r--meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.2.0.bb (renamed from meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.2.0_rc7.bb)5
-rw-r--r--meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.3.0.bb23
-rw-r--r--meta-ivi/recipes-graphics/wayland/weston/0001-Enable-disable-default-virtual-keyboard.patch84
-rw-r--r--meta-ivi/recipes-graphics/wayland/weston/ivi-shell-click-event.patch124
-rw-r--r--meta-ivi/recipes-graphics/wayland/weston_1.5.0.bbappend17
-rw-r--r--meta-ivi/recipes-graphics/xorg-lib/xkeyboard-config_%.bbappend4
8 files changed, 259 insertions, 10 deletions
diff --git a/meta-ivi/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-ivi/recipes-graphics/mesa/mesa_10.%.bbappend
index 9d471e4..2561585 100644
--- a/meta-ivi/recipes-graphics/mesa/mesa_10.%.bbappend
+++ b/meta-ivi/recipes-graphics/mesa/mesa_10.%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG_append = "gallium gallium-egl gallium-llvm"
+PACKAGECONFIG_append = " gallium gallium-egl gallium-llvm"
diff --git a/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension/use_sysroot_dir.patch b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension/use_sysroot_dir.patch
index 8811879..17dbb9e 100644
--- a/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension/use_sysroot_dir.patch
+++ b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension/use_sysroot_dir.patch
@@ -1,13 +1,13 @@
Index: git/weston-ivi-shell/CMakeLists.txt
===================================================================
---- git.orig/weston-ivi-shell/CMakeLists.txt 2014-04-04 00:15:43.000000000 +0300
-+++ git/weston-ivi-shell/CMakeLists.txt 2014-04-04 00:16:20.000000000 +0300
-@@ -44,7 +44,7 @@
+--- git.orig/weston-ivi-shell/CMakeLists.txt
++++ git/weston-ivi-shell/CMakeLists.txt
+@@ -49,7 +49,7 @@ link_directories(
${CAIRO_LIBRARY_DIRS}
${WESTON_LIBRARY_DIRS}
${PIXMAN_LIBRARY_DIRS}
- ${WESTON_LIBDIR}/weston
+ =${WESTON_LIBDIR}/weston
+ ${EGL_LIBRARY_DIRS}
+ ${GLES_LIBRARY_DIRS}
)
-
-
diff --git a/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.2.0_rc7.bb b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.2.0.bb
index 73e5266..fdc7c50 100644
--- a/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.2.0_rc7.bb
+++ b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.2.0.bb
@@ -7,17 +7,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=176cedb32f48dd58f07e0c1c717b3ea4"
DEPENDS = "weston"
-PV = "1.2.0-rc7+git${SRCPV}"
-
SRC_URI = "git://git.projects.genivi.org/wayland-ivi-extension.git \
file://use_sysroot_dir.patch \
file://fix_compositor_include.patch \
"
-SRCREV = "6ee4b2e418bd6c0c9fd21ff7195faff3875da1e8"
+SRCREV = "278437417d1ac0958a800eecfebd2a388d6d9ca7"
S = "${WORKDIR}/git"
inherit cmake autotools
FILES_${PN} += "${libdir}/weston/*"
FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
-
diff --git a/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.3.0.bb b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.3.0.bb
new file mode 100644
index 0000000..c8f9ca8
--- /dev/null
+++ b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.3.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
+BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=176cedb32f48dd58f07e0c1c717b3ea4"
+
+DEPENDS = "weston"
+
+# FIX ME
+# This should be TAG = "${PV}" but yocto doesn't support lightweight tags for now
+# https://bugzilla.yoctoproject.org/show_bug.cgi?id=6881
+TAG = "a4bde3e5a4c21ff7cf28cc027d45d7c63cac2f66"
+SRC_URI = "git://git.projects.genivi.org/${PN}.git;tag=${TAG} \
+ file://use_sysroot_dir.patch \
+ file://fix_compositor_include.patch \
+ "
+S = "${WORKDIR}/git"
+
+inherit cmake autotools
+
+FILES_${PN} += "${libdir}/weston/*"
+FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
diff --git a/meta-ivi/recipes-graphics/wayland/weston/0001-Enable-disable-default-virtual-keyboard.patch b/meta-ivi/recipes-graphics/wayland/weston/0001-Enable-disable-default-virtual-keyboard.patch
new file mode 100644
index 0000000..d6ae6c2
--- /dev/null
+++ b/meta-ivi/recipes-graphics/wayland/weston/0001-Enable-disable-default-virtual-keyboard.patch
@@ -0,0 +1,84 @@
+From 42f5cc1e4436c34dd1c939ff49f403be609f8f1c Mon Sep 17 00:00:00 2001
+From: Imran Zaman <imran.zaman@intel.com>
+Date: Thu, 5 Feb 2015 13:21:44 +0100
+Subject: [PATCH] Enable/disable default virtual keyboard
+
+Adapted from Tizen commit ad9e205ea7fdb859679b63698a931fa127c5523a
+
+<quote>
+Since fullscreen shell does not support virtual keyboard,
+added configure option to enable/disable default virtual
+keyboard. This avoids unnecessary trial of launching vkb
+and hence will improve boot time
+
+Change-Id: I67bdd8ee231d101d6e3747a45968758af42ebc5a
+Bug-Tizen: TC-810
+Signed-off-by: Imran Zaman <imran.zaman@intel.com>
+</quote>
+
+Signed-off-by: Holger Behrens <holger.behrens@windriver.com>
+---
+ configure.ac | 10 ++++++++++
+ src/text-backend.c | 15 ++++++++++++---
+ 2 files changed, 22 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d14ed16..9f898ca 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -456,6 +456,15 @@ if test x$enable_ivi_shell = xyes; then
+ PKG_CHECK_MODULES(IVI_SHELL, [cairo])
+ fi
+
++AC_ARG_ENABLE([default-vkb],
++ [AC_HELP_STRING([--enable-default-vkb],
++ [Enable default virtual keyboard])],
++ [],
++ [enable_default_vkb=yes])
++if test "x$enable_default_vkb" = "xyes"; then
++ AC_DEFINE(HAVE_DEFAULT_VKB, [1], [Enable default virtual keyboard])
++fi
++
+ AC_ARG_ENABLE(wcap-tools, [ --disable-wcap-tools],, enable_wcap_tools=yes)
+ AM_CONDITIONAL(BUILD_WCAP_TOOLS, test x$enable_wcap_tools = xyes)
+ if test x$enable_wcap_tools = xyes; then
+@@ -558,6 +567,7 @@ AC_MSG_RESULT([
+ dbus ${enable_dbus}
+
+ ivi-shell ${enable_ivi_shell}
++ default virtual keyboard ${enable_default_vkb}
+
+ Build wcap utility ${enable_wcap_tools}
+ Build Fullscreen Shell ${enable_fullscreen_shell}
+diff --git a/src/text-backend.c b/src/text-backend.c
+index d6a6f3b..4908b8a 100644
+--- a/src/text-backend.c
++++ b/src/text-backend.c
+@@ -939,12 +939,21 @@ static void
+ text_backend_configuration(struct text_backend *text_backend)
+ {
+ struct weston_config_section *section;
++ char *client = NULL;
++ int ret = -1;
+
+ section = weston_config_get_section(text_backend->compositor->config,
+ "input-method", NULL, NULL);
+- weston_config_section_get_string(section, "path",
+- &text_backend->input_method.path,
+- LIBEXECDIR "/weston-keyboard");
++#if HAVE_DEFAULT_VKB
++ ret = asprintf(&client, "%s/weston-keyboard",
++ weston_config_get_libexec_dir());
++#endif
++ if (ret < 0)
++ client = NULL;
++
++ weston_config_section_get_string(section, "path",
++ &text_backend->input_method.path,
++ client);
+ }
+
+ static void
+--
+2.2.2
+
diff --git a/meta-ivi/recipes-graphics/wayland/weston/ivi-shell-click-event.patch b/meta-ivi/recipes-graphics/wayland/weston/ivi-shell-click-event.patch
new file mode 100644
index 0000000..3921ca9
--- /dev/null
+++ b/meta-ivi/recipes-graphics/wayland/weston/ivi-shell-click-event.patch
@@ -0,0 +1,124 @@
+From ntanibata@jp.adit-jv.com Fri Dec 12 03:56:24 2014
+Received: from mail.windriver.com (147.11.1.11) by ALA-HCA.corp.ad.wrs.com
+ (147.11.189.50) with Microsoft SMTP Server (TLS) id 14.3.174.1; Thu, 11 Dec
+ 2014 18:56:23 -0800
+Received: from mr1.windriver.com (mr1 [192.124.127.25]) by mail.windriver.com
+ (8.14.9/8.14.5) with ESMTP id sBC2uLlr026848 (version=TLSv1/SSLv3
+ cipher=DHE-RSA-AES256-SHA bits=256 verify=OK); Thu, 11 Dec 2014 18:56:22
+ -0800 (PST)
+Received: from esa2.edoxs1.iphmx.com (esa2.edoxs1.iphmx.com [68.232.135.254])
+ by mr1.windriver.com (8.14.9/8.14.9) with ESMTP id sBC2uL7v028404
+ (version=TLSv1/SSLv3 cipher=RC4-SHA bits=128 verify=FAIL); Thu, 11 Dec 2014
+ 18:56:21 -0800
+X-IronPort-Anti-Spam-Filtered: true
+X-IronPort-Anti-Spam-Result: AtUAAKJYilSFwLVOnGdsb2JhbABZg1hYw1aCGwqFbgKBFRYBAQEBAREBAQEBAQYNCQkULoQMAQEBBAECCRsJEAEBLAsBCwQCAQgRBAEBAQoGFwEGAR4JBBoJCAIEEwgMB4gQDsBZhVIBBZFGAQEBAQEBAQEBAQEBAQEBAQEBAQEBEQaPDwEQAgEeBisHBoInTB2BE4Uig3YohEQEgzqBQIFcIoFzgQwNI4ItihODN4QdXwGBAiSBHAEBAQ
+X-IPAS-Result: AtUAAKJYilSFwLVOnGdsb2JhbABZg1hYw1aCGwqFbgKBFRYBAQEBAREBAQEBAQYNCQkULoQMAQEBBAECCRsJEAEBLAsBCwQCAQgRBAEBAQoGFwEGAR4JBBoJCAIEEwgMB4gQDsBZhVIBBZFGAQEBAQEBAQEBAQEBAQEBAQEBAQEBEQaPDwEQAgEeBisHBoInTB2BE4Uig3YohEQEgzqBQIFcIoFzgQwNI4ItihODN4QdXwGBAiSBHAEBAQ
+X-IronPort-AV: E=Sophos;i="5.07,561,1413270000";
+ d="scan'208";a="110097519"
+Received: from ma-dnext03.denso.co.jp ([133.192.181.78]) by
+ esa2.edoxs1.iphmx.com with ESMTP; 11 Dec 2014 18:56:12 -0800
+Received: from guardw2.denso.co.jp (unknown [133.192.24.24]) by
+ ma-dnext03.denso.co.jp (Postfix) with ESMTP id 25D295D02BA; Fri, 12 Dec 2014
+ 11:56:09 +0900 (JST)
+DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=adit-jv.com;
+ s=jpadit-jvmail2011; t=1418352969;
+ bh=AfmD+uPkOMv42mZQfFad+rgrE601l5DmedvTjy11d4c=;
+ h=MIME-Version:Content-Type:Content-Transfer-Encoding:Subject:Date:
+ Message-ID:In-Reply-To:References:From:To:Cc;
+ b=V6gBLvmpZtG28BTmzIocIVwltzkvm1YCiUgCQ+FFRQ6rUVlsPjLbJ7OGQP3Z47xQT
+ BveplQwKTCpnNCHqvvqyCNQcuTWbOBjOpgCzkOQH8163Mi6fHeRsrOIWVwvb5WLLbQ
+ Otpd6b/gvSfgv5uBk3cUQHNeG2aby+iZmdRsaQILqkhv1oUlT7FWBP1hHCLGHpqJL4
+ p4MxHtAqKjQlnDJELSK/8ExdbQJGlDsAc0DNk4RzzwUp4Ff3m3CMwRBmkvtma4UVQh
+ NYbSXaPGDnJcYSg7r9qT5k7K1mbBuoKcz0bNYMtTDUsBOLEirXT0kYWqoFfl+Jaw/q
+ eY6yHT+Z0lw2A==
+Received: by guardw2.denso.co.jp (Postfix, from userid 0) id 15D6E6DF3; Fri,
+ 12 Dec 2014 11:56:09 +0900 (JST)
+Received: from smtp1.denso.co.jp [133.192.24.88] by guardw2 with ESMTP id
+ MAA08496; Fri, 12 Dec 2014 11:56:08 +0900
+Received: from msj2.adit-jv.com ([10.71.113.25]) by smtp01.denso.co.jp (MOS
+ 4.2.4-GA) with ESMTP id CJC78590; Fri, 12 Dec 2014 11:56:07 +0900
+X-MimeOLE: Produced By Microsoft Exchange V6.5
+Content-Class: urn:content-classes:message
+Content-Type: text/plain; charset="iso-8859-1"
+Content-Transfer-Encoding: quoted-printable
+Subject: RE: weston-ivi-shell input method not supported
+Date: Fri, 12 Dec 2014 11:56:06 +0900
+Message-ID: <EC24A990E5DA3D41A67C0F9C755F987BEA7A60@msj2.adit-jv.com>
+In-Reply-To: <0994C93624B9194C867A2AA78BFAA734AD74977C@ALA-MBB.corp.ad.wrs.com>
+X-MS-Has-Attach:
+X-MS-TNEF-Correlator:
+Thread-Topic: weston-ivi-shell input method not supported
+Thread-Index: AdAEo9qzd7B8JvN8SiCG1HHmuOgOQgAps/xQAgi50BAAHfTugAAGiR4wACG0O/AAJFPVgAAfTuMAABx/dYABEnjvXgABCAagAFhzyOA=
+References: <0994C93624B9194C867A2AA78BFAA734AD7327F7@ALA-MBB.corp.ad.wrs.com> <EC24A990E5DA3D41A67C0F9C755F987BE562C8@msj2.adit-jv.com> <0994C93624B9194C867A2AA78BFAA734AD73F017@ALA-MBB.corp.ad.wrs.com> <EC24A990E5DA3D41A67C0F9C755F987BEA73BB@msj2.adit-jv.com> <0994C93624B9194C867A2AA78BFAA734AD73F824@ALA-MBB.corp.ad.wrs.com> <EC24A990E5DA3D41A67C0F9C755F987BEA7445@msj2.adit-jv.com> <547ECC2F.5000201@windriver.com> <EC24A990E5DA3D41A67C0F9C755F987BEA7500@msj2.adit-jv.com>,<54805D89.5010003@windriver.com> <7A688B48FC95D148BFE83E098348BE505CF002FB@ALA-MBA.corp.ad.wrs.com> <0994C93624B9194C867A2AA78BFAA734AD74977C@ALA-MBB.corp.ad.wrs.com>
+From: "Tanibata, Nobuhiko (ADITJ/SWG)" <ntanibata@jp.adit-jv.com>
+To: =?iso-8859-1?Q?Bourcier=2C_Fr=E9d=E9ric?=
+ <Frederic.Bourcier@windriver.com>, "Behrens, Holger"
+ <Holger.Behrens@windriver.com>, "Sarbu, Florin-Ionut (Florin)"
+ <Florin.Sarbu@windriver.com>, "Gherzan, Andrei"
+ <Andrei.Gherzan@windriver.com>
+CC: <genivi-ivi-layer-management@lists.genivi.org>,
+ <philippe.robin@technoveo.com>, "Ishikawa, Tetsuri (ADITJ/SWG)"
+ <tishikawa@jp.adit-jv.com>
+Return-Path: ntanibata@jp.adit-jv.com
+X-MS-Exchange-Organization-AuthSource: ALA-HCA.corp.ad.wrs.com
+X-MS-Exchange-Organization-AuthAs: Anonymous
+MIME-Version: 1.0
+Status: RO
+Content-Length: 10061
+Lines: 284
+
+Hi Frederic-san, Holger-san,
+
+I think I find root cause as result of debug.
+
+For first check, please apply this patch on ivi-shell, branch genivi-1.2.0;=
+ I think you are using now.
+Please forget genivi-1.3.0 in my another mail. Formally we should use 1.3.0=
+ but for demo purpose first fix might be better.
+
+-----------------------------------------------------------------------------------------------
+Subject: [PATCH] Add the processing which has notice of click event from compositor
+
+Signed-off-by: Nobuhiko Tanibata <NOBUHIKO_TANIBATA at xddp.denso.co.jp>
+---
+ ivi-shell/ivi-shell.c | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/ivi-shell/ivi-shell.c b/ivi-shell/ivi-shell.c
+index 468e66a..9238e93 100644
+--- a/ivi-shell/ivi-shell.c
++++ b/ivi-shell/ivi-shell.c
+@@ -413,6 +413,20 @@ surface_configure_notify(struct wl_listener *listener, void *data)
+
+ }
+
++static void
++click_to_activate_binding(struct weston_seat *seat, uint32_t time, uint32_t button,
++ void *data)
++{
++ if (seat->pointer->grab != &seat->pointer->default_grab) {
++ return;
++ }
++ if (seat->pointer->focus == NULL) {
++ return;
++ }
++
++ weston_surface_activate(seat->pointer->focus->surface, seat);
++}
++
+ WL_EXPORT int
+ module_init(struct weston_compositor *compositor,
+ int *argc, char *argv[])
+@@ -479,6 +493,8 @@ module_init(struct weston_compositor *compositor,
+
+ keyboard_key_func = ivi_layout->grab_keyboard_key;
+
++ weston_compositor_add_button_binding(compositor, BTN_LEFT, 0, click_to_activate_binding, shell);
++
+ free(setting.ivi_module);
+ return 0;
+ }
+1.7.11.7
+
+BR,
+Nobuhiko Tanibata
diff --git a/meta-ivi/recipes-graphics/wayland/weston_1.5.0.bbappend b/meta-ivi/recipes-graphics/wayland/weston_1.5.0.bbappend
index 10a417f..52522b0 100644
--- a/meta-ivi/recipes-graphics/wayland/weston_1.5.0.bbappend
+++ b/meta-ivi/recipes-graphics/wayland/weston_1.5.0.bbappend
@@ -40,6 +40,23 @@ SRC_URI_append = " \
"
#
+# [PATCH] Add the processing which has notice of click event from compositor
+# Signed-off-by: Nobuhiko Tanibata <NOBUHIKO_TANIBATA at xddp.denso.co.jp>
+SRC_URI_append = "\
+ file://ivi-shell-click-event.patch \
+ "
+#
+# [PATCH] Enable/disable default virtual keyboard
+# Signed-off-by: Imran Zaman <imran.zaman@intel.com>
+SRC_URI_append = "\
+ file://0001-Enable-disable-default-virtual-keyboard.patch \
+ "
+
+EXTRA_OECONF += "\
+ --disable-default-vkb \
+ "
+
+#
# TO DO
# Remove when bug is fixed: https://bugzilla.yoctoproject.org/show_bug.cgi?id=5968
# Due to a yocto bug, applying patches with something else then quilt fails.
diff --git a/meta-ivi/recipes-graphics/xorg-lib/xkeyboard-config_%.bbappend b/meta-ivi/recipes-graphics/xorg-lib/xkeyboard-config_%.bbappend
new file mode 100644
index 0000000..427e4f6
--- /dev/null
+++ b/meta-ivi/recipes-graphics/xorg-lib/xkeyboard-config_%.bbappend
@@ -0,0 +1,4 @@
+# FIX ME
+# Temporary fix until patch is merged in yocto:
+# http://lists.openembedded.org/pipermail/openembedded-core/2014-November/098774.html
+inherit gettext