aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/common-api
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/common-api')
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch30
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb (renamed from meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p1.bb)6
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch28
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb (renamed from meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6.bb)8
4 files changed, 69 insertions, 3 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch
new file mode 100644
index 0000000..49abf35
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch
@@ -0,0 +1,30 @@
+Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
+issues with automake 1.15.
+
+https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
+https://bugzilla.redhat.com/show_bug.cgi?id=1179182
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=353]
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -4,12 +4,14 @@ AC_INIT([GENIVI IPC Common API DBus C++]
+ [],
+ [CommonAPI-DBus])
+
++AC_CONFIG_AUX_DIR([build-aux])
++AC_CONFIG_HEADERS([build-aux/config.h])
++
+ AC_USE_SYSTEM_EXTENSIONS
+
+ AC_CONFIG_MACRO_DIR([m4])
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+-AC_CONFIG_AUX_DIR([build-aux])
+-AC_CONFIG_HEADERS([build-aux/config.h])
++
+ AC_CONFIG_FILES([
+ Makefile
+ CommonAPI-DBus.pc
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p1.bb b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
index bf91a97..34b3071 100644
--- a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p1.bb
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
@@ -4,7 +4,11 @@ LICENSE = "MPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
BRANCH ?= "maintain/2.1.6"
-SRC_URI = "git://git.projects.genivi.org/ipc/common-api-dbus-runtime.git;protocol=http;branch=${BRANCH};tag=${PV}"
+TAG ?= "${PV}"
+SRC_URI = " \
+ git://git.projects.genivi.org/ipc/common-api-dbus-runtime.git;branch=${BRANCH};tag=${TAG} \
+ file://fix-with-automake-1-15.patch \
+ "
S = "${WORKDIR}/git"
DEPENDS = "common-api2 dbus"
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
new file mode 100644
index 0000000..1c5eaab
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
@@ -0,0 +1,28 @@
+Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
+issues with automake 1.15.
+
+https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
+https://bugzilla.redhat.com/show_bug.cgi?id=1179182
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=352]
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -4,10 +4,12 @@ AC_INIT([GENIVI IPC Common API C++],
+ [],
+ [CommonAPI])
+
+-AC_CONFIG_MACRO_DIR([m4])
+-m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AC_CONFIG_HEADERS([build-aux/config.h])
++
++AC_CONFIG_MACRO_DIR([m4])
++m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
++
+ AC_CONFIG_FILES([
+ Makefile
+ CommonAPI.pc
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6.bb b/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
index b5b43d1..5608bc4 100644
--- a/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6.bb
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
@@ -3,9 +3,13 @@ SECTION = "libs"
LICENSE = "MPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
PROVIDES = "common-api2"
-PR = "r0"
-SRC_URI = "git://git.projects.genivi.org/ipc/common-api-runtime.git;protocol=http;tag=${PV}"
+BRANCH ?= "maintain/2.1.6"
+TAG ?= "${PV}"
+SRC_URI = " \
+ git://git.projects.genivi.org/ipc/common-api-runtime.git;branch=${BRANCH};tag=${TAG} \
+ file://fix-with-automake-1-15.patch \
+ "
S = "${WORKDIR}/git"
CXXFLAGS := "${@oe_filter_out('-fvisibility-inlines-hidden', '${CXXFLAGS}', d)}"