aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg')
-rw-r--r--meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch15
-rw-r--r--meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xorg-CVE-2013-6424.patch31
-rw-r--r--meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch55
3 files changed, 101 insertions, 0 deletions
diff --git a/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch b/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch
new file mode 100644
index 0000000..2f62972
--- /dev/null
+++ b/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/fix_open_max_preprocessor_error.patch
@@ -0,0 +1,15 @@
+Upstream-Status: Pending
+
+Index: git/os/osdep.h
+===================================================================
+--- git.orig/os/osdep.h 2008-10-07 18:38:21.000000000 +0100
++++ git/os/osdep.h 2008-10-07 18:39:36.000000000 +0100
+@@ -92,7 +92,7 @@
+ * like sysconf(_SC_OPEN_MAX) is not supported.
+ */
+
+-#if OPEN_MAX <= 256
++#if 0
+ #define MAXSOCKS (OPEN_MAX - 1)
+ #else
+ #define MAXSOCKS 256
diff --git a/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xorg-CVE-2013-6424.patch b/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xorg-CVE-2013-6424.patch
new file mode 100644
index 0000000..7c61530
--- /dev/null
+++ b/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xorg-CVE-2013-6424.patch
@@ -0,0 +1,31 @@
+This patch comes from:
+http://lists.x.org/archives/xorg-devel/2013-October/037996.html
+
+Upstream-Status: Backport
+
+Signed-off-by: Baogen shang <baogen.shang@windriver.com>
+diff -Naur xorg-server-1.14.0-orig/exa/exa_render.c xorg-server-1.14.0/exa/exa_render.c
+--- xorg-server-1.14.0-orig/exa/exa_render.c 2014-02-27 14:32:38.000000000 +0800
++++ xorg-server-1.14.0/exa/exa_render.c 2014-02-27 15:46:59.000000000 +0800
+@@ -1141,7 +1141,8 @@
+
+ exaPrepareAccess(pPicture->pDrawable, EXA_PREPARE_DEST);
+ for (; ntrap; ntrap--, traps++)
+- (*ps->RasterizeTrapezoid) (pPicture, traps, -bounds.x1, -bounds.y1);
++ if (xTrapezoidValid(traps))
++ (*ps->RasterizeTrapezoid) (pPicture, traps, -bounds.x1, -bounds.y1);
+ exaFinishAccess(pPicture->pDrawable, EXA_PREPARE_DEST);
+
+ xRel = bounds.x1 + xSrc - xDst;
+diff -Naur xorg-server-1.14.0-orig/render/picture.h xorg-server-1.14.0/render/picture.h
+--- xorg-server-1.14.0-orig/render/picture.h 2014-02-27 14:32:26.000000000 +0800
++++ xorg-server-1.14.0/render/picture.h 2014-02-27 15:48:13.000000000 +0800
+@@ -211,7 +211,7 @@
+ /* whether 't' is a well defined not obviously empty trapezoid */
+ #define xTrapezoidValid(t) ((t)->left.p1.y != (t)->left.p2.y && \
+ (t)->right.p1.y != (t)->right.p2.y && \
+- (int) ((t)->bottom - (t)->top) > 0)
++ ((t)->bottom > (t)->top))
+
+ /*
+ * Standard NTSC luminance conversions:
diff --git a/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch b/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch
new file mode 100644
index 0000000..55e0913
--- /dev/null
+++ b/meta-ivi-demo/recipes-graphics/xorg-xserver/xserver-xorg/xshmfence-option.patch
@@ -0,0 +1,55 @@
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+commit 1affe20d5c82befc3b1626e557409dab5343c47b
+Author: Ross Burton <ross.burton@intel.com>
+Date: Mon Jul 7 12:53:35 2014 +0100
+
+ configure.ac: add option for xshmfence
+
+ xshmfence is usable outside of DRI3, and is currently autodetected which isn't
+ good for distributions where deterministic builds are aspired to.
+
+ Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 2daa6be..fd1cf3f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -648,6 +648,7 @@ AC_ARG_ENABLE(kdrive-kbd, AS_HELP_STRING([--enable-kdrive-kbd], [Build kbd d
+ AC_ARG_ENABLE(kdrive-mouse, AS_HELP_STRING([--enable-kdrive-mouse], [Build mouse driver for kdrive (default: auto)]), [KDRIVE_MOUSE=$enableval], [KDRIVE_MOUSE=auto])
+ AC_ARG_ENABLE(kdrive-evdev, AS_HELP_STRING([--enable-kdrive-evdev], [Build evdev driver for kdrive (default: auto)]), [KDRIVE_EVDEV=$enableval], [KDRIVE_EVDEV=auto])
+ AC_ARG_ENABLE(libunwind, AS_HELP_STRING([--enable-libunwind], [Use libunwind for backtracing (default: auto)]), [LIBUNWIND="$enableval"], [LIBUNWIND="auto"])
++AC_ARG_ENABLE(xshmfence, AS_HELP_STRING([--disable-xshmfence], [Disable xshmfence (default: auto)]), [WANT_XSHMFENCE="$enableval"], [WANT_XSHMFENCE="auto"])
+
+
+ dnl chown/chmod to be setuid root as part of build
+@@ -1235,18 +1236,19 @@ esac
+
+ AM_CONDITIONAL(BUSFAULT, test x"$BUSFAULT" = xyes)
+
+-PKG_CHECK_MODULES([XSHMFENCE], $XSHMFENCE,
+- [HAVE_XSHMFENCE=yes], [HAVE_XSHMFENCE=no])
++HAVE_XSHMFENCE=no
++if test "x$WANT_XSHMFENCE" != "xno"; then
++ PKG_CHECK_MODULES([XSHMFENCE], $XSHMFENCE,
++ [HAVE_XSHMFENCE=yes], [HAVE_XSHMFENCE=no])
+
++ if test "$WANT_XSHMFENCE,$HAVE_XSHMFENCE" = "yes,no"; then
++ AC_MSG_ERROR([libxshmfence requested but not found.])
++ fi
++ AC_DEFINE(HAVE_XSHMFENCE, 1, [Have X Shared Memory Fence library])
++ REQUIRED_LIBS="$REQUIRED_LIBS xshmfence"
++fi
+ AM_CONDITIONAL(XSHMFENCE, test "x$HAVE_XSHMFENCE" = xyes)
+
+-case x"$HAVE_XSHMFENCE" in
+- xyes)
+- AC_DEFINE(HAVE_XSHMFENCE, 1, [Have X Shared Memory Fence library])
+- REQUIRED_LIBS="$REQUIRED_LIBS xshmfence"
+- ;;
+-esac
+-
+
+ case "$DRI3,$HAVE_XSHMFENCE" in
+ yes,yes | auto,yes)