aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-bsp')
-rw-r--r--meta-ivi-bsp/recipes-bsp/u-boot/u-boot_2015.01.bbappend (renamed from meta-ivi-bsp/recipes-bsp/u-boot/u-boot_2013.07.bbappend)2
-rw-r--r--meta-ivi-bsp/recipes-graphics/wayland/weston_1.6.0.bbappend (renamed from meta-ivi-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend)2
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg11
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg11
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg13
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend23
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend13
7 files changed, 46 insertions, 29 deletions
diff --git a/meta-ivi-bsp/recipes-bsp/u-boot/u-boot_2013.07.bbappend b/meta-ivi-bsp/recipes-bsp/u-boot/u-boot_2015.01.bbappend
index d33c17d..6becfb8 100644
--- a/meta-ivi-bsp/recipes-bsp/u-boot/u-boot_2013.07.bbappend
+++ b/meta-ivi-bsp/recipes-bsp/u-boot/u-boot_2015.01.bbappend
@@ -2,4 +2,4 @@
FILESEXTRAPATHS_append := ":${THISDIR}/files"
# Patch for removing autostart countdown
-SRC_URI_append_imx53qsb += "file://no_delay.patch"
+SRC_URI_append_imx53qsb = " file://no_delay.patch"
diff --git a/meta-ivi-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend b/meta-ivi-bsp/recipes-graphics/wayland/weston_1.6.0.bbappend
index ce963ea..fb6f3b0 100644
--- a/meta-ivi-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend
+++ b/meta-ivi-bsp/recipes-graphics/wayland/weston_1.6.0.bbappend
@@ -1,4 +1,4 @@
-RDEPENDS_${PN}_append = " libegl-gallium llvm3.3 "
+RDEPENDS_${PN}_append = " llvm3.3 "
EXTRA_OECONF_append_vexpressa9 = "\
--enable-simple-egl-clients \
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg
index a0efded..99c0c4f 100644
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg
@@ -1,4 +1,4 @@
-# Genivi configs
+# GENIVI configs
#additional configs requested by SysInfra EG
CONFIG_MEDIA_SUPPORT=y
@@ -13,7 +13,16 @@ CONFIG_EXPERIMENTAL=y
CONFIG_KEYS=y
CONFIG_CRYPTO=y
CONFIG_ECRYPT_FS=y
+CONFIG_ECRYPT_FS_MESSAGING=y
CONFIG_QUOTA=y
# Bluetooth support
CONFIG_BT=y
+CONFIG_BT_BNEP=y
+CONFIG_BT_HIDP=m
+CONFIG_CRC_ITU_T=m
+
+# Near Field Communication (NFC)
+CONFIG_NFC=y
+CONFIG_NFC_DIGITAL=m
+CONFIG_NFC_SIM=m
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg
index 994e0bc..99c0c4f 100644
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg
@@ -1,4 +1,4 @@
-#Genivi configs
+# GENIVI configs
#additional configs requested by SysInfra EG
CONFIG_MEDIA_SUPPORT=y
@@ -13,7 +13,16 @@ CONFIG_EXPERIMENTAL=y
CONFIG_KEYS=y
CONFIG_CRYPTO=y
CONFIG_ECRYPT_FS=y
+CONFIG_ECRYPT_FS_MESSAGING=y
CONFIG_QUOTA=y
# Bluetooth support
CONFIG_BT=y
+CONFIG_BT_BNEP=y
+CONFIG_BT_HIDP=m
+CONFIG_CRC_ITU_T=m
+
+# Near Field Communication (NFC)
+CONFIG_NFC=y
+CONFIG_NFC_DIGITAL=m
+CONFIG_NFC_SIM=m
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
index 00ce31c..fb81b22 100644
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
@@ -1,4 +1,4 @@
-3# Kernel fragment taken from linaro.org
+# Kernel fragment taken from linaro.org
# http://releases.linaro.org/platform/linaro-n/hwpacks/11.09/
CONFIG_AC97_BUS=y
@@ -826,7 +826,7 @@ CONFIG_ZLIB_DEFLATE=y
CONFIG_ZLIB_INFLATE=y
CONFIG_ZONE_DMA_FLAG=0
-#Genivi configs
+# GENIVI configs
#additional configs requested by SysInfra EG
CONFIG_MEDIA_SUPPORT=y
@@ -843,7 +843,16 @@ CONFIG_EXPERIMENTAL=y
CONFIG_KEYS=y
CONFIG_CRYPTO=y
CONFIG_ECRYPT_FS=y
+CONFIG_ECRYPT_FS_MESSAGING=y
CONFIG_QUOTA=y
# Bluetooth support
CONFIG_BT=y
+ONFIG_BT_BNEP=y
+CONFIG_BT_HIDP=m
+CONFIG_CRC_ITU_T=m
+
+# Near Field Communication (NFC)
+CONFIG_NFC=y
+CONFIG_NFC_DIGITAL=m
+CONFIG_NFC_SIM=m
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 11629d8..0000000
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
-# find defconfig path
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-# Kernel configs
-SRC_URI_append_beagleboard = " \
- file://beagle_qemu.cfg \
- "
-
-SRC_URI_append_vexpressa9 = " \
- file://vexpress_a9.cfg \
- "
-
-SRC_URI_append_qemux86 = " \
- file://qemux86.cfg \
- "
-
-SRC_URI_append_qemux86-64 = " \
- file://qemux86_64.cfg \
- "
-
-KMACHINE_vexpressa9 = "beagleboard"
-SRCREV_machine_vexpressa9 ?= "${AUTOREV}"
-COMPATIBLE_MACHINE_vexpressa9 = "vexpressa9"
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend
new file mode 100644
index 0000000..5fc758d
--- /dev/null
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -0,0 +1,13 @@
+# Find defconfig path
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+# Kernel configs
+SRC_URI_append_beagleboard = " file://beagle_qemu.cfg"
+SRC_URI_append_vexpressa9 = " file://vexpress_a9.cfg"
+SRC_URI_append_qemux86 = " file://qemux86.cfg"
+SRC_URI_append_qemux86-64 = " file://qemux86_64.cfg"
+
+# vexpress-a9 support
+KMACHINE_vexpressa9 = "beagleboard"
+SRCREV_machine_vexpressa9 ?= "${AUTOREV}"
+COMPATIBLE_MACHINE_vexpressa9 = "vexpressa9"