aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/bblayers.conf.sample24
-rw-r--r--conf/distro/include/default-providers-ivi.inc8
-rw-r--r--conf/distro/poky-ivi-systemd.conf (renamed from conf/distro/yocto-ivi-systemd.conf)16
-rw-r--r--conf/layer.conf28
-rw-r--r--conf/machine/vexpressa9.conf82
5 files changed, 79 insertions, 79 deletions
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 6453ed5..3a7aad2 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -1,12 +1,12 @@
-# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
-# changes incompatibly
-LCONF_VERSION = "4"
-
-BBFILES ?= ""
-BBLAYERS = " \
- ##COREBASE##/poky/meta \
- ##COREBASE##/poky/meta-yocto \
- ##COREBASE##/meta-ivi \
- ##COREBASE##/meta-temp \
- ##COREBASE##/meta-systemd \
- "
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "4"
+
+BBFILES ?= ""
+BBLAYERS = " \
+ ##COREBASE##/poky/meta \
+ ##COREBASE##/poky/meta-yocto \
+ ##COREBASE##/meta-ivi \
+ ##COREBASE##/meta-temp \
+ ##COREBASE##/meta-systemd \
+ "
diff --git a/conf/distro/include/default-providers-ivi.inc b/conf/distro/include/default-providers-ivi.inc
index 70f709a..d136143 100644
--- a/conf/distro/include/default-providers-ivi.inc
+++ b/conf/distro/include/default-providers-ivi.inc
@@ -1,4 +1,4 @@
-#
-# Default virtual providers
-#
-PREFERRED_PROVIDER_virtual/arm-oe-linux-gnueabi-depmod ?= "kmod-cross"
+#
+# Default virtual providers
+#
+PREFERRED_PROVIDER_virtual/arm-oe-linux-gnueabi-depmod ?= "kmod-cross"
diff --git a/conf/distro/yocto-ivi-systemd.conf b/conf/distro/poky-ivi-systemd.conf
index 10fc20a..4461a03 100644
--- a/conf/distro/yocto-ivi-systemd.conf
+++ b/conf/distro/poky-ivi-systemd.conf
@@ -1,8 +1,8 @@
-require ${COREBASE}/meta/conf/distro/defaultsetup.conf
-
-VIRTUAL-RUNTIME_init_manager = "systemd"
-VIRTUAL-RUNTIME_initscripts = ""
-
-FILESYSTEM_PERMS_TABLES = "files/yocto-ivi-perms.txt"
-
-include conf/distro/include/default-providers-ivi.inc
+require ${COREBASE}/meta/conf/distro/defaultsetup.conf
+
+VIRTUAL-RUNTIME_init_manager = "systemd"
+VIRTUAL-RUNTIME_initscripts = ""
+
+FILESYSTEM_PERMS_TABLES = "files/yocto-ivi-perms.txt"
+
+include conf/distro/include/default-providers-ivi.inc
diff --git a/conf/layer.conf b/conf/layer.conf
index 91a1857..1a90791 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,14 +1,14 @@
-BBPATH ?= ""
-# We add conf directory to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
-
-# We have a recipes directory containing .bb and .bbappend files, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "ivi"
-BBFILE_PATTERN_ivi := "^${LAYERDIR}/"
-BBFILE_PRIORITY_ivi = "7"
-
-# Define a similar VARIABLE to COREBASE in order to get a reference to
-# top directory easily
-IVI_COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'
+BBPATH ?= ""
+# We add conf directory to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a recipes directory containing .bb and .bbappend files, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "ivi"
+BBFILE_PATTERN_ivi := "^${LAYERDIR}/"
+BBFILE_PRIORITY_ivi = "7"
+
+# Define a similar VARIABLE to COREBASE in order to get a reference to
+# top directory easily
+IVI_COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'
diff --git a/conf/machine/vexpressa9.conf b/conf/machine/vexpressa9.conf
index 930687b..a2636ce 100644
--- a/conf/machine/vexpressa9.conf
+++ b/conf/machine/vexpressa9.conf
@@ -1,41 +1,41 @@
-#@TYPE: Machine
-#@NAME: vexpress-a9 machine
-#@DESCRIPTION: Machine configuration for the vexpress a9 board
-
-PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
-XSERVER = "xserver-xorg \
- xserver-xf86-config \
- xf86-input-evdev \
- xf86-input-mouse \
- xf86-video-fbdev \
- xf86-input-keyboard"
-
-# Ship all kernel modules by default
-MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
-
-# Allow for MMC booting (required by the NAND-less)
-EXTRA_IMAGEDEPENDS += ""
-
-# Uncomment the following line to enable the hard floating point abi. Note that
-# this breaks some binary libraries and 3D (neither of which ship with
-# meta-yocto). For maximum compatibility, leave this disabled.
-#DEFAULTTUNE ?= "cortexa8hf-neon"
-include conf/machine/include/tune-cortexa9.inc
-
-IMAGE_FSTYPES += "tar.bz2 jffs2"
-EXTRA_IMAGECMD_jffs2 = "-lnp "
-
-# 2.6.37 and later kernels use OMAP_SERIAL, ttyO2
-# earlier kernels use ttyS2
-SERIAL_CONSOLE = "115200 ttyO2"
-
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
-PREFERRED_VERSION_linux-yocto ?= "3.0%"
-
-KERNEL_IMAGETYPE = "uImage"
-
-UBOOT_MACHINE = "ca9x4_ct_vxp_config"
-UBOOT_ENTRYPOINT = "0x80008000"
-UBOOT_LOADADDRESS = "0x80008000"
-
-MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat alsa"
+#@TYPE: Machine
+#@NAME: vexpress-a9 machine
+#@DESCRIPTION: Machine configuration for the vexpress a9 board
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
+XSERVER = "xserver-xorg \
+ xserver-xf86-config \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard"
+
+# Ship all kernel modules by default
+MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
+
+# Allow for MMC booting (required by the NAND-less)
+EXTRA_IMAGEDEPENDS += ""
+
+# Uncomment the following line to enable the hard floating point abi. Note that
+# this breaks some binary libraries and 3D (neither of which ship with
+# meta-yocto). For maximum compatibility, leave this disabled.
+#DEFAULTTUNE ?= "cortexa8hf-neon"
+include conf/machine/include/tune-cortexa9.inc
+
+IMAGE_FSTYPES += "tar.bz2 jffs2"
+EXTRA_IMAGECMD_jffs2 = "-lnp "
+
+# 2.6.37 and later kernels use OMAP_SERIAL, ttyO2
+# earlier kernels use ttyS2
+SERIAL_CONSOLE = "115200 ttyO2"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "3.0%"
+
+KERNEL_IMAGETYPE = "uImage"
+
+UBOOT_MACHINE = "ca9x4_ct_vxp_config"
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat alsa"