aboutsummaryrefslogtreecommitdiffstats
path: root/meta-nuc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nuc')
-rw-r--r--meta-nuc/COPYING.MIT17
-rw-r--r--meta-nuc/README156
-rw-r--r--meta-nuc/README.sources17
-rw-r--r--meta-nuc/conf/layer.conf10
-rw-r--r--meta-nuc/conf/machine/nuc.conf27
-rw-r--r--meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf24
-rw-r--r--meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig3
-rw-r--r--meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh28
-rw-r--r--meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend10
11 files changed, 0 insertions, 294 deletions
diff --git a/meta-nuc/COPYING.MIT b/meta-nuc/COPYING.MIT
deleted file mode 100644
index 89de3547..00000000
--- a/meta-nuc/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/meta-nuc/README b/meta-nuc/README
deleted file mode 100644
index 20b53f0f..00000000
--- a/meta-nuc/README
+++ /dev/null
@@ -1,156 +0,0 @@
-This README file contains information on building the meta-nuc
-BSP layer, and booting the images contained in the /binary directory.
-Please see the corresponding sections below for details.
-
-This BSP is made specifically for "Next Unit of Computing Kit DC3217IYE"
-with Intel Centrino Advanced-N 6235 Wireless mini PCI Express card.
-
-Further information on this NUC platform can be found here:
-
- http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-boards-d33217gke-dc3217iye.html
-
-Information on all IntelĀ® embedded platforms can be found here:
-
- http://www.intel.com/p/en_US/embedded/hwsw/hardware
-
-
-Yocto Project Compatible
-========================
-
-This BSP is compatible with the Yocto Project as per the requirements
-listed here:
-
- https://www.yoctoproject.org/webform/yocto-project-compatible-registration
-
-
-Dependencies
-============
-
-This layer depends on:
-
- URI: git://git.openembedded.org/bitbake
- branch: master
-
- URI: git://git.openembedded.org/openembedded-core
- layers: meta
- branch: master
-
- URI: git://git.yoctoproject.org/meta-intel
- layers: intel
- branch: master
-
-
-Patches
-=======
-
-Please submit any patches against this BSP to the meta-intel mailing list
-(meta-intel@yoctoproject.org) and cc: the maintainer:
-
-Maintainer: Nitin A Kamble <nitin.a.kamble@intel.com>
-
-Please see the meta-intel/MAINTAINERS file for more details.
-
-
-Table of Contents
-=================
-
- I. Building the meta-nuc BSP layer
- II. Booting the images in /binary
-
-
-I. Building the meta-nuc BSP layer
-=========================================
-
-In order to build an image with BSP support for a given release, you
-need to download the corresponding BSP tarball from the 'Board Support
-Package (BSP) Downloads' page of the Yocto Project website.
-
-Having done that, and assuming you extracted the BSP tarball contents
-at the top-level of your yocto build tree, you can build a nuc
-image by adding the location of the meta-nuc layer to
-bblayers.conf, along with the meta-intel layer itself (to access
-common metadata shared between BSPs) e.g.:
-
- yocto/meta-intel \
- yocto/meta-intel/meta-nuc \
-
-To enable the nuc layer, add the nuc MACHINE to local.conf:
-
- MACHINE ?= "nuc"
-
-You should then be able to build a nuc image as such:
-
- $ source oe-init-build-env
- $ bitbake core-image-sato
-
-At the end of a successful build, you should have a live image that
-you can boot from a USB flash drive (see instructions on how to do
-that below, in the section 'Booting the images from /binary').
-
-NOTE: The 'nuc' machine will include support for hardware video
-acceleration via gstreamer if and only if the "commercial" string is
-added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
-
-For example:
-
- LICENSE_FLAGS_WHITELIST = "commercial"
-
-The reason this is needed is to prevent the image from including
-anything that might violate the license terms of the packages used to
-implement the the video acceleration feature, such as gst-ffmpeg and
-ffmpeg. As always, please consult the licenses included in the
-specific packages for details if you use packages that require
-particular LICENSE_FLAGS.
-
-The xf86-video-intel recipe depends on Xorg's dri and glx modules,
-which are built only when 'opengl' is listed in DISTRO_FEATURES. So
-if the distro doesn't list 'opengl' in the DISTRO_FEATURES, then you
-would need this additional line in your local.conf:
-
- DISTRO_FEATURES_append = " opengl"
-
-As an alternative to downloading the BSP tarball, you can also work
-directly from the meta-intel git repository. For each BSP in the
-'meta-intel' repository, there are multiple branches, one
-corresponding to each major release starting with 'laverne' (0.90), in
-addition to the latest code which tracks the current master (note that
-not all BSPs are present in every release). Instead of extracting a
-BSP tarball at the top level of your yocto build tree, you can
-equivalently check out the appropriate branch from the meta-intel
-repository at the same location.
-
-
-II. Booting the images in /binary
-=================================
-
-This BSP contains bootable live images, which can be used to directly
-boot Yocto off of a USB flash drive.
-
-Under Linux, insert a USB flash drive. Assuming the USB flash drive
-takes device /dev/sdf, use dd to copy the live image to it. For
-example:
-
-# dd if=core-image-sato-nuc.hddimg of=/dev/sdf
-# sync
-# eject /dev/sdf
-
-This should give you a bootable USB flash device. Insert the device
-into a bootable USB socket on the target, and power on. This should
-result in a system booted to the Sato graphical desktop.
-
-If you want a terminal, use the arrows at the top of the UI to move to
-different pages of available applications, one of which is named
-'Terminal'. Clicking that should give you a root terminal.
-
-If you want to ssh into the system, you can use the root terminal to
-ifconfig the IP address and use that to ssh in. The root password is
-empty, so to log in type 'root' for the user name and hit 'Enter' at
-the Password prompt: and you should be in.
-
-----
-
-If you find you're getting corrupt images on the USB (it doesn't show
-the syslinux boot: prompt, or the boot: prompt contains strange
-characters), try doing this first:
-
-# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-nuc/README.sources b/meta-nuc/README.sources
deleted file mode 100644
index 0d4d849a..00000000
--- a/meta-nuc/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
-The sources for the packages comprising the images shipped with this
-BSP can be found at the following location:
-
-http://downloads.yoctoproject.org/mirror/sources/
-
-The metadata used to generate the images shipped with this BSP, in
-addition to the code contained in this BSP, can be found at the
-following location:
-
-http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
-
-The metadata used to generate the images shipped with this BSP, in
-addition to the code contained in this BSP, can also be found at the
-following locations:
-
-git://git.yoctoproject.org/poky.git
-git://git.yoctoproject.org/meta-intel
diff --git a/meta-nuc/conf/layer.conf b/meta-nuc/conf/layer.conf
deleted file mode 100644
index 174411ff..00000000
--- a/meta-nuc/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "nuc"
-BBFILE_PATTERN_nuc := "^${LAYERDIR}/"
-BBFILE_PRIORITY_nuc = "6"
diff --git a/meta-nuc/conf/machine/nuc.conf b/meta-nuc/conf/machine/nuc.conf
deleted file mode 100644
index bdc4bca1..00000000
--- a/meta-nuc/conf/machine/nuc.conf
+++ /dev/null
@@ -1,27 +0,0 @@
-#@TYPE: Machine
-#@NAME: chiefriver
-
-#@WEBTITLE: Intel Next Unit of Computing (NUC) Model: DC3217IYE
-
-#@DESCRIPTION: Machine configuration for Intel NUC model DC3217IYE
-# i.e. Ivy Bridge + Panther Point
-
-PREFERRED_VERSION_linux-yocto ?= "3.19%"
-MACHINE_FEATURES += "va-impl-intel wifi efi"
-MACHINE_FEATURES += "intel-ucode"
-
-require conf/machine/include/meta-intel.inc
-require conf/machine/include/intel-corei7-64-common.inc
-require conf/machine/include/intel-common-pkgarch.inc
-
-MACHINE_HWCODECS ?= "va-intel gstreamer-vaapi-1.0"
-
-XSERVER ?= "${XSERVER_X86_BASE} \
- ${XSERVER_X86_EXT} \
- ${XSERVER_X86_I965} \
- "
-
-MACHINE_EXTRA_RRECOMMENDS += "linux-firmware-iwlwifi-6000g2b-6 lms8"
-
-# disable the serial port configuration
-SERIAL_CONSOLE = ""
diff --git a/meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf b/meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf
deleted file mode 100644
index 1defe77d..00000000
--- a/meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf
+++ /dev/null
@@ -1,24 +0,0 @@
-pcm.!default {
- type plug
- slave.pcm "dmixer"
-}
-
-pcm.dmixer {
- type dmix
- ipc_key 1024
- ipc_key_add_uid 0
- ipc_perm 0666
- slave {
- pcm "hw:0,3" # HDMI CARD AND DEVICE
- period_time 0
- period_size 1024
- buffer_size 8192
- rate 48000 #or 44100
- }
-}
-
-ctl.dmixer {
- type hw
- card 0
-}
-
diff --git a/meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig b/meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
-# Assume a USB mouse and keyboard are connected
-HAVE_TOUCHSCREEN=0
-HAVE_KEYBOARD=1
diff --git a/meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh b/meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh
deleted file mode 100644
index 69d8a53f..00000000
--- a/meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides:
-# Required-Start:
-# Required-Stop:
-# Default-Start: S
-# Default-Stop:
-# Short-Description: Configure ALSA audio output to the connected HDMI port
-### END INIT INFO
-
-#
-# If both HDMI ports are connected then use HDMI0 for default ALSA audio out..
-
-ALSA_CONF_FILE="/etc/asound.conf"
-
-HDMI0_STATUS_FILE="/sys/class/drm/card0-HDMI-A-1/status"
-HDMI1_STATUS_FILE="/sys/class/drm/card0-HDMI-A-2/status"
-
-HDMI0_ALSA_CONF="hw:0,3"
-HDMI1_ALSA_CONF="hw:0,7"
-
-if [ -f "${HDMI0_STATUS_FILE}" ] && [ "`cat ${HDMI0_STATUS_FILE}`" == "connected" ]
-then
- sed -i "s/pcm *\"hw:[0-9]*,[0-9]*\"/pcm \"${HDMI0_ALSA_CONF}\"/" ${ALSA_CONF_FILE}
-elif [ -f "${HDMI1_STATUS_FILE}" ] && [ "`cat ${HDMI1_STATUS_FILE}`" == "connected" ]
-then
- sed -i "s/pcm \"hw:[0-9]*,[0-9]*\"/pcm \"${HDMI1_ALSA_CONF}\"/" ${ALSA_CONF_FILE}
-fi
diff --git a/meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend b/meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend
deleted file mode 100644
index abc5fe01..00000000
--- a/meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://hdmi_port_audio.sh"
-
-PR .= ".1"
-
-do_install_append() {
- install -m 0755 ${WORKDIR}/hdmi_port_audio.sh ${D}${sysconfdir}/init.d
- ln -sf ../init.d/hdmi_port_audio.sh ${D}${sysconfdir}/rcS.d/S66hdmi_port_audio.sh
-}