aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2011.0.0.0.diff30
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2011.0.0.0.bb37
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/librealsense/librealsense_2.33.1.bb30
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb131
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch383
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest13
6 files changed, 624 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2011.0.0.0.diff b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2011.0.0.0.diff
new file mode 100644
index 00000000..e000a160
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2011.0.0.0.diff
@@ -0,0 +1,30 @@
+From ec7d732a6a23e90be34840b0f1a57e5199d393cf Mon Sep 17 00:00:00 2001
+From: Alexander Usyskin <alexander.usyskin@intel.com>
+Date: Mon, 17 Jun 2019 13:27:33 +0300
+Subject: [PATCH] lms: drop rpath definitions
+
+Yocto fail to compile with this definitions.
+
+Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Alexander Usyskin <alexander.usyskin@intel.com>
+---
+ CMakeLists.txt | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e22ff05..14d5dd1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -112,9 +112,6 @@ install (DIRECTORY Docs/Licenses
+ FILES_MATCHING PATTERN "LICENSE.*"
+ )
+
+-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/UNS/GMS_COMMON")
+-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/WsmanClient")
+-
+ if (BUILD_TESTS)
+ include (gtest.cmake)
+ endif (BUILD_TESTS)
+--
+2.7.4
+
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2011.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2011.0.0.0.bb
new file mode 100644
index 00000000..d5793500
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2011.0.0.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Intel(R) Local Managability Service"
+DESCRIPTION = "Intel Local Manageability Service allows applications \
+to access the Intel Active Management Technology (AMT) firmware via \
+the Intel Management Engine Interface (MEI)."
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
+
+COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
+COMPATIBLE_HOST_libc-musl = "null"
+
+inherit cmake systemd
+
+DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman"
+
+EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
+
+REQUIRED_DISTRO_FEATURES= "systemd"
+
+FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "lms.service"
+
+SRC_URI = "git://github.com/intel/lms.git"
+SRCREV = "b3e27d4f39f7388a1676d855771e21846e75469c"
+
+SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
+}
+
+RDEPENDS_${PN} += "ace"
diff --git a/dynamic-layers/openembedded-layer/recipes-core/librealsense/librealsense_2.33.1.bb b/dynamic-layers/openembedded-layer/recipes-core/librealsense/librealsense_2.33.1.bb
new file mode 100644
index 00000000..2679f68c
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-core/librealsense/librealsense_2.33.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Intel® RealSense™ SDK"
+HOMEPAGE = "https://www.intelrealsense.com/"
+DESCRIPTION = "Intel® RealSense™ SDK 2.0 is a cross-platform library for \
+Intel® RealSense™ depth cameras (D400 series and the SR300) and the T265 \
+tracking camera"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a1692f06943fa281fd047a22d7e10800"
+SECTION = "lib"
+
+inherit pkgconfig cmake
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/IntelRealSense/librealsense.git"
+SRCREV = "842ee1e1e5c4bb96d63582a7fde061dbc1bebf69"
+
+UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
+
+EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=Release"
+EXTRA_OECMAKE += "-DBUILD_EXAMPLES=true"
+EXTRA_OECMAKE += "-DBUILD_GRAPHICAL_EXAMPLES=${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'true', 'false', d)}"
+EXTRA_OECMAKE += "-DBUILD_WITH_TM2=false"
+EXTRA_OECMAKE += "-DUSE_SYSTEM_LIBUSB=true"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${S}/config/99-realsense-libusb.rules ${D}${sysconfdir}/udev/rules.d/99-${BPN}-libusb.rules
+}
+
+DEPENDS = "udev libusb1"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'libpng libglu glfw gtk+3', '', d)}"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
new file mode 100644
index 00000000..42d223c9
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
@@ -0,0 +1,131 @@
+SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
+HOMEPAGE = "https://github.com/opencv/dldt"
+DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
+deep learning models through a high-level C++ Inference Engine API \
+integrated with application logic."
+
+SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2020 \
+ https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_usb-ma2450_942_R10.15.zip;name=ma2450 \
+ https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_pcie-ma248x_942_R10.15.zip;name=ma248x \
+ https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_usb-ma2x8x_942_R10.15.zip;name=ma2x8x \
+ file://0001-Installation-and-build-fixes.patch \
+ file://run-ptest \
+ "
+
+SRCREV = "b2140c083a068a63591e8c2e9b5f6b240790519d"
+
+SRC_URI[ma2450.sha256sum] = "32747515f0a387a8f878a88670aefe2788132fa24828b3775df791144627d9f6"
+SRC_URI[ma248x.sha256sum] = "f32cd6396d0e6f0e4b24c8ee15e9f0b1b493ebbfc0f03371ca732f75b763d4a2"
+SRC_URI[ma2x8x.sha256sum] = "c00f77692bfdccf92f32233b3dd1189f51dee73c15d79f35a612c7ba841d9c8d"
+
+LICENSE = "Apache-2.0 & ISSL & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
+ file://inference-engine/thirdparty/mkl-dnn/LICENSE;md5=afa44a3d001cc203032135324f9636b7 \
+ file://inference-engine/tests/libs/gtest/googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
+ file://inference-engine/thirdparty/mkl-dnn/src/cpu/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
+ file://inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/LICENSE.txt;md5=88b295a48d2b3244ba65d3c055472c8a \
+"
+LICENSE_${PN}-vpu-firmware = "ISSL"
+
+inherit cmake ptest python3native
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE += " \
+ -DENABLE_OPENCV=0 \
+ -DENABLE_PLUGIN_RPATH=0 \
+ -DENABLE_GNA=0 \
+ -DPYTHON_EXECUTABLE=${PYTHON} \
+ -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
+ -DTHREADING=TBB -DTBB_DIR=${STAGING_LIBDIR} \
+ -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \
+ -DBUILD_GMOCK=1 \
+ -DBUILD_GTEST=0 \
+ -DINSTALL_GMOCK=0 \
+ -DINSTALL_GTEST=0 \
+ -DENABLE_SAMPLES=1 \
+ -DENABLE_NGRAPH=ON \
+ -DENABLE_MKL_DNN=ON \
+ -DIE_CPACK_IE_DIR=${prefix} \
+ "
+
+DEPENDS += "libusb1 \
+ ade \
+ opencv \
+ pugixml \
+ ngraph \
+ tbb \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', 'gflags', '', d)} \
+ "
+
+COMPATIBLE_HOST = '(x86_64).*-linux'
+COMPATIBLE_HOST_libc-musl = "null"
+
+PACKAGECONFIG ?= "vpu"
+PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1 -DCLDNN__IOCL_ICD_INCDIRS=${STAGING_INCDIR} -DCLDNN__IOCL_ICD_STLDIRS=${STAGING_LIBDIR} -DCLDNN__IOCL_ICD_SHLDIRS=${STAGING_LIBDIR}, -DENABLE_CLDNN=0, opencl-icd-loader libva, intel-compute-runtime"
+PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3 python3-numpy python3-opencv python3-progress python3-cython"
+PACKAGECONFIG[vpu] = "-DENABLE_VPU=ON -DVPU_FIRMWARE_USB-MA2450_FILE=../mvnc/usb-ma2450.mvcmd -DVPU_FIRMWARE_USB-MA2X8X_FILE=../mvnc/usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA248X_FILE=../mvnc/pcie-ma248x.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware"
+PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
+
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'vpu', 'true', 'false', d)}; then
+ install -m0644 ${WORKDIR}/mvnc/usb-ma2450.mvcmd ${D}${libdir}/
+ install -m0644 ${WORKDIR}/mvnc/usb-ma2x8x.mvcmd ${D}${libdir}/
+ install -m0644 ${WORKDIR}/mvnc/pcie-ma248x.mvcmd ${D}${libdir}/
+ fi
+
+ if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'true', 'false', d)}; then
+ cp -r ${S}/inference-engine/src/cldnn_engine/cldnn_global_custom_kernels ${D}${libdir}/
+ fi
+
+ if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
+ install -d ${D}${datadir}/inference_engine
+ mv ${D}/usr/samples/python ${D}${datadir}/inference_engine/
+
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ mv ${D}${prefix}/python/${PYTHON_DIR}/openvino ${D}${PYTHON_SITEPACKAGES_DIR}/
+
+ rm -rf ${D}${prefix}/python
+ fi
+
+ # Remove the samples source directory. We install the built samples.
+ rm -rf ${D}/usr/samples
+}
+
+do_install_ptest_base_prepend() {
+ # While not a Makefile based project that strictly falls into the category of
+ # what ptest helps with, adding the unit tests here as ptest would help.
+ # Create a dummy Makefile so installation doesn't fail.
+ touch ${WORKDIR}/Makefile
+ mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/
+ mv ${D}${libdir}/libmock_engine.so ${D}${PTEST_PATH}/
+}
+
+# Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR
+# instead of RSS
+SSTATE_SCAN_FILES_append = " *.cmake"
+
+FILES_${PN}-dev = "${includedir} \
+ ${libdir}/cmake \
+ "
+
+FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
+ ${datadir}/openvino \
+ ${libdir}/cldnn_global_custom_kernels \
+ ${libdir}/custom_kernels \
+ ${libdir}/plugins.xml \
+ ${libdir}/cache.json \
+ "
+
+# Move inference engine samples into a separate package
+PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
+
+FILES_${PN}-samples = "${datadir}/inference_engine \
+ ${bindir} \
+ "
+FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd"
+
+# Package for inference engine python API
+PACKAGES =+ "${PN}-${PYTHON_PN}"
+
+FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch
new file mode 100644
index 00000000..c4c7bd01
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Installation-and-build-fixes.patch
@@ -0,0 +1,383 @@
+From 1c78ff3ff1f77c78a618f7a780985cef1933bb2b Mon Sep 17 00:00:00 2001
+From: Anuj Mittal <anuj.mittal@intel.com>
+Date: Mon, 13 Apr 2020 15:20:28 +0800
+Subject: [PATCH] Installation and build fixes
+
+- Install libs, samples and binaries at appropriate places.
+- Use system installed pugixml, ade, gflags, ngraph, opencl-headers
+and icd-loader.
+- Disable usage of Werror.
+- Use find_library to look for tbb instead of looking for cmake module.
+
+Upstream-Status: Inappropriate [OS-specific]
+
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ CMakeLists.txt | 2 --
+ cmake/developer_package.cmake | 8 +++++---
+ cmake/os_flags.cmake | 1 -
+ inference-engine/CMakeLists.txt | 7 ++-----
+ inference-engine/cmake/ie_parallel.cmake | 10 ++--------
+ .../include/gpu/gpu_ocl_wrapper.hpp | 2 +-
+ inference-engine/samples/CMakeLists.txt | 8 +++-----
+ .../samples/common/format_reader/CMakeLists.txt | 2 ++
+ .../src/cldnn_engine/CMakeLists.txt | 1 +
+ .../src/inference_engine/CMakeLists.txt | 17 +----------------
+ .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
+ .../tests/mock_engine/CMakeLists.txt | 2 ++
+ inference-engine/tests/unit/CMakeLists.txt | 2 ++
+ inference-engine/thirdparty/CMakeLists.txt | 4 +---
+ .../clDNN/CMakeCompilerLinkerOpts.txt | 2 --
+ .../thirdparty/clDNN/CMakeLists.txt | 1 -
+ .../clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
+ .../tools/compile_tool/CMakeLists.txt | 2 +-
+ .../tools/vpu/vpu_compile/CMakeLists.txt | 4 ++--
+ .../tools/vpu/vpu_perfcheck/CMakeLists.txt | 2 +-
+ 20 files changed, 28 insertions(+), 53 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e48cee57..e9598455 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -120,8 +120,6 @@ function(build_ngraph)
+ endif()
+
+ ie_cpack_add_component(ngraph)
+-
+- add_subdirectory(ngraph)
+ endfunction()
+
+ build_ngraph()
+diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
+index e59edb2b..35672cac 100644
+--- a/cmake/developer_package.cmake
++++ b/cmake/developer_package.cmake
+@@ -5,7 +5,9 @@
+ include(CPackComponent)
+ unset(IE_CPACK_COMPONENTS_ALL CACHE)
+
+-set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
++if (NOT DEFINED IE_CPACK_IE_DIR)
++ set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
++endif()
+
+ function(ie_cpack_set_library_dir)
+ string(TOLOWER ${CMAKE_SYSTEM_PROCESSOR} ARCH)
+@@ -18,7 +20,7 @@ function(ie_cpack_set_library_dir)
+ if(WIN32)
+ set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/$<CONFIG>/${ARCH} PARENT_SCOPE)
+ else()
+- set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH} PARENT_SCOPE)
++ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
+ endif()
+ endfunction()
+
+@@ -99,7 +101,7 @@ if(UNIX)
+ SET(LIB_DL ${CMAKE_DL_LIBS})
+ endif()
+
+-set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
++set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
+
+ # Enable postfixes for Debug/Release builds
+ set(IE_DEBUG_POSTFIX_WIN "d")
+diff --git a/cmake/os_flags.cmake b/cmake/os_flags.cmake
+index 6f70768f..40141aca 100644
+--- a/cmake/os_flags.cmake
++++ b/cmake/os_flags.cmake
+@@ -139,7 +139,6 @@ if(WIN32)
+ else()
+ # TODO: enable for C sources as well
+ # ie_add_compiler_flags(-Werror)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ ie_add_compiler_flags(-ffunction-sections -fdata-sections)
+ ie_add_compiler_flags(-fvisibility=hidden)
+ ie_add_compiler_flags(-fdiagnostics-show-option)
+diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
+index d5feedb4..1ee656a1 100644
+--- a/inference-engine/CMakeLists.txt
++++ b/inference-engine/CMakeLists.txt
+@@ -123,12 +123,13 @@ install(FILES samples/CMakeLists.txt
+
+ # install Python samples
+
++if (ENABLE_PYTHON)
+ ie_cpack_add_component(python_samples REQUIRED DEPENDS core)
+
+ install(DIRECTORY ${ie_python_api_SOURCE_DIR}/sample/
+ DESTINATION ${IE_CPACK_IE_DIR}/samples/python
+ COMPONENT python_samples)
+-
++endif()
+ # Custom target to build only Inference Engine Developer Package targets
+
+ add_custom_target(ie_dev_targets ALL DEPENDS inference_engine HeteroPlugin)
+@@ -136,10 +137,6 @@ add_custom_target(ie_dev_targets ALL DEPENDS inference_engine HeteroPlugin)
+ # Developer package
+ ie_developer_export_targets(format_reader)
+
+-if (ENABLE_NGRAPH)
+- ie_developer_export_targets(${NGRAPH_LIBRARIES})
+-endif()
+-
+ export(TARGETS ${IEDeveloperPackageTargets} NAMESPACE IE::
+ APPEND FILE "${CMAKE_BINARY_DIR}/targets_developer.cmake")
+
+diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
+index 9ea885be..71733fd9 100644
+--- a/inference-engine/cmake/ie_parallel.cmake
++++ b/inference-engine/cmake/ie_parallel.cmake
+@@ -42,14 +42,8 @@ function(set_ie_threading_interface_for TARGET_NAME)
+ set(IE_THREAD_DEFINE "IE_THREAD_SEQ")
+
+ if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
+- find_package(TBB COMPONENTS tbb tbbmalloc)
+- if (TBB_FOUND)
+- set(IE_THREAD_DEFINE "IE_THREAD_TBB")
+- ie_target_link_libraries(${TARGET_NAME} PUBLIC ${TBB_IMPORTED_TARGETS})
+- else ()
+- ext_message(WARNING "TBB was not found by the configured TBB_DIR path. \
+- SEQ method will be used for ${TARGET_NAME}")
+- endif ()
++ set(IE_THREAD_DEFINE "IE_THREAD_TBB")
++ target_link_libraries(${TARGET_NAME} PUBLIC tbb tbbmalloc)
+ elseif (THREADING STREQUAL "OMP")
+ if (WIN32)
+ set(omp_lib_name libiomp5md)
+diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
+index fce7d8f1..827e5764 100644
+--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
++++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
+@@ -21,4 +21,4 @@
+ # pragma GCC system_header
+ #endif
+
+-#include <CL/cl2.hpp>
++#include <cl2.hpp>
+diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
+index f355e7b9..d24c7c78 100644
+--- a/inference-engine/samples/CMakeLists.txt
++++ b/inference-engine/samples/CMakeLists.txt
+@@ -24,7 +24,7 @@ endif()
+
+ if(IE_MAIN_SOURCE_DIR)
+ # in case if samples are built from IE repo
+- set(IE_MAIN_SAMPLES_DIR ${OpenVINO_MAIN_SOURCE_DIR})
++ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
+ # hint for find_package(InferenceEngine in the samples folder)
+ set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
+ else()
+@@ -91,10 +91,6 @@ set (HAVE_INTTYPES_H 1)
+ set (INTTYPES_FORMAT C99)
+ set (BUILD_TESTING OFF)
+
+-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
+- add_subdirectory(thirdparty/gflags)
+-endif()
+-
+ if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
+ endif()
+@@ -203,6 +199,8 @@ macro(ie_add_sample)
+ if(COMMAND add_cpplint_target AND NOT IE_SAMPLE_EXCLUDE_CPPLINT)
+ add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME})
+ endif()
++
++ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
+ endmacro()
+
+ # collect all samples subdirectories
+diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
+index 6d935135..fe12eeb7 100644
+--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
++++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
+@@ -40,3 +40,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}/..")
+
+ set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME})
++
++install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
+diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
+index 43344e7f..50beda23 100644
+--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
++++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
+@@ -32,6 +32,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CLDNN__IOCL_ICD_INCDIRS}
+ ${CLDNN_TOP_FOLDER}
++ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
+ ${IE_MAIN_SOURCE_DIR}/thirdparty/pugixml/src)
+
+ # copy default global xml file describing the custom kernels and the *.cl files
+diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
+index 54e264c8..e3809654 100644
+--- a/inference-engine/src/inference_engine/CMakeLists.txt
++++ b/inference-engine/src/inference_engine/CMakeLists.txt
+@@ -292,20 +292,6 @@ if(threading_tbb)
+ ie_cpack_add_component(tbb REQUIRED)
+ list(APPEND core_components tbb)
+
+- install(DIRECTORY "${TBB}/include"
+- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
+- COMPONENT tbb)
+- install(DIRECTORY "${TBB}/lib"
+- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
+- COMPONENT tbb)
+- if(EXISTS "${TBB}/bin")
+- install(DIRECTORY "${TBB}/bin"
+- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
+- COMPONENT tbb)
+- endif()
+- install(FILES "${TBB}/LICENSE"
+- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
+- COMPONENT tbb)
+ endif()
+
+ ie_cpack_add_component(core REQUIRED DEPENDS ${core_components})
+@@ -318,10 +304,9 @@ install(TARGETS ${TARGET_NAME} ${TARGET_NAME}_nn_builder
+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH}
+ COMPONENT core)
+ install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
+- "${OpenVINO_BINARY_DIR}/share/ie_rh_decoder.cmake"
+ "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
+ "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
+- DESTINATION ${IE_CPACK_IE_DIR}/share
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
+ COMPONENT core)
+ install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
+diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
+index 32cb534a..858ffefc 100644
+--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
++++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
+@@ -41,5 +41,5 @@ target_link_libraries(${TARGET_NAME}
+ # install
+
+ install(FILES ${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules
+- DESTINATION deployment_tools/inference_engine/external
++ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
+ COMPONENT myriad)
+diff --git a/inference-engine/tests/mock_engine/CMakeLists.txt b/inference-engine/tests/mock_engine/CMakeLists.txt
+index f3fb53e1..09fb66ce 100644
+--- a/inference-engine/tests/mock_engine/CMakeLists.txt
++++ b/inference-engine/tests/mock_engine/CMakeLists.txt
+@@ -38,3 +38,5 @@ target_compile_definitions(${TARGET_NAME} PRIVATE IMPLEMENT_INFERENCE_ENGINE_PLU
+ set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD 11)
+ set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
+ set_property(TARGET ${TARGET_NAME} PROPERTY COMPILE_PDB_NAME ${TARGET_NAME})
++
++install(TARGETS ${TARGET_NAME} EXPORT ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+diff --git a/inference-engine/tests/unit/CMakeLists.txt b/inference-engine/tests/unit/CMakeLists.txt
+index a5c945ae..eabe70d3 100644
+--- a/inference-engine/tests/unit/CMakeLists.txt
++++ b/inference-engine/tests/unit/CMakeLists.txt
+@@ -187,3 +187,5 @@ add_test(NAME ${TARGET_NAME}
+ COMMAND ${TARGET_NAME})
+
+ add_dependencies(${TARGET_NAME} mock_engine)
++
++install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
+diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
+index ec22761d..3962d924 100644
+--- a/inference-engine/thirdparty/CMakeLists.txt
++++ b/inference-engine/thirdparty/CMakeLists.txt
+@@ -35,14 +35,12 @@ function(build_with_lto)
+ add_subdirectory(clDNN)
+ endif()
+
+- add_subdirectory(pugixml)
+ add_subdirectory(stb_lib)
+- add_subdirectory(ade)
+ add_subdirectory(fluid/modules/gapi)
+
+ # developer package
+
+- ie_developer_export_targets(ade fluid pugixml)
++ ie_developer_export_targets(fluid)
+ if(TARGET pugixml_mt)
+ ie_developer_export_targets(pugixml_mt)
+ endif()
+diff --git a/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt b/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt
+index 6b799cdd..91755b35 100644
+--- a/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt
++++ b/inference-engine/thirdparty/clDNN/CMakeCompilerLinkerOpts.txt
+@@ -206,7 +206,6 @@ elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+ ALIAS RttiDisabled "-fno-rtti"
+ ALIAS RttiEnabled "-frtti"
+ ALIAS TreatWarnAsErrorDisabled TreatWarnAsError REMOVE_GROUP
+- ALIAS TreatWarnAsErrorEnabled "-Werror" "-pedantic-errors"
+ ALIAS WarnLevel0 "-w"
+ ALIAS WarnLevel1 WarnLevels REMOVE_GROUP
+ ALIAS WarnLevel2 "-Wall"
+@@ -290,7 +289,6 @@ elseif((CMAKE_C_COMPILER_ID MATCHES "^Clang$") OR (CMAKE_CXX_COMPILER_ID MATCHES
+ ALIAS RttiDisabled "-fno-rtti"
+ ALIAS RttiEnabled Rtti REMOVE_GROUP
+ ALIAS TreatWarnAsErrorDisabled TreatWarnAsError REMOVE_GROUP
+- ALIAS TreatWarnAsErrorEnabled "-Werror"
+ ALIAS WarnLevel0 "-w"
+ ALIAS WarnLevel1 WarnLevels REMOVE_GROUP
+ ALIAS WarnLevel2 "-Wall"
+diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
+index b08c2744..42ca79e6 100644
+--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
++++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
+@@ -767,7 +767,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
+ MultiProcessorCompilation
+ DeadCodeEliminate
+ ExtensionsEnabled
+- TreatWarnAsErrorEnabled
+ WarnLevel4
+ NoFastMath
+ StackProtector
+diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
+index a9e379bd..8b822223 100644
+--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
++++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
+@@ -30,7 +30,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
+ typedef cl_va_api_device_source_intel cl_device_source_intel;
+ typedef cl_va_api_device_set_intel cl_device_set_intel;
+ #endif
+-#include <CL/cl_intel_planar_yuv.h>
++#include <CL/cl_ext_intel.h>
+
+ namespace cl {
+ typedef CL_API_ENTRY cl_int(CL_API_CALL *PFN_clEnqueueAcquireMediaSurfacesINTEL)(
+diff --git a/inference-engine/tools/compile_tool/CMakeLists.txt b/inference-engine/tools/compile_tool/CMakeLists.txt
+index 25168bac..1c57116f 100644
+--- a/inference-engine/tools/compile_tool/CMakeLists.txt
++++ b/inference-engine/tools/compile_tool/CMakeLists.txt
+@@ -48,5 +48,5 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
+ # install
+
+ install(TARGETS compile_tool
+- RUNTIME DESTINATION ${IE_CPACK_LIBRARY_PATH}
++ RUNTIME DESTINATION bin
+ COMPONENT core)
+diff --git a/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt b/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt
+index 4123de6f..52179fac 100644
+--- a/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt
++++ b/inference-engine/tools/vpu/vpu_compile/CMakeLists.txt
+@@ -50,5 +50,5 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
+ # install
+
+ install(TARGETS ${TARGET_NAME}
+- RUNTIME DESTINATION ${IE_CPACK_LIBRARY_PATH}
+- COMPONENT myriad)
+\ No newline at end of file
++ RUNTIME DESTINATION bin
++ COMPONENT myriad)
+diff --git a/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt b/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt
+index a7a801d4..b8f9e26f 100644
+--- a/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt
++++ b/inference-engine/tools/vpu/vpu_perfcheck/CMakeLists.txt
+@@ -55,6 +55,6 @@ if(ENABLE_MYRIAD)
+ add_perfcheck_target(myriad_perfcheck myriadPlugin)
+
+ install(TARGETS myriad_perfcheck
+- RUNTIME DESTINATION ${IE_CPACK_LIBRARY_PATH}
++ RUNTIME DESTINATION bin
+ COMPONENT myriad)
+ endif()
+--
+2.25.2
+
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
new file mode 100644
index 00000000..92f238a9
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+# InferenceEngineUnitTests requires libmock_engine.so, since they are
+# installed in the same directory we will need to set LD_LIBRARY_PATH
+# so that libmock_engine.so is picked up correctly. We also assume that
+# this script is only execute within the same directory where it is
+# installed.
+
+export LD_LIBRARY_PATH=.
+
+./InferenceEngineUnitTests |sed \
+ -e 's|\[.*OK.*\]\(.*\)|PASS:\1|' \
+ -e 's|\[.*FAILED.*\]\(.*\)|FAIL:\1|'