aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch45
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb1
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-IGA-Add-missing-header.patch26
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch27
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/a58dd6de4c29595a0f93cff167b487d777e4559e.patch46
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch26
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb4
7 files changed, 175 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch
new file mode 100644
index 00000000..5edb52d0
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch
@@ -0,0 +1,45 @@
+From a72b1fe0c571c191d857297114e0393ce017b7ab Mon Sep 17 00:00:00 2001
+From: Mateusz Jablonski <mateusz.jablonski@intel.com>
+Date: Wed, 28 Jul 2021 09:25:56 +0000
+Subject: [PATCH] Add missing includes
+
+Signed-off-by: Florian Minnecker <florian.github@minnecker.com>
+Signed-off-by: Mateusz Jablonski <mateusz.jablonski@intel.com>
+
+Upstream-Status: Backport
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ shared/source/helpers/basic_math.h | 3 ++-
+ shared/source/helpers/registered_method_dispatcher.h | 1 +
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/shared/source/helpers/basic_math.h b/shared/source/helpers/basic_math.h
+index fd62b9e6b..f339677eb 100644
+--- a/shared/source/helpers/basic_math.h
++++ b/shared/source/helpers/basic_math.h
+@@ -11,8 +11,9 @@
+ #include <algorithm>
+ #include <cmath>
+ #include <cstdint>
++#include <cstdio>
+ #include <cstdlib>
+-#include <stdio.h>
++#include <limits>
+
+ #define KB 1024uLL
+ #define MB (KB * KB)
+diff --git a/shared/source/helpers/registered_method_dispatcher.h b/shared/source/helpers/registered_method_dispatcher.h
+index 56f880a16..cd778fad0 100644
+--- a/shared/source/helpers/registered_method_dispatcher.h
++++ b/shared/source/helpers/registered_method_dispatcher.h
+@@ -7,6 +7,7 @@
+
+ #pragma once
+
++#include <cstddef>
+ #include <cstdint>
+ #include <functional>
+
+--
+2.37.3
+
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
index 5525b66a..eb17b642 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
+ file://113cef897712c8b475f668f2bcf77a12db76a90e.patch \
"
SRCREV = "e0633548a9bd025c70bc7f3539eef094b1bc9ce1"
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-IGA-Add-missing-header.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-IGA-Add-missing-header.patch
new file mode 100644
index 00000000..0a4a0fd9
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-IGA-Add-missing-header.patch
@@ -0,0 +1,26 @@
+From a36a4788a52128e5ccbec4cd29eb167153dcc8b8 Mon Sep 17 00:00:00 2001
+From: Diana Chen <po-yu.chen@intel.com>
+Date: Mon, 11 Jan 2021 19:06:36 +0000
+Subject: [PATCH] IGA: Add missing header
+
+Upstream-Status: Backport
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ visa/iga/IGALibrary/IR/SWSBSetter.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/visa/iga/IGALibrary/IR/SWSBSetter.cpp b/visa/iga/IGALibrary/IR/SWSBSetter.cpp
+index 87f119f3b..6956edf0d 100644
+--- a/visa/iga/IGALibrary/IR/SWSBSetter.cpp
++++ b/visa/iga/IGALibrary/IR/SWSBSetter.cpp
+@@ -27,6 +27,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ #include "Traversals.hpp"
+ #include "BitSet.hpp"
+ #include <iterator>
++#include <limits>
+ using namespace iga;
+
+ /**
+--
+2.37.3
+
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch
new file mode 100644
index 00000000..68131584
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch
@@ -0,0 +1,27 @@
+From 79a95322fc5ae21c3380f6455b28b931c98b2d13 Mon Sep 17 00:00:00 2001
+From: Marcin Naczk <marcin.naczk@intel.com>
+Date: Tue, 22 Feb 2022 13:09:54 +0000
+Subject: [PATCH] Upgrade github Action build IGC
+
+- Fix build IGC on Ubuntu 22.04 by adding missing include
+
+Upstream-Status: Backport
+Part of: https://github.com/intel/intel-graphics-compiler/commit/4369c970d4e02258b3c53e854faaa34197124a33
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+
+---
+ visa/iga/IGALibrary/IR/SWSBSetter.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/visa/iga/IGALibrary/IR/SWSBSetter.hpp b/visa/iga/IGALibrary/IR/SWSBSetter.hpp
+index 5a7ad75c0..02d52add2 100644
+--- a/visa/iga/IGALibrary/IR/SWSBSetter.hpp
++++ b/visa/iga/IGALibrary/IR/SWSBSetter.hpp
+@@ -32,6 +32,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ #include "Operand.hpp"
+ #include "../ErrorHandler.hpp"
+ #include "RegDeps.hpp"
++#include <limits>
+
+ namespace iga
+ {
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/a58dd6de4c29595a0f93cff167b487d777e4559e.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/a58dd6de4c29595a0f93cff167b487d777e4559e.patch
new file mode 100644
index 00000000..b88e9678
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/a58dd6de4c29595a0f93cff167b487d777e4559e.patch
@@ -0,0 +1,46 @@
+From a58dd6de4c29595a0f93cff167b487d777e4559e Mon Sep 17 00:00:00 2001
+From: "Szymichowski, Pawel" <pawel.szymichowski@intel.com>
+Date: Wed, 8 Apr 2020 08:24:05 -0700
+Subject: [PATCH] Changes in code.
+
+Change-Id: Ica75407e834f6b3439912bd0b47a6b30a6521fc7
+
+Upstream-Status: Backport
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ visa/iga/IGALibrary/api/igax.hpp | 21 ++++++++++++---------
+ 1 file changed, 12 insertions(+), 9 deletions(-)
+
+diff --git a/visa/iga/IGALibrary/api/igax.hpp b/visa/iga/IGALibrary/api/igax.hpp
+index 4f1c680c6a9..6d17cd99b6a 100644
+--- a/visa/iga/IGALibrary/api/igax.hpp
++++ b/visa/iga/IGALibrary/api/igax.hpp
+@@ -492,16 +492,19 @@ inline iga::Op OpSpec::op() const
+ }
+
+
+-#define IGA_OPSPEC_STRING_GETTER(API, INITSIZE) { \
+- char _staticBuf[INITSIZE]; \
+- char *strPtr = &_staticBuf[0]; \
+- size_t strCap = sizeof(_staticBuf); \
+- IGA_CHECKED_CALL(API, m_op, strPtr, &strCap); \
+- if (strCap > sizeof(_staticBuf)) { \
+- strPtr = (char *)alloca(strCap); \
++#define IGA_OPSPEC_STRING_GETTER(API, INITSIZE) { \
++ char _staticBuf[INITSIZE]; \
++ char *strPtr = &_staticBuf[0]; \
++ size_t strCap = sizeof(_staticBuf); \
++ IGA_CHECKED_CALL(API, m_op, strPtr, &strCap); \
++ if (strCap > sizeof(_staticBuf)) { \
++ strPtr = (char *)malloc(strCap); \
+ IGA_CHECKED_CALL(API, m_op, strPtr, &strCap); \
+- } \
+- return std::string(strPtr); \
++ std::string res(strPtr); \
++ free(strPtr); \
++ return res; \
++ } \
++ return std::string(strPtr); \
+ }
+ inline std::string OpSpec::menmonic() const
+ IGA_OPSPEC_STRING_GETTER(iga_opspec_mnemonic, 16);
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch
new file mode 100644
index 00000000..6efd51bc
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch
@@ -0,0 +1,26 @@
+From 59d5ba1517c48a9e629994917a6e90207df26b08 Mon Sep 17 00:00:00 2001
+From: Bruno Pagani <bruno.n.pagani@gmail.com>
+Date: Mon, 21 Feb 2022 12:32:25 +0000
+Subject: [PATCH] Fix missing include
+
+Same as 6c805b2
+
+Upstream-Status: Backport
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+
+---
+ visa/LocalScheduler/SWSB_G4IR.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/visa/LocalScheduler/SWSB_G4IR.cpp b/visa/LocalScheduler/SWSB_G4IR.cpp
+index 0ef7961a0..bb631117d 100644
+--- a/visa/LocalScheduler/SWSB_G4IR.cpp
++++ b/visa/LocalScheduler/SWSB_G4IR.cpp
+@@ -26,6 +26,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+ #include <fstream>
+ #include <functional>
++#include <limits>
+ #include <sstream>
+ #include "SWSB_G4IR.h"
+ #include "../G4_Opcode.h"
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
index 6cfa0b6d..5474f8a7 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
@@ -9,6 +9,10 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc
SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
file://0001-skip-execution-of-ElfPackager.patch \
+ file://a58dd6de4c29595a0f93cff167b487d777e4559e.patch \
+ file://0001-IGA-Add-missing-header.patch \
+ file://4369c970d4e02258b3c53e854faaa34197124a33.patch \
+ file://fix-header.patch \
"
SRCREV = "577887bf74c51a6084058836720fe58f8c35ca58"