aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch45
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch
new file mode 100644
index 00000000..5edb52d0
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch
@@ -0,0 +1,45 @@
+From a72b1fe0c571c191d857297114e0393ce017b7ab Mon Sep 17 00:00:00 2001
+From: Mateusz Jablonski <mateusz.jablonski@intel.com>
+Date: Wed, 28 Jul 2021 09:25:56 +0000
+Subject: [PATCH] Add missing includes
+
+Signed-off-by: Florian Minnecker <florian.github@minnecker.com>
+Signed-off-by: Mateusz Jablonski <mateusz.jablonski@intel.com>
+
+Upstream-Status: Backport
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ shared/source/helpers/basic_math.h | 3 ++-
+ shared/source/helpers/registered_method_dispatcher.h | 1 +
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/shared/source/helpers/basic_math.h b/shared/source/helpers/basic_math.h
+index fd62b9e6b..f339677eb 100644
+--- a/shared/source/helpers/basic_math.h
++++ b/shared/source/helpers/basic_math.h
+@@ -11,8 +11,9 @@
+ #include <algorithm>
+ #include <cmath>
+ #include <cstdint>
++#include <cstdio>
+ #include <cstdlib>
+-#include <stdio.h>
++#include <limits>
+
+ #define KB 1024uLL
+ #define MB (KB * KB)
+diff --git a/shared/source/helpers/registered_method_dispatcher.h b/shared/source/helpers/registered_method_dispatcher.h
+index 56f880a16..cd778fad0 100644
+--- a/shared/source/helpers/registered_method_dispatcher.h
++++ b/shared/source/helpers/registered_method_dispatcher.h
+@@ -7,6 +7,7 @@
+
+ #pragma once
+
++#include <cstddef>
+ #include <cstdint>
+ #include <functional>
+
+--
+2.37.3
+
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
index 5525b66a..eb17b642 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
+ file://113cef897712c8b475f668f2bcf77a12db76a90e.patch \
"
SRCREV = "e0633548a9bd025c70bc7f3539eef094b1bc9ce1"